Why am I sending MLAT data?


#1

My RPi’s are reporting they are synchronized with 4 or 5 nearby receivers, but FA logs show I haven’t reported an MLAT position/plane in months.

Apart from a technical interest, this doesn’t matter at the moment, but I’m planning on putting a receiver in a remote location (solar powered) where data volume will be metered and cost accordingly.
Obviously there is no point paying to send data that is never used.

So, is there any point sending MLAT data if no position are recorded?


#2

Of the 4 “nearby receivers”, two are your own receivers in essentially the same location. Receivers that are that close to each other don’t actually count as distinct receiver for mlat purposes so you are unlikely to ever see mlat until there is better coverage in your area.

You can disable mlat if the bandwidth etc is an issue via piaware-config or the stats page.


#3

Thanks for the reply Obj. I rather assumed that was the case, but it doesn’t answer my question.

Is MLAT data useful when you (I) have less than ‘enough’ nearby receivers (or is it just noise that gets discarded).

On your point above, what ‘is’ the minimum separation between sites to calculate MLAT positions?

Also, is there anyway (for us users) to know which ‘nearby stations’ we are synchronized with?


#4

It is discarded. It is a bit of a catch-22 as without actually collecting the data we don’t know if there’s enough receiver overlap to produce useful positions.

1km. For receivers closer than this all the timing data is still used but only one receiver from the group is counted towards the minimum required.

No, not currently.


#5

I’ve just noticed an interesting status report.
When I look at the ip:80 address of one of the RPi’s, I see “Radio, PiAware, FlightAware” are all green, but MLAT is now brown (not red).

Mousing over the MLAT patch, brings up:
“Unexpected Multilaterertation Status unknown, please report this”.

I disabled MLAT yesterday, so I would have expected the status to simply be “Disabled”.


#6

This is a bug on the server side, thanks for the report.


#7

I see there’s been an update:
Current status (as I see it):
When I look at the ip:80 address of one of the RPi’s, I see “Radio, PiAware, FlightAware” are all green, but MLAT is now red (MLAT is not enabled) (as expected).

But when I look at my stats page, under Site Information:
(on the LHS) I have three green (PiAware, FlightAware and MLAT).
Mousing over MLAT reveals: "MLAT Sychronised"
while on the RHS it shows: “Multilateration (MLAT): Supported / Not Enabled”

Edit:
Looks like I was ‘between updates’ as it’s now indicating correctly.