What is Easiest Way To Install Dump1090-Mutability


#1

Given a plain vanilla installation from a Piaware image, what is the simplest, least complicated way to change to dump1090-mutability without creating havoc? Joe K4AA


STAFF piaware and dump1090 - ALL documentation in ONE place
New SD Card... can't get Dump1090-mut running
New SD Card... can't get Dump1090-mut running
Raspberry Pi 2 Install
Multilateration (MLAT) now available on PiAware!
Antenna Run
#2

For me when I switched I started with a new SD card with a fresh Linux install for the Raspberry Pi. This way you still have the base Piaware SD card to fall back to if things go wrong.
…Tom

Dump1090-mutability

http://discussions.flightaware.com/ads-b-flight-tracking-f21/raspbian-ubuntu-packages-for-dump1090-mutability-available-t19619.html

Piaware 2.0-7

https://flightaware.com/adsb/piaware/upgrade


#3

The nice thing with the dump1090-mutability install is that you don’t have to manually blacklist the Raspbarian supplied TV drivers for the dongle, mutabilty does it for you (thanks Obj!)


#4

I wouldn’t recommend it. Stick with the FA version. There’s no indication when, if ever, any of the mutability stuff will be upgraded.


#5

I’ve been slack on the packaging/release front because it’s a lot of effort to sort out for not much reward; doing user support is really not my idea of fun.
There’s plenty of development going on, you just have to build it yourself.


#6

As I said, I’d recommend against it.


#7

If you’re not willing to put a bit of effort, sure, that’s the best path. Or stick with the last released package, there’s nothing wrong with that package.
But please don’t imply that it’s been abandoned. It hasn’t been.


#8

That’s exactly what I’m implying because it effectively has. Saying it hasn’t and then saying how you don’t want to do “support” is disingenuous at best. Comments like “just build it yourself” are useless to those of us that installed it and don’t have your level of expertise. Perhaps a little more detail would be beneficial or is that “support?”


#9

OK guys, I didn’t mean to kick over the chamber pot. So I created a new SD chip with the Piaware image from FA. Want I want to do is remove my separate perfectly working SD chip with 2.07 on it and dump1090 from my Pi, lay it aside and take my newly created SD chip with the stock FA configuration and convert it to dump1090-mutability. What do I need to do? (I have SSH access to the Pi.) Do I need to disable dump1090? Joe K4AA


#10

The instructions in the first post here still apply: ads-b-flight-tracking-f21/raspbian-ubuntu-packages-for-dump1090-mutability-available-t19619.html

If you run into problems with that on a piaware image, let me know. I don’t test that combination so there may be sticking points I’m not aware of.

@jim: if you don’t want to use it, don’t use it. Was there some problem with the latest package that you ran into? You don’t have to be running the latest and greatest if you don’t want to or if it is beyond your expertise. It’s not my responsibility to hold your hand.

edit: to be really clear: I’m happy to provide support for packaged versions. If you want to run a newer version that’s not packaged, I expect you to know enough to be able to solve the obvious problems yourself. If you’re not able to do that, stick to the packaged versions. I have not released a new version recently because I don’t want yet another version to support.


#11

Instead of installing the FA Piaware image onto the new SD card I would suggest downloading the Raspbian image from the website below and start fresh. After your first boot, do a [sudo apt-get update && sudo apt-get upgrade] to pull down all the latest fixes and patches. Then follow my links from my earlier post to install Dump1090-mutability and Piaware.

…Tom

https://www.raspberrypi.org/downloads/


#12

Fine… would you dare lower yourself to a level to help a lowly fool like myself as to how uninstall piaware-mutability or is that something I should have known how to do before I went down this path? That way I can leave you be?


#13

That’s a really weird way of asking for help, but sure:

$ sudo apt-get remove --purge dump1090-mutability

Pretty sure that’s been mentioned a few times in the main thread.

Or you can do the scorched-earth policy of re-imaging your SD card with the FA-provided piaware image if you want something that’s absolutely pristine.


#14

I’ve asked for help before… and all I got back was…

never mind.

Thank you.


#15

Wow. My words for you wouldn’t be appropriate for this forum. OBJ gives away free software and you demand free support. When you don’t get the FREE support like the way you want, you whine and complain.
He has a strong history of helping any reasonable person.

All of this requires at least some base knowledge. Despite that, I’ve asked stupid questions and he was still helpful.


#16

TJO: OK will do the following:

1: Format SD card
2. Install NOOBS
3. Install RASPBIAN
4. Do update
5. Install dump1090-mutability
6 Do update
7. Install Piaware
8. Do update

Question: when I install Piaware, is it devoid of dump1090?

Thanks Joe K4AA


#17

I agree with tjowen. Start with a standard install. Update everything, then install the packages per OBJ’s threads which contain step-by-step instructions.

If you start with the FA image, you have to undo some stuff they did beforehand.


#18

You can install Raspbian directly.

Do:
Raspbian: Set up the repository and signing key:
wget [github.com/mutability/mutabilit ... _armhf.deb](https://github.com/mutability/mutability-repo/releases/download/v0.1.0/mutability-repo_0.1.0_armhf.deb) sudo dpkg -i mutability-repo_0.1.0_armhf.deb

Both: Install and upgrade packages via apt-get:
Code:
sudo apt-get update && sudo apt-get install dump1090-mutability sudo dpkg-reconfigure dump1090-mutability (for detailed configuration)
$ sudo apt-get install lighttpd && sudo lighty-enable-mod dump1090 (if you want to use the external webserver integration) <— YES YOU DO! DON’T USE INTERNAL!

Then follow https://flightaware.com/adsb/piaware/install starting at step 2.

Piaware is separate from dump1090.


#19

…snip question already answered.


#20

When stepping through the Dump1090-mutability reconfigure remember the following unless this no longer applies to the new piaware…
…Tom

Important: You must configure NET_BIND_ADDRESS="", or equivalently enter a blank answer to the “Interface address to bind to?” configuration question, to avoid a bug in piaware that will make piaware think that there is no dump1090 running.

From posting: http://discussions.flightaware.com/ads-b-flight-tracking-f21/raspbian-ubuntu-packages-for-dump1090-mutability-available-t19619-275.html