FlightAware Discussions

Viewing Virtual Radar Server on another device

Hi All.

I have had my feed set up to flightaware for several months now but in the past few days I’ve downloaded VRS as I like the map with the additional info it provides over the FA one anyway I have got it set up and running

Now the issue I’m having is a simply can’t get the VRS map to show on any other device it gives me 3 addresses local, network and internet the 1st 2 simply timeout and won’t load whilst the network address only works with :8080 which just takes me to the FA map

Any ideas what I’m doing wrong?

Look at the web server and website options.
http://virtualradarserver.co.uk/Documentation/WebServer/WebServerOptions2.aspx
http://virtualradarserver.co.uk/Documentation/WebServer/WebSiteOptions.aspx

1 Like

Got that set up maybe I need to alter a few boxes?

Changed the settings to the same as the are on the links above but still nothing on another device links just time out

Make sure that the local device Firewall is not blocking access.

Try some telnet tests to see if the port is actually open.
telnet

ie telnet 192.168.1.5 80

Having checked it looks to be fine

Didn’t you install VRS on your local Windows PC?

That means that you need to connect to that to get the VRS webpage.

Yes. I tried to install it on the PI but had no luck so had to do it on the PC and add the plugins

So did you type in the IP address of your PC or the pi?

I used the PI ip which was listed in the connected devices section of my hub

So if you ask for the pi you are not gonna get your main PC which is running VRS are you? :stuck_out_tongue_winking_eye:
You need to use the IP of your main PC. (it kinda makes sense because you didn’t install it on the pi)

Anyway you might need to add firewall exceptions to your windows.
You can probably find threads about it on the VRS forum, for example like this one https://forum.virtualradarserver.co.uk/viewtopic.php?t=1508

I can get the map to load using my main ip of 86.xx.xx.xxx and the port which takes me directly to the FA map

I don’t think there will be an easy way to get to the VRS map away from my installed PC

Well if you are in you local network it shouldn’t be so hard to find the IP of your main PC.

If you are not then you obviously need to forward any port from the public side to the correct port on your PC.

Sorry to sound stupid but I wouldn’t even know where to look to find it all it know re ip’s is to type it in google and it brings it up

I mean you can view your local map on your Pi just fine, so VRS is no different.

Imagine your main PC as being just another Pi.

Here you should find the IP for you main PC as well.

So if you are on your mobile phone connected to the WiFi you just type in that other IP and it should work.

Making it work from somewhere not your local network requires you to configure your router but you might not even be asking for that. (Anyway you would need to let your main PC stay running all the time so you can access it)

try the following:

windows key + r
type in ‘cmd’ and press return
in the window that appeared type ‘ipconfig’ and hit return.
The ‘IPV4 address’ number is your local ip address.

Done that IPV4 is exactly the same as what VRS gives me as the network address

Make sure to add http:// before the ip address or phones/tables will just make an internet search instead of going to the address.

Also make sure the device is actually in your home WiFi and not using your phone providers data service.

Have you tried to access the Pi / local map on your phone/tablet? Does that work?

Then you will need to add an exception to your Windows Firewall.
Best look at a howto for your specific Windows version.

You should be able to select a program in Windows Firewall, so that it can receive connections. There you select VRS and then it should work.

Every time I put http:// it just removes it when I go to search (this happens on my PC as well as phone)

I can access the PI aware map via my phone on the 86. address

Only connected to home wifi

I have this working this way. PiAware is running on a pi at local address 192.168.1.35. VRS is installed on a W10 PC on the same network.
This is in the PIAware log:

[2019-02-02 17:55 EST] Started faup1090 (pid 1167) to connect to dump1090-fa [2019-02-02 17:55 EST] Starting faup1090: /usr/lib/piaware/helpers/faup1090 --net-bo-ipaddr localhost --net-bo-port 30005 --stdout --lat 40.105 --lon -75.177 [2019-02-02 17:55 EST] mlat-client(1158): fa-mlat-client 0.2.10 starting up
The [2019-02-02 17:55 EST] message says that faup1090 is on port 30005. The port is probably this on any PiAware installation, but I am not sure of this. Check the log only if the "Test Connection" doesn't work and the IP address is correct.

So in the Configuration settings for the receiver the Connection Type is “Network”
The Address is the pi’s address “192.168.1.35” and the port is “30005”.