Unable to SSH in version 3.5.3


#1

I have just installed version 3.5.3 and is now unable to SSH. My command is sudo ssh pi@192.168.0.10
I am prompted for a password but flightaware (or any other password) will not work.
In the previous version 3.5.1 it all worked just fine.
Any suggestions?


#2

Sounds like you need to read this:

For headless setup, SSH can be enabled by placing a file named ssh, without any extension, onto the boot partition of the SD card from another computer. When the Pi boots, it looks for the ssh file. If it is found, SSH is enabled and the file is deleted. The content of the file does not matter; it could contain text, or nothing at all.

If you have loaded Raspbian onto a blank SD card, you will have two partitions. The first one, which is the smaller one, is the boot partition. Place the file into this one.


#3

Thank you for the advice. I will try this again and hopefully it will work.


#4

If he’s being prompted for a password then SSH is already enabled.


#5

That was my thought as well. The thing is that if I hook up my Raspberry to a screen with keyboard and mouse I am able to log in with username PI and password flightaware. So something seems to stop me from logging in via SSH


#6

It looks like you are trying to SSH from a unix system over to your PiAware. So I tried this from one RasPi over to another running PiAware. It worked, no problems.

However, I did not need SUDO before the SSH command. If you used it, depending upon how your Unix system is set up, specifically the user you are signed on with, and the SUDO config, are you sure it isn’t asking for the root password for the Unix system you are signed on to?

Using SUDO SSH worked, and because I was on a RasPi as user Pi, and SUDO is allowed on that user without prompting for password, it worked OK as well. But if you had a different user, or different ID setup for SUDO, or a different uniix system, it might prompt you for the root password.

…just an idea.


#7

Thank you for your comments. I am using OSX when I am trying to SSH. I have tried your suggestions but without luck. I will go back and hook up my PI to screen, keyboard etc and analyse the contents. Maybe I can find the problem around the SUDO user.
If I find a solution I will come back on this forum.


#8

https://support.apple.com/en-ca/HT202035
???