UDP anomaly on a remote Pi


#1

Suddenly getting the “21% of UDP Multilateration traffic sent by Piaware is not reaching Flightaware servers” anomaly on a remote site. ( Percentage seems to be increasing as the day goes on)

I can VNC into the Pi and router- any tips on things to check to find what may be causing the problem ?


#2

A re-boot usually clears it. First the router, then, if not enough, the RPi.


#3

Not at all always the case.

In my case it was the automatic tunnel the router made for bundling LTE and DSL. Once i switched that off that message was gone.

I have tested and it was not the MTU size. Maybe they arrived in a wrong order and that was the problem? Not sure.

You can try traceroute to see if it has problems with certain hops in between.
But it’s really hard to diagnose such problems even if you are more familiar with networks.

It’s not really a problem for feeding afaik so you can just ignore it if you want.


#4

Well I tried a router reboot remotely as the regular internet speed tests were slow as well- big mistake as I was using VNC on the Pi to log into the router instead of going straight to the router externally as I normally do. Don’t do this.

Idiot- now the router failed to complete boot and its 3 hours away so cant correct that till next week.


#5

Ouch. But if the router did not boot correctly, than you would not be able to access remotely anyway, I guess.

Maybe it is a problem on the ISP’s side and and it reconnects properly by itself? #fingerscrossed


#6

The packet loss measurement is literally just 1 - (# of datagrams seen by server) / (# of datagrams the mlat client reports it sent). So it could be pretty much anything between your Pi and the FA servers.

Out of order arrival doesn’t really matter so long as the datagrams do arrive eventually (within a couple of seconds of the message arriving at the receiver, at least). Packet loss also doesn’t matter other than obviously the lost data can’t be used for multilateration (there is no retransmission done)


#7

Sorry to hear that. Remote operations carry that kind of risk. It has happened to me in the past, but I’m only a step ladder away from the equipment.


#8

…and I am only an arms length away from ALL of my equipment (including antenna). Thanks to our building management who refused permission to place my antenna and other equipment on roof or wall of building.


#9

It has been pretty bulletproof other than during a hurricane :scream:

My own fault, I have rebooted and reset modem and router remotely before but always directly using a ddns connection- this time I was actually using the browser on the pi “inside” the network, got cocky and when the router hung during the reboot it all went pear-shaped, and all device sessions ended of course. Like standing on a tree branch and sawing it off…:roll_eyes:

I had to go there anyways early next week, so just annoying for now.


#10

But you can never prevent a router hang during reboot can you?

I mean no matter form where you trigger the reboot.
What model is it?


#11

Yes, perhaps you are right- it might have hung regardless, but I should be at least have been able to get to the modem ahead of it so perhaps the issue is with it not the router.

Pretty sure its a tplink brand router, I forget the model at the moment. All will be solved in 4 or 5 days, or new gear will be installed to replace the old ones if they get "cranky ". :wink:


#12

Actually now that i think about it that sounds like the router just failed.

First it couldn’t handle all the packets and then just died.
Not sure which failure would present that way but it sounds plausible.

If you have a spare take it so you can replace it when you get there :slight_smile:


#13

Very likely- post hurricane power surges dips/sags/ etc. have been reported. Probably time for a newer box there anyways.

Sounds like an afternoon’s worth of configuration fun and games tho, with the number of things that I have set up there ( some security cams etc. ) Good news is it will help eliminate some of the wireless freeloaders :slight_smile: I have accumulated.

Aint technology grand ?


#14

Update:

Finally got on site and confirmed no Internet access via Spectrum Cable. Called it in and waited…
Since they were projecting an end of day service call, I purchased another modem just in case it was simply toasted and the cause of the issue. No Joy, same no signal as before.
Cable techs arrived and after some amount of coaxing I convinced them to swap out the house coax feeds going to the modem ( see what I did there ? Coaxing coax… I crack myself up :joy:) I think there was some water intrusion that killed the line into the house.

For kicks I put the old modem/ router combo back online but found that the hardwire speeds were significantly higher than the old router wifi. The old router would only pump 8Mb up and down, it was ridiculously slow, so installed the new modem/router combo and that made a huge difference.

TLDR: Bad coax, bad router.