FlightAware Discussions

Ubuntu X86/64 Install

Sorry but im an absolute newb when it comes to linux but giving it a crack.

What I have installed is as follows:
Ubuntu 18.10 updated and unstalled the stuff i dont need.

Completed > https://www.adsbreceiver.net/documentation/setup.php
sudo apt-get update
sudo apt-get install git
git clone https://github.com/jprochazka/adsb-receiver.git ~/adsb-receiver
cd ~/adsb-receiver
chmod +x install.sh

Had to install dump1090-fa and FR24 manually as it failed during the above install. Everything should be done in theory. In practice it seems I have problems.

adsb@HPadsb:~$ sudo dump1090-fa
Wed Nov 13 10:08:25 2019 ACDT dump1090-fa 3.7.0 starting up.
rtlsdr: using device #0: Generic RTL2832U OEM (Realtek, RTL2838UHIDIR, SN 00000001)
usb_claim_interface error -6
rtlsdr: error opening the RTLSDR device: Device or resource busy

adsb@HPadsb:~$ rtl_test
Found 1 device(s):
0: Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
usb_claim_interface error -6
Failed to open rtlsdr device #0.

adsb@HPadsb:~$ usb-devices
T: Bus=01 Lev=01 Prnt=01 Port=02 Cnt=03 Dev#= 7 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=0bda ProdID=2838 Rev=01.00
S: Manufacturer=Realtek
S: Product=RTL2838UHIDIR
S: SerialNumber=00000001
C: #Ifs= 2 Cfg#= 1 Atr=80 MxPwr=500mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=ff(vend.) Sub=ff Prot=ff Driver=usbfs
I: If#= 1 Alt= 0 #EPs= 0 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)

It appears that most of my config is ok because FR24 shows it as online with no data (expected because I dont have an antenna connected) but thats not really a problem right now. Think I need to blacklist something to get the USB working first???

Any pointers please!

Current version is 3.7.2

How to Install Piaware v 3.7.2 on Ubuntu 18.04 (Bionic) & Ubuntu 19.04 (Disco) amd64 / Intel PC


If you have Ubuntu 19.1 (Disco), a workaround is required for piaware. Dont do the workaround mentioned in above linked post. Instead do the revised wokaround in this post:


On Ubuntu 18.10

Trying to update dump1090-fa but not really sure how to.

adsb@HPadsb:~$ sudo apt-get install dump1090-fa
[sudo] password for adsb:
Reading package lists… Done
Building dependency tree
Reading state information… Done
dump1090-fa is already the newest version (3.7.0).
The following packages were automatically installed and are no longer required:
libncursesw5 libtinfo5
Use ‘sudo apt autoremove’ to remove them.
0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.


First step:

sudo dpkg --purge dump1090-fa
sudo dpkg --purge piaware

Next step:
Follow the method for Ubuntu 18.04 in the post I have linked


Ubuntu does not have ver 18.10.

It has

  • 18.04 LTS (Bionic)
  • 19.10 (Disco)

Which one you have, Bionic LTS, or Disco?

1 Like

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.10
Release: 18.10
Codename: cosmic

are you suggesting I would be better to start from scratch @SoNic67

Oops, I missed this release.

I am not sure if the method for v 18.04 will be ok for 18.10, as I have not tried it, but most likely steps for 18.04 Bionic should also apply to 18.10 Cosmic. There is no harm in trying. If procedure for 18.04 Bionic fails, you can try procedure for 19.10 Disco.

Trying 18.04 and got to the build but it failed.

Renaming dump1090-fa-dbgsym_3.7.2_amd64.deb to dump1090-fa-dbgsym_3.7.2_amd64.ddeb
mv debian/.debhelper/scratch-space/build-dump1090-fa/dump1090-fa-dbgsym_3.7.2_amd64.deb ../dump1090-fa-dbgsym_3.7.2_amd64.ddeb

dpkg-genbuildinfo --build=binary
dpkg-genchanges --build=binary >…/dump1090-fa_3.7.2_amd64.changes
dpkg-genchanges: info: binary-only upload (no source code included)
dpkg-source --after-build dump1090-fa
dpkg-buildpackage: info: binary-only upload (no source included)
signfile dump1090-fa_3.7.2_amd64.buildinfo
gpg: WARNING: unsafe ownership on homedir ‘/home/adsb/.gnupg’
gpg: skipped “Eric Tran eric.tran@flightaware.com”: No secret key
gpg: dpkg-sign.VD8foqeJ/dump1090-fa_3.7.2_amd64.buildinfo: clear-sign failed: No secret key

dpkg-buildpackage: error: failed to sign .buildinfo file

did the same on the 19.04 attempt. “No secret key”

Bugger it. going to start a fresh install. 18.04LTS.

Thanks for your time folks. Much Apprecieated @abcd567 @SoNic67

fingers crossed :wink:

I have installed the 18.04LTS too…

Ignore this error. I always get this error (on Debian 10, Ubuntu Bionic 18.04 and Ubuntu Disco 19.10).
Did the package build? Check by following commands

cd ../
1 Like

Read the actual warning.
It’s telling you it can’t put a signature on the file because you are not Eric Tran.
If you just tried installing the debian package that is produced, it would work.

The -6 error just means that the device is already in use.
Probably in use by dump1090-fa, if you installed that package; it auto-starts.
i.e. everything was working fine…

1 Like

(1) The dump1090-fa was already started by systemd service at boot.

I am not sure if binary’s name is dump1090 or dump1090-fa, but if the linux binary is /usr/bin/dump1090-fa, then command sudo dump1090-fa will start 2nd instance of dump1090-fa directly (as the command does not have systemctl in it), and as the dongle is already grabbed by the first instance, then usb_claim_interface error -6 is given.

Same is the case with rtl_test.

(2) In any case, it was ver 3.7.0 built from source for amd64, it cannot be upgraded to 3.7.2 by sudo apt-get install dump1090-fa.

The best option is a fresh install by building from source code which is the latest 3.7.2.

I realize that you don’t like Ubuntu (I really don’t understand why, but that’s neither here nor there), but if you are going to provide advice about it you should probably understand that they are on a twice-annual release cycle - a new release every April and October. The release numbers are YY.MM, so 18.04 and 18.10 were last year, 19.04 and 19.10 this year, 20.04 and 20.10 will be next year.

Of those, Ubuntu releases a “Long Term Support” (LTS) version every 2 years. 18.04 is the most recent, released in April of 2018, 20.04 will be the next one, coming out in April of 2020.

They recommend running only the LTS versions for mission-critical applications, hopefully for obvious reasons. LTS versions get 5 years of support, while the intermediate versions only get 9 months or so.

Here is everything you never wanted to know on the subject: https://ubuntu.com/about/release-cycle

What makes you think so?

I am the one who posted how-to for piaware on Ubuntu 18.04 LTS and Ubuntu 19.10, and I did that only after installing these two versions of Ubuntu on my Desktop/VM. If I disliked Ubuntu, I will not do all this effort.

1 Like