FlightAware Discussions

Two Airspy Feeders w/ Similar Stats, Wildly Different Messages/Sec

I have two production feeders, one for 1090 (site 100063) and one for UAT978 (site 101266). A few weeks ago I decided I wanted better stats for the 1090 feeder. I put together a pi3B+ airspy mini feeder and got better stats. Then I got greedy and built a pi4 airspy mini feeder and got some strange results.

spyaware (site 108954) is a pi3B+ powered by a POE hat/airspy mini/RTL-SDR Blog Triple Filter
LNA running the FA SD card image 3.7.1.

spy4 (site 103073) is a pi4 powered by the official USB-C PS/airspy mini/RTL-SDR Blog Triple
Filter LNA running the latest Buster lite image with the Debian add-on 3.7.1.

Both spyaware and spy4 were configured per wiedehopf’s howto for airspy manual install/config.

Both feeders are each fed by 50 feet of LMR400 cable with FA antennas and produce very similar stats for aircraft and positions.

My concern is that spy4 (103073) indicates on both SkyView and performance graphs that it produces only one-half as many messages/sec as spyaware (108954), even though for both feeders, FA stats for aircraft and positions are similar. Also on the ADS-B Message Rate/Aircraft graph you can see that the Maximum Messages/AC for spy4 is exactly half of the number for spyaware. The graphs for ADS-B Range and ADS-B Signal Level for both feeders are for all practical purposes identical.

Where are the rest of the messages/sec for spy4 (103073)?

Below I have included for both feeders, the status of airspy_adsb, appropriate graphs, htop views, and a couple of pictures.

Help me find the missing messages.

A couple of other things come to mind:
Why does spyaware run a beast-splitter process and not spy4?
What is the purpose for the connection to port 45748 on spyaware and how does it get
configured?

airspy_adsb status

pi@spy4:~ $ uname -a
Linux spy4 4.19.66-v7l+ #1253 SMP Thu Aug 15 12:02:08 BST 2019 armv7l GNU/Linux
pi@spy4:~ $ 

pi@spy4:~ $ systemctl status airspy_adsb
● airspy_adsb.service - Airspy ADS-B receiver
   Loaded: loaded (/etc/systemd/system/airspy_adsb.service; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2019-09-09 17:51:02 MST; 15h ago
     Docs: https://discussions.flightaware.com/t/howto-airspy-mini-piaware-dump1090-fa-configuration/44343/2
 Main PID: 358 (airspy_adsb)
    Tasks: 4 (limit: 4915)
   Memory: 7.6M
   CGroup: /system.slice/airspy_adsb.service
           └─358 /usr/local/bin/airspy_adsb -v -f 1 -p -b -l 29999:beast -l 47806:asavr -c localhost:30104:beast -g 

Sep 09 17:51:02 spy4 systemd[1]: Started Airspy ADS-B receiver.
Sep 09 17:51:02 spy4 airspy_adsb[358]: Listening for beast clients on port 29999
Sep 09 17:51:02 spy4 airspy_adsb[358]: Listening for asavr clients on port 47806
Sep 09 17:51:02 spy4 airspy_adsb[358]: Acquired Airspy device with serial 26A464DC28364493
Sep 09 17:51:02 spy4 airspy_adsb[358]: Decoding started at 12 MSPS
Sep 09 17:51:14 spy4 airspy_adsb[358]: Push client connected to localhost:30104 (beast)
pi@spy4:~ $ 


pi@spyaware:~ $ uname -a
Linux spyaware 4.14.98-v7+ #1200 SMP Tue Feb 12 20:27:48 GMT 2019 armv7l GNU/Linux
pi@spyaware:~ $ 

pi@spyaware:~ $ systemctl status airspy_adsb
● airspy_adsb.service - Airspy ADS-B receiver
   Loaded: loaded (/etc/systemd/system/airspy_adsb.service; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2019-09-09 17:47:20 PDT; 15h ago
     Docs: https://discussions.flightaware.com/t/howto-airspy-mini-piaware-dump1090-fa-configuration/44343/2
 Main PID: 269 (airspy_adsb)
   CGroup: /system.slice/airspy_adsb.service
           └─269 /usr/local/bin/airspy_adsb -v -f 1 -p -b -l 29999:beast -l 47806:asavr -c localhost:30104:beast -g 16 -m 12

Sep 09 17:47:20 spyaware systemd[1]: Started Airspy ADS-B receiver.
Sep 09 17:47:20 spyaware airspy_adsb[269]: Listening for beast clients on port 29999
Sep 09 17:47:20 spyaware airspy_adsb[269]: Listening for asavr clients on port 47806
Sep 09 17:47:20 spyaware airspy_adsb[269]: Acquired Airspy device with serial 26A464DC28341B93
Sep 09 17:47:20 spyaware airspy_adsb[269]: Decoding started at 12 MSPS
Sep 09 17:47:25 spyaware airspy_adsb[269]: Client connected from 127.0.0.1:45718 (beast)
Sep 09 17:47:25 spyaware airspy_adsb[269]: Client disconnected 127.0.0.1:45718 (beast)
Sep 09 17:47:32 spyaware airspy_adsb[269]: Push client connected to localhost:30104 (beast)
Sep 09 17:48:34 spyaware airspy_adsb[269]: Client connected from 127.0.0.1:45748 (beast)
pi@spyaware:~ $



spyaware (108954) on the left. piaware (100063) in thr middle. spy4 (103073) on the right

Did you do it manually or did you use the script?

First of all it’s piaware :wink: (edit: oh i get it now!)
On the sd-card image you can’t configure it as neatly as with the package add-on installation.
That’s why the configuration for the sd-card image uses beast-splitter.

The messages are probably being routed to dump1090-fa twice, resulting in double the message rate.
It’s happened before, due to a change i made with the configuration for the sd-card image.
(I’ve since fixed that bug, you probably installed some time ago)
Sorry but your high message rage was a bug.

So the issue is probably with the piaware sd-card site, duplicating the messages.
Just run the configuration script again, it should fix it.
https://github.com/wiedehopf/airspy-conf#airspy-conf
Otherwise i’ll have a closer look at the configuration.

On a side note be sure to configure the airspy_adsb on the Pi4 to 20 MHz, that’s why you got the Pi4, right? :slight_smile:

[wiedehopf]

Did you do it manually or did you use the script?

I did both manually.

The messages are probably being routed to dump1090-fa twice, resulting in double the message rate.

Bummer, I thought I had a smoking hot feeder for a while. :sunglasses:

On a side note be sure to configure the airspy_adsb on the Pi4 to 20 MHz, that’s why you got the Pi4, right? :slight_smile:

Yes. The pi4 has only been up for a couple of days. On the first day I set -m20 for several hours
with no problems. MLAT worked great. I changed it back to -m12 until I got the message rate
issue resolved so that I would not be comparing apples to oranges.

Its late here now. I will work on this tomorrow evening.

Thank you for the fast response and for all the work you do here.

The bug i fixed in the script version was still present in the manual instructions.

I’ve added the following in the section about /etc/default/airspy_adsb:

#network settings
NET= -l 29999:beast -l 47806:asavr  -c localhost:30004:beast

If you are using the piaware sd-card image, remove -c localhost:30004:beast in the last line of the configuration.

Just a quick comment: It’s better to have the LNA placed before the splitter in the chain. If the FA dongle requires a lower input level, add an attenuator after the splitter. This also allows you to move the LNA near the antenna and get best NF for all the radios.