Airspy Mini on a Raspberry Pi for ADS-B flight tracking


#1

Hi everyone,

I am currently tracking aircraft using the FA antenna, Pro Stick and a Raspberry Pi 3 model B. All is working well. I’m also experimenting with the Airspy Mini, which I haven’t been able to get to work on the RPi yet.

I followed instructions as described here and here. I am able to run airspy_rx -r /dev/null -t 0, which does provide output, confirming that the Pi is communicating with the Airspy. The rate drops significantly over time though, but this is something I expected as I am testing this set-up on a Raspberry Pi 1B.

My current issue is that I cannot seem to run the airspy_adsb or spyserver programs at all. For example, when I try ./spyserver spyserver.config, I get “Segmentation fault” as output. Same result when I try sudo ./airspy_adsb -c localhost:30104:beast -g 21 -p (just an example).

Does anyone have experience with the Airspy or did anyone encounter a similar problem? I am aware of the various threads on the Airspy on this forum, but none of them seem to address this specific issue. Thanks!


#2

I ran airspy on a 3b but it was under powered for my location. I had to upgrade to an odroid XU4.
Some people have had better luck but I am in a very busy location.

I wonder if you have another airspy application running and that is why you are getting the segment fault.
Or, are you running the correct application? Make sure you have downloaded the version for an RPI.

try an ls -lart airspy_adsb and show us the output. I can compare it to mine.


#3

Are you running the airspy server? The RPi is border line for that. The recommended board for now, is the ASUS Tinkerboard. But I would not go out and buy one at this time, as the new Tinkerboard S, with 16GB eMMC, is due out soon.


#4

I downloaded the airspy_adsb-linux-arm.tgz file which I assume to be the correct one for the Raspberry Pi. I am aware of the fact that even the RPi 3b is underpowered for use with the Airspy. Therefore I’m only using it to understand and validate the software settings, before I continue and buy a more powerful board (odroid or Tinkerboard as @Dxista mentions (thanks!)

I don’t think I am running other applications that are trying to communicate with the airspy - I have not configured airspy_adsb or spyserver to start at boot and the issue occurs even after a reboot.

I’m getting the following output when trying ls -lart airspy_adsb:

-rwxr-xr-x 1 pi pi 30664 Apr 12 00:26 airspy_adsb

I am unsure if I am using the right command to start airspy_adsb. When I use the same command as mentioned in my first post but with a & at the end, I get one line of output like this:

[1] 609

I am not sure if that is normal behaviour. When checking `sudo piaware-status’, I see a message that no data is being produced on port 30104 (after running said command).

Furthermore, per this post, I configured dump1090-fa to run in relay mode and configured its listening host and port to localhost and 30104, respectively. That’ll only be relevant if I manage to fix the issue at hand, though :slight_smile:.


#5

The looks OK.
Mine is running in rtlsdr mode. I have device index set to none.

I have a slightly different setup. The airspy is connected to an Odroid XU4 and it sends the data to an RPI3.
(Long story relate to previously only having 2 cat5s running to my attic and having to running 2 dongles and an airspy from one device).


#6

I tried running PiAware in rtlsdr mode, but to no avail. Also, I don’t think that airspy_adsb is actually running since any command I execute after starting it with a & at the end results in an output of the same `segmentation fault’ error.


#7

check for other apps running
ps -eaf | grep airspy


#8
pi@raspberrypi:~/airspy $ ps -eaf | grep airspy
pi         893   471  0 18:54 pts/0    00:00:00 grep --color=auto airspy

No meaningful output after I try to start airspy_adsb either.