FlightAware Discussions

Raspberry Pi 4, Airspy Mini, Uptronics Ceramic = No Aircraft

After the advice I received in this thread (Accessing Dongle (AirSpy) through TCP/IP) and I finally received my Airspy Mini and Uptronics Ceramic 1090 MHZ LNA, I was able to build a new PiAware on the Raspberry Pi 4 B 4 GB model.

Many thanks to @wiedehopf for his recommendations and clear concise instructions on getting Airspy Mini and PiAware running on a Raspberry Pi 4.

Now we get to the reason for this post. After following the instructions I got Raspbian Bust Lite, PiAware and Airspy_adsb installed. I configured the AirSpy Mini to supply BiasT to power the Uptronics Ceramic 1090 MHz LNA and sutedown the Pi4. Connected the antenna to the ANT port on the Uptronics LNA, a short jumper from the RX port of the Uptronics LNA to the Airspy Mini dongle. After checking all connections, I powered the RPi4 on. Went to the x.x.x.x:8080 and no aircraft. Hmm. Shut the Rpi4 down, checked all connections again, and powered the RPi4 on again. Still no aircraft. Modified the config file for the Airspy Mini to no longer provide BiasT power, and shut the RPI4 down. Wired the antenna directly to the Airspy mini, and booted the RPi4. Surprise, aircraft are seen. Scratching head, I shut the RPi4 down again, checked the jumper from the Airspy Mini to the Uptronics LNA for continuity, recabled to put the LNA back in, rebooted, change the config of the Airspy Mini to supply BiasT power, restarted airspy_adsb dump1090-fa. Still no aircraft.

Does anyone see something I am doing wrong, as I am at a loss here. Any suggestions are more than welcome.

Thank you

Show the config for that or just the output of:
pgrep airspy_adsb -a

You can always power the uputronics via the supplied USB cable.
Sounds like you either have the uputronics in reverse or it’s defective.

2 Likes

If I recall correctly, the power via bias Tee is an option which can be ordered with the unit.
I added a regulator and associated capacitors to enable it on my SAW version of the Uptronics.

Edit:
This was for when >5v is used to power the LNA.

1 Like

You just need the correct USB cable:

All our preamps are compatible with most USB SDR Dongles such as the RTL USB, Airspy, Fun Cube. You can power them from either bias tee (This item is 100% compatible with the Airspy bias-tee) or a simple USB minicable (Not Supplied). Bias tee/USB voltage is 5V max unless the optional (see related items) LDO kit is fitted which takes the bias-tee voltage input range from 5V to 26V (USB remains 5V).

https://store.uputronics.com/index.php?route=product/product&path=59&product_id=50

It’s probably an older mini type socket, while today most cables are micro type.

Anyway it should work with the bias-t, let’s check first if the -b for bias-tee option is correctly in the command line.

1 Like

I’m not home right now so I can’t provide the output of the requested command, ill do that when I get home. But would this not be the correct way to wire the LNA?

Well it has an input and an output, input is towards the antenna, output towards the receiver.

While having the LNA closer to the antenna is preferred, it’s not required.

Maybe the ANT/OUT sticker was placed the wrong way around from factory? :stuck_out_tongue:
Anyway check that the side with the mini USB socket is connected with the receiver.

Then you can always check that you don’t have by accident bought some RP-SMA gear with a missing pin in the SMA male connector.
But that seems unlikely, still always good to check.

Then also check the receipt if it’s for the 1090 MHz amp, they offer LNAs for other frequencies.

And as i said it’s always a possibility that your gear is just defective, but still the other possibilities however remote should be checked.

1 Like

After troubleshooting everything mentioned above and still come up short? When looking at all your connections, which of these do they all look like?

image

If you have anything that resembles the one on the right, that’s you’re issue.

1 Like

The response to the above command was as follows;

335 /usr/local/bin/airspy_adsb -v -f 1 -b -l 47787:beast -c localhost:30004:beast -g 21 -m 20

The SMA plugs have the pins not holes in the centre.

The receipt from Airspy.us is for a “1090 MHz ADS-B Premium Filter/Preamp”.

They all look like the SMA Male.

It looks like you were correct. The label is on backwards. The mini USB is on the side the label says is the ANT. Based upon your statment that the mini USB should be on the RX side, I installed the LNA “backwards” (according to the label), and it is now working.

Thank you all for your suggestions.

3 Likes

Wow, that i did not expect :wink:

Glad i could help!

Be sure to install the graphs if you fancy some statistics: https://github.com/wiedehopf/graphs1090#graphs1090

4 Likes

That was done as part of the build.

Once again, thank you for your assistance.

I sent a message with photo to Airspy.us and got the following response;

Yes, it appears that label (or shell) is on backwards. If desired, you can remove the ends of the preamp and turn the shell around. That would effectively fix the issue.

Thank you for bringing this issue to our attention.
We will check existing stock for the same issue.

@wiedehopf, nice catch! Thank you for your assistance. I would never have thought that was a possibility.

This has been mentioned in the past.
I think I had one backwards too. I think it was a 1090mhz filter too. I have theee or four different modlels (APRS.AIS, UAT and maybe NOAA)

If you have a lot of noise you may need a cavity filter between the amp and antenna. My location in NYC requires them. I have a half dozen cell towers with two or three blocks.

1 Like