FlightAware Discussions

Timelapse1090

Hey everyone!

Published this before but without an installer and it wasn’t really polished.
This version is much better.

This will provide you with a timelapse/history webinterface for dump1090-fa.
Reachable at your RPi address:
http://ip-address.of.pi/timelapse/

This uses a small bash script to regularly copy the current aircraft.json.
Over time it creates an independent history of aircraft positions and data in memory.
This history is saved compressed to conserve memory and bandwidth for the accessing browser.
The data is overwritten after 24 hours.
(Can be changed, depending on browser this might already be stretching it)

Installation:

sudo bash -c "$(wget -q -O - https://raw.githubusercontent.com/wiedehopf/timelapse1090/master/install.sh)"

github page: https://github.com/wiedehopf/timelapse1090#timelapse1090

In the top right you can find buttons to change the playback speed or jump forwards/backwards.
After installation, reboot, or changing the settings it will not have saved any data, this is normal, just wait a bit.

Some rudimentary configuration via configuration file: /etc/default/timelapse1090
After changing settings, restart timelapse1090: sudo systemctl restart timelapse1090

Screenshot%20from%202019-05-31%2017-19-39

5 Likes

Running time-lapse on flight aware -image,

it’s working but lots of error

http://192.168.1.74/timelapse/data/chunk_55.gz

That’s normal, those chunks are not generated yet.

Not sure if i can somehow suppress those errors?

Edit: Google says no, nothing to be done about it.
I could of course somehow write the number of existing chunks in another file but i don’t think it’s too important.

Once the thing runs for length of hours you’ve set the history to, the errors will be gone.

Also good to know it works for someone else :wink:

I only works on Safari ,
Chrome and Firefox only shows a spinner…

Hmm i’m using chrome.
Ctrl-F5 doesn’t help i suppose.

Can you check the log in chrome?

I am using Chrome also and it is just showing a spinner. May need to wait a while for it to accumulate data.

Do you have dump978-fa and dump1090-fa installed?
I suppose if you are using an piaware sd-card i would be a yes.

There is a duplicate module activated causing problems with lighttpd.

Let’s try this:

sed -i -e 's/^server.modules += ( "mod_setenv" )/#server.modules += ( "mod_setenv" )/' /etc/lighttpd/conf-available/89-skyview978.conf
sudo systemctl restart lighttpd

I’ve put something to a similar effect into my install script so this problem is hopefully a thing of the past.

I’ve added a few more buttons to change playback speed and jump around.
Also the settings in /etc/default/timelapse1090 are actually honored now, oops!

I’d be happy about any testers.
The CPU use on the Raspberry should be minimal.
Memory use should be no more than around 100 MB assuming default settings.

2 Likes

Working perfectly here, thanks. A start/stop/pause button might be a handy addition and how about a ‘reset’ which goes back to a default setting (x5?)

There is a 5x button.

Would you want a 1x and pause button as well?
It’s getting crowded with buttons but it shouldn’t hurt :slight_smile:

Even more buttons added:
Screenshot%20from%202019-06-01%2013-17-22

How do I jump back to a “live” view? (meaining a button for that would be nice :slight_smile:)

There is no live view.
It only loads the history which is only made current every 60 seconds or so.
(And the current history from the RPi is only loaded when you load the page.
So if you’ll have to refresh the complete page when you want to see something in the last 5 minutes and had the page open for 10 minutes already)

Just use the normal SkyView for live viewing?

1 Like

Still thinking about how i can make the webinterface smarter, so you can choose a day of the week.

If you have enough free ram, then saving a week worth of history should not be a problem.
(typical installation has enough ram for that)

Yeah, I added a few links to my browser, so I can reach that easily, quite a few extensions available now :wink:

Not having any joy getting this to work. I installed it and set it running about 14 hours ago but all I get is the page setup and a spinner. Any suggestions?

Thanks

Run the install again, it will fix a problem with the piaware 3.7.1 sd-card install.
(Discussed in more detail somewhere in the thread but nothing interesting)

Many thanks.

How long do I have to leave it before I can see something…reinstalled about an hour ago but still only getting the spinner?

Thanks

That should work by now.
Which browser are you using? (try Ctrl-F5)

I’ve tried it on IE, Opera and UR. I’ve tried Ctrl-F5 but just shows the same thing.