FlightAware Discussions

Suitable OS for N2 and Airspy

I think I have given Wiedehopf a bit of a head ache trying to sort out my 1090 graph problem. I am using Ubuntu for the first time, not sure if it is the OS that is causing the graph problem, although I see plenty of recommendations in using Ubuntu. So thinking ahead if an OS change is recommended, thinking of Debian buster for N2 or Armbian Buster for N2. Will be using Airspy, any personal recommendations on which one works best for the N2 / Odroid?

This is a very old operating system I have on an N2
jonha@odroidn2:~$ cat /etc/os-release
PRETTY_NAME=“Debian GNU/Linux 9 (stretch)”
NAME=“Debian GNU/Linux”
VERSION_ID=“9”
VERSION=“9 (stretch)”
VERSION_CODENAME=stretch
ID=debian
HOME_URL=“https://www.debian.org/
SUPPORT_URL=“Debian -- Support
BUG_REPORT_URL=“https://bugs.debian.org/
jonha@odroidn2:~$

I would suggest the latest version of debian.
It worked with @wiedehopf 's graphs and install scripts.

1 Like

I’m using an XU4 not an N2 but the graphs work fine for me on Ubuntu 20.04.3 LTS

odroid@odroid:~$ cat /etc/os-release
NAME=“Ubuntu”
VERSION=“20.04.3 LTS (Focal Fossa)”
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME=“Ubuntu 20.04.3 LTS”
VERSION_ID=“20.04”

1 Like

Thank you both for your suggestions. The only other thing that I did out of norm, was installed everything at once before booting the N2 into ADSB. That is and in this order ABCD’s Dump 1090-FA, PiAware (6 is now his default), PiAware-Web (I have always used his set up as it has worked every time); Wiedehopf’s Airspy-conf and finally his 1090 graphs. Everything is working other than the graphs. First time user of Ubuntu, new OS with it’s peculiarities (I love the simpleness of Raspi-config in setting the basics up but struggle to find a similar program for other OS’s like debian, armbian and now Ubuntu). I am think it is not the ubuntu that is causing the problem but not sure about the sequence I used i;e not running the ADSB setup with airspy, before adding the graphs. I think I normally do it that way. Anyway the N2 has been up on the mast all night, dawns cracking shorlty, so I will pull it down and see if wiedehopf can script me out of this problem. Otherwise I might fresh install

You could just answer the question i posed in the other thread.
Without knowing which exact system your on comparing to other systems isn’t useful.
I’d be surprised if it’s Ubuntu 20.04.3 like above, this python issue was present with some versions in between i’ve seen it before.
But first i was checking to make sure my install script was going right.
The one goes on.
It’s the usual way to debug it, no headaches involved. Just not magic so it’s an iterative process.

You have not asked any questions about what system I am using in the other thread and I have executed and posted all the information / reports you have asked for: I am using Ubuntu 20.04-4.9-mate-n2-20210126.

Apology accepted, he missed my last post and wiedehopf has supplied a working script fix with graphs now working :slight_smile:

This might be of interest: AirSpy One + Odroid XU4 + Linux kernel 5

2 Likes