FlightAware Discussions

Odroid N2 & Airspy - Now running!

I received my Odroid N2 today, and have managed to get piaware 3.63/Dump1090-fa running fine with a RTL-SDR v3, but am not having any success with getting an Airspy running.

OS is ubuntu 18.04.2-4.9 running in 64bit - tried at first to just get the Airspy working on its own, but no joy at all.

The Airspy host software seems to be working fine as the Airspy is recognised, and I managed to run the test command “airspy_rx -r /dev/null -a 20000000 -t 3” as recommended by @prog which returned a rate of 20+ MSPS and cpu usage is very low on the RTL, so would be good to see what could be achieved with the airspy :grinning:

Any thoughts or suggestions much appreciated.

Try the adsb-receiver script to setup an N1.
https://www.adsbreceiver.net/

It is likely to work the easiest for you.
You may need to configure dump1090 afterwards for --net-only mode.

@wiedehopf also has a setup that may work.

I was hoping they would have released an armbian version for the N1 by now. Maybe in the near future. I am not sure how close Armbian is to Ubuntu. I may have time to give it a try this weekend. I should have time by the end of the month.

You need an airspy_adsb binary compiled for arm64 (64 bit kernel)

The only arm binary offered on the airspy website right now is for armhf (32 bit kernel).

So either you somehow manage to get a 32 bit kernel running or you’ll have to wait until an arm64 version is published.
(The hardware can run 32 bit as well just like with x86_64 hardware still being able to run 32 bit. But using a 64 bit kernel you can’t run 32 bit binaries without multiarch support or w/e, i’m not exactly sure.)

And no obviously my install script doesn’t work as it can’t get the correct binary.
Also the adsb-receiver script won’t help in getting the airspy_adsb program to run.
(It may help you to compile dump1090-fa)

So i guess i would advise you to contact airspy and ask for an airspy_adsb binary for arm64.

VMT for your answers - has given me something to work on.

I have loaded dpkg --add-architecture armhf, and come up with an error which you Linux Gods might be able to help with:-

“error while loading shared libraries: libusb-1.0.so.0: cannot open shared object file: No such file or directory”.

I have tried “sudo apt-get install libusb-1.0-0-dev”, but the error still persists :sleepy:

Ideas anyone???

You can try an

apt update
apt dist-upgrade

after that architecture change.

Also the development version of libusb has nothing to do with the stuff :slight_smile:

You might try to install the armhf version of this library:

apt install libusb-1.0-0:armhf

I’m not sure maybe you need to setup different apt sources before you do that, why don’t you show me this:
cat /etc/apt/sources.list

Also after doing that let’s have a look at:
ldconfig -p | grep libusb

1 Like

That seems strange, where did you get that from?

@thespeedycab Seems like it works if you install some stuff:

sudo apt install libc6:armhf libstdc++6:armhf libusb-1.0-0:armhf
sudo ldconfig
/usr/local/bin/airspy_adsb  -v

Could you try that before doing the other stuff navzptc did, i’d like to find out what the minimum it is you need to do.

Yeah before installing that it needs:

sudo dpkg --add-architecture armhf
sudo apt update
sudo apt dist-upgrade

speedycab already did that.

I was mostly curious if this part
ln -s arm-linux-gnueabihf/ld-2.23.so ld-linux.so.3
was necessary.

The rest is a bit redundant but nothing strange.

Wow. It seems to work.
I had started from a fresh install and needed to do the --add-architecture first.

root@odroid:~# /usr/local/bin/airspy_adsb -v
Acquired Airspy device with serial XXXXXXX
*8DA506D5998D6A80508809A97744;00007735;06;1C24;
Decoding started at 12 MSPS
*8DAA49329904990888470A17A372;0005ED97;06;E57E;
*8DA037DA25184633DB4DE012ED40;0007D43B;06;2840;
*58AC3D05716333;0008FE9F;06;5B58;
*8DA0C20F580994A448BEECE58946;000951CC;06;D081;
*5DA29AFF5F8CB0;00098068;06;201C;
*8DA825205813D4AE88BF6B337296;000CD27B;06;9091;
*0281823D039975;000D34DA;06;933D;
*026181193D118A;000F4F7A;06;FFFF;
*026181193D118A;00107184;06;CF68;
*026181B6CEFD8F;0011D084;06;FFFF;

Let me put the config files on the N2

1 Like

My install script should work now or if you already used it, just restart the service:

sudo systemctl restart airspy_adsb

root@odroid:~# systemctl status airspy_adsb
● airspy_adsb.service - Airspy ADS-B receiver
Loaded: loaded (/etc/systemd/system/airspy_adsb.service; enabled; vendor preset: enabled)
Active: active (running) since Thu 2019-04-11 13:54:21 UTC; 3min 25s ago
Docs: HOWTO: Airspy mini and Airspy R2: Piaware / dump1090-fa configuration
Main PID: 2071 (airspy_adsb)
CGroup: /system.slice/airspy_adsb.service
└─2071 /usr/local/bin/airspy_adsb -v -f 1 -b -l 29999:beast -l 47806:asavr -c localhost:30104:beast -g 19 -m 20

Apr 11 13:54:21 odroid systemd[1]: Started Airspy ADS-B receiver.
Apr 11 13:54:21 odroid airspy_adsb[2071]: Listening for beast clients on port 29999
Apr 11 13:54:21 odroid airspy_adsb[2071]: Listening for asavr clients on port 47806
Apr 11 13:54:21 odroid airspy_adsb[2071]: Acquired Airspy device with serial XXXXXXXX
Apr 11 13:54:21 odroid airspy_adsb[2071]: Decoding started at 20 MSPS
Apr 11 13:54:33 odroid airspy_adsb[2071]: Push client connected to localhost:30104 (beast)
root@odroid:~#

Sure enough, MyADS-B page claims it is connected and feeding, including MLAT.
In the next few days (barring business travel) I will start with a fresh sd-card from scratch. That can see if ln -s arm-linux-gnueabihf/ld-2.23.so ld-linux.so.3 is necessary. it is included today.

I mean it doesn’t really matter as long as the rest of the system is still working i guess :slight_smile:

I agree… my guess is that you and I think the same about it. Let’s see what the minimum is that we can get away with to get a clean install. You are a rockstar for figuring out how to get it run. Thank you

I gave up because of the apt update error you had. Didn’t realize that wasn’t a problem.
(Only the hardkernel specific stuff like the kernel isn’t available in armhf (32bit), but the rest of the Ubuntu sources including the libraries are available as armhf)

Luckily navzptc gave it another try.

Aren’t you very close to SFO? I would expect a gain of 16 or 17 to give better results with an LNA and good antenna above the roof.

@wiedehopf
Just to let you know, I have done another clean build, using the above you suggested and all working hunky dory - looks like that ’ ln -s arm-linux-gnueabihf/ld-2.23.so ld-linux.so.3’ wasn’t needed after all :grinning:

Once again, VMT for all your hard work in getting this going.

Now, to compare the xu4 against the N2 with same gain settings to see which one wins!!

Would be very surprised if there was any difference.

Do you have it set up in a way where you could check for lost samples or do you still use rc.local without logging?

I’d also recommend my graphs as i’ve built in a display of how much CPU airspy uses:
https://github.com/wiedehopf/graphs1090#graphs1090

I don’t check for lost samples, but both units manage over 20 MSPS, so I don’t think that will be a problem.

I have been comparing daily position/plane numbers between both units (xu4’s), and interesting to see they are quite close with about +4% difference in AC reported between gains of 21 to 16, and positions reported difference under 1%.

gain 21 gives highest AC count and 16 gives most messages with me.

I will setup the logging sometime - using your manual setup which works very well :+1:

1 Like

Aren’t you very close to SFO? I would expect a gain of 16 or 17 to give better results with an LNA and good antenna above the roof.

I am close to SFO, indeed. Before I left for the office this morning I set the gain to 18. Let’s see how it will run. I may have to play around with the gain a bit to find the optimal one.

so that is the answer then. Clean install without the ln-statement. Glad it works.

There is an Armbian image now available for the N2 - ver.5.86.

I have just loaded the ‘stretch’ version from their download page https://www.armbian.com/odroid-n2/ and whilst it is not officially supported, some clever people have been working on various images for a while.

It works very well indeed - similar cpu% being used compared to the ubuntu image from odroid, but htop etc work on the Armbian image, where I had problems with ubuntu.

Well worth a try - have piaware/dump-fa 3.71 working here fine.

2 Likes