Suggestions re RPI 3B hdmi output quit


#1

my RPI has been online for over 30 days, no problem. i usually leave the monitor off. today i disconnected the HDMI cable to the monitor to use the monitor for a few minutes with another device (camera). when i reconnected the RPI hdmi cable to the monitor i got a “no signal” message. the monitor works fine with other devices, (camera and PC). the cable is also fine (works when i feed PC hdmi out to monitor using the RPI hdmi cable)…but no signal from RPI all of a sudden. i rebooted the RPI but still no signal. i removed the SD card, reinserted and rebooted, still no signal…

any advice?


#2

see my original post, problem is “semi” solved. when i plug into a HP monitor (using HDMI) all is well…so only the old Vizio (that i had been using for 30 plus days and worked well) does not work with the RPI (3B). as noted, the Vizio still works with other devices (camera and PC) but all of a sudden the RPI will not “drive” the Vizio… any suggestions?


#3

Not really, maybe it is not automatically recognized and you have tomanually change the source?

Maybe attach the hdmi cable, then unplug the power cable of the screen, wait a little and plug it in again. That solves a dvi monitor/thin client connection problem I have at work, where the thin client is not recognized.


#4

thanks for the suggestion. unfortunately this (hard reset of monitor) didn’t work.


#5

Since it looks like the HDMI was working at some point your problem is probably is the HDMI circuit it off.

The official raspbian image will have the HDMI output default to OFF and during the boot it will try to detect if a HDMI monitor is connected and turn on the HDMI. Usually a reboot with a HDMI monitor connected will fix this problem.

The PiAware SD card image turns ON the HDMI circuit by default. So it should always be running and will try to hot connect HDMI monitors. HDMI monitors usually works without a reboot but a reboot should fix any HDMI problems.


#6

The two options for HDMI monitors are
hdmi_force_hotplug=1
hdmi_drive=2

They are located in /boot/config.txt
This is the raspberry pi boot configuration file and not the piaware configuration file.


#7

thanks david, much appreciated


#8

hello david, there is a posting on this site (setting gain for beginners, or similar name) that is very nice. it is a step by step procedure for people like me…can you advise similar line by line for me to get into the raspberry pi boot configuration file and see where the hdmi drive is currently set. (as noted above, the pi (3b) hdmi drive quit working (it had been working well for a month or more) on a vizio monitor and then i unpluged, re-plugged a few minutes and nothing…the hdmi drive does work on a newer HP monitor (but my wife won’t let me have it for my ADS-B setup)
what i have read in raspberry pi forums is that setting the drive level to “2” usually corrects the issue i am having


#9

You can take out the SD card out of your RPi and through your PC edit the config.txt file for the settings.
The config.txt file is for RPi settings.
The piaware-config.txt is for PiAware settings.

If you want to remotely access the RPi without taking out the SD card you would need to setup SSH (secure shell connection).

Follow step 3 and 4 on the raspberry pi website for SSH access.

  1. enable SSH access by taking out the SD card and making a new file called ssh.txt on the SD card (using your PC)

  2. Install one of the clients on your PC in step 4 and then connect to the Raspberry Pi through your PC.

Your RPi IP is on your stats page
Site Local IP: 192.168.1.124

Once you are connected with the SSH client you can then type on the command line to edit the config.txt file.

sudo nano /boot/config.txt

Add or edit the settings you want.