Stats page issues?

For the past couple of days, the stats page does not update or reflect the current status of my RPI’s. I have multiple RPI’s and the stats page only shows the first 4 of many that I have operating. Nightly, I see the same problem, but it only lasts for about an hour or so.

I only see a circle, circling next to the RPI ID number, and the “gear icon” is missing.
Can the Flightaware staff look into this? Does anyone else have this problem?
Eastern US, South Carolina.


1 Like

I’ve been having the same error for about 12 months.

I usually look at the stats pages about 9am eastern Australian summer time (2200 UTC) and can only see the first 4 or 5 of my stations.

It stays like this on and off for the next 8 hours.

Someone else mentioned it a week or two ago.


1 Like

obj, how can I put in a service repair ticket to look into this problem?
Thank you, in advance.


DUH!!! Solved- Ctrl- F5 did it for me…

1 Like

I pressed Ctrl-F5 and it refreshed the screen and all looked OK.

Sadly it lasted about 8 hours and now I am back to only seeing stats for five of my eight Pi.

No amount of Ctrl-F5 fixes it now.

Win10 and Chrome or Edge browser.

Open to any suggestions.


Same problem here since this morning 06 UTC

I’m having the same problem again…

For me it is fixed again since 20 UTC yesterday evening.

There is an outstanding stats issue that needs looking into that is possibly contributing here, but unfortunately everyone who can look at it (me included!) is on leave or travelling at the moment so it may be a few days.

Disregard…all seems ok now.

When did the other local sites section disappear (the on that showed readers within xxx miles of me)? I used this to gauge how my reader was working compared to other local sites. Half the fun of this hobby is catching up to the leader, etc!


Hope you all have a wonderful break and looking forward to getting this resolved.


It hasn’t disappeared(at least for me it hasn’t).
I can see the nearby sites section at the bottom when I look at your stats.

Thnx…it did come back. Was odd but all good now!

1 Like

the issue with not all sites loading is back again unfortunately.
I only get the first 5 ( out of 11) loaded. at the moment.

1 Like

I rarely look at my stats. Also I never compare my rank with rank of neighbouring sites. This saves me from frustration and anger. Dont care, be happy. :slightly_smiling_face: :wink:

1 Like

I only use them for reference, I’m happy as long as the infrastructure keeps running at home :wink: Rank comparison, I don’t use it for that either.

Supposedly, the FAA has a blackout on their computers. Just saw this on twitter.

I look at my stats every day to make sure that all my receivers are working and Flightaware is receiving all the data.

Only 4 sites are loading at the moment.


Seems to be fixed again on my recievers :wink: haven’t been home for 10 hrs but it recovered again.

I’ve been getting steady timeouts at the site. Update returns this error: Failed to fetch . Could not connect to (, connection timed out