FlightAware Discussions

Starting UAT using Nooelec Nano 3 (v5)

On Raspberry PI 4B, I was having trouble trying to start UAT using Nooelec NESDR Nano 3.
Dump1090-fa start with no issues, but the enabled dump978-fa.service fail with “Error -6” (device in use).
During the initial configuration, as advised, I did the following:

 sudo piaware-config uat-sdr-device driver=rtlsdr,serial=00000978

However, UAT (dump978-fa) fail to start.
Using sudo rtl_eeprom -d1, I find out that the ‘real’ factory serial number was stx:978:0 and not the expected default 00000978.

.....
Current configuration:
__________________________________________
Vendor ID:              0x0bda
Product ID:             0x2838
Manufacturer:           Nooelec
Product:                NESDR Nano 3
Serial number:          stx:978:0
Serial number enabled:  yes
IR endpoint enabled:    no
Remote wakeup enabled:  no

Two methods can fix the issue

  1. Edit the factory serial on the device (using rtl_eeprom)
  2. Change the serial on the config command:

sudo piaware-config uat-sdr-device driver=rtlsdr,serial=stx:978:0

After the fix, all services running as expected.

That’s probably a dongle that’s been previously used for Stratux? That’s the convention they use for serial numbers, IIRC.

It’s a brand new set from Amazon.

Nooelec Dual-Band NESDR Nano 3 Premium ADS-B (978MHz UAT & 1090MHz 1090ES) Bundle for Stratux, Avare, Foreflight, FlightAware & Other Applications. Includes 2 SDRs, 4 Antennas, 5 Adapters