Something very broken


#1

Weird things afoot…

Wanted to look up DAL656 so keyed it in and hit enter. Brings up the flight details for COM5344. :open_mouth: Similarly, DAL657 brings up the flight details for COM5343 :open_mouth: :open_mouth: . I can click on the links from the TXKF airport page and the flights load ok but not when directly keyed.

Edit: When entering DAL656 from the forum index it loads ok first time, but if you key it in a second time it gives you COM5344 again. :open_mouth: :open_mouth:

Opera 10.50


#2

More issues… :confused:

DAL494 works ok if you click the link from the MDSD departures but when entering it directly it morphs into ASQ494. :open_mouth:

Edit: and same thing as above - if you key it in from the forums it works ok first time but try keying it in again and you’ll get ASQ494. :open_mouth:


#3

Are you sure you’re not adding another digit?

I’m unable to reproduce your findings, and none of our Delta codeshare ranges change the numbers except some Comair flights that drop the 6.


#4

:exclamation: No Mark… I am not adding additional digits… :neutral_face:

Still broken. Just tried DAL493 which gives me SKW493 instead. WTF :open_mouth:


#5

Works fine for me on IE8


#6

Works for me.


#7

No problemo on Firefox.

Rob, have you been drinking again? :laughing:


#8

No squawks here on Opera10. However, an extra numerical digit in the flight number for either of the DAL flights brings up COM flights. But again, using 6656, 6556, or 6566 instead of DAL 656 didn’t yield any of the reported COM flight numbers.


#9

I don’t use FF but I tried it on Chrome and IE6 which are the only other browsers I have on this machine (I don’t use IE6 but I tried it as it’s there). The same issue is apparent using those browsers as well. First time you key in DAL656 with Chrome it pulls up the correct details but type in DAL656 a second time from there and it returns COM5344.

With IE6 the first time you type in DAL656 it gives you COM5344.

The main PC is shared with others and uses Adblock in both Opera and Chrome (don’t blame me, I didn’t put them on there!) but there’s no Adblock on IE6. I tried my laptop which doesn’t use any Adblockers and the problem is still there, so it’s definitely nothing to do with those just in case someone was about to ask if I was using any.

I also tried it logged out and logged in and it doesn’t make any difference there either.

I can’t believe that NO-ONE else is getting this issue. This is across 3 different browsers and 2 completely different systems (ancient Compaq desktop pre-Pent 1 and top end HP laptop with all the bells and whistles). Both do run XP though so are all you guys running Vista or 7 ? Perhaps OS related?

I’ve even recorded some avi files of the processes for you to see what happens

Chrome - sendspace.com/file/6iqgk2 (12 MEG)
Opera - sendspace.com/file/bb7gpi (12 MEG)
IE6 - sendspace.com/file/1dp0dc (14 MEG)

The processes are laggy due to CamStudio running. The browsers (with exception of IE) normally run very fast.


#10

I also was able to reproduce this. Typed in DAL656 hit enter, flight came up normally. Typed in dal656 again, hit enter and came up with COM 5344 (copied from top of page: FlightAware couldn’t find flight tracking data for COM5344 just yet.)

ROBK IS CORRECT!!!


#11

:slight_smile: :slight_smile:

I now await the onslaught of FF-fanboys with the usual “every other browser in the world is shit except FF… Works fine on FF… You should change to FF… FF is open source and therefore automatically better than anything else ever made in entire world… FF FTW!” etc etc etc etc yawn etc yawn. :laughing:


#12

My! My! Did we get up on the wrong side of the browser this morning?


#13

Confirmed here. Both FF and IE8.


#14

“Every other browser in the world is shit except FF… Works fine on FF… You should change to FF… FF is open source and therefore automatically better than anything else ever made in entire world… FF FTW!”

:wink:


#15

I entered DAL656 into the “track any flight” field while in the forum DAL656 came up. Then when I entered DAL656 again, COM5344 came up with a protest that the flight doesn’t exist.

When I entered DAL656 directly into the “track any flight” field from within the main site (i.e. not when I was in the forum". The COM5344 protest came up.
Tried: DAL657, got COM5343 (flight doesn’t exist)
DAL659 - got COM5341 (flight doesn’t exist)
DAL658, got COM5342 with the following data:

Aircraft (XXXX/ - track or photos)
Origin Montreal-Trudeau (CYUL / YUL - track or info)
Destination John F Kennedy Intl (KJFK - track or info)

Route n/a
Date Wednesday, Jul 09, 2008
Duration Unknown
Status result unknown
Scheduled Actual/Estimated
Departure 06:28 EDT 06:28 EDT
Arrival 07:07 EDT result unknown
Speed
Altitude Unspecified

This doesn’t occur when I use the “track commercial flight” field.


#16

Nobody asked, but yes, I’ve been drinking again.
You know, St Paddy’s Month.


#17

You have been drinking, isn’t it St. Patty’s?


#18

Nope! I was just giving the Fire of the Fox fan-boys a good dowsing of water before they got chance to get started! :stuck_out_tongue:


#19

I don’t think it’s anything firefox can fix anyway. :question:
Anyway, I have the described result when I enter DAL656 in the “Flight/Tail” box, hit enter, re-enter DAL656, and hit enter again.
Using the “Type part of airline name…” box doesn’t come up with that error.


#20

Only to the accursed English invaders!