Setup help

Hi All
I need to set up auto log in and auto reconnect for my wifi connection.
Can someone help?
Also flight aware image will not let my usb n dongle work.
If I download noobs it works fine.
Can anyone help me get my system going again?


If I remember correctly, this worked for me,

sudo nano /etc/network/interfaces


auto wlan0
iface wlan0 inet dhcp
wpa-ssid my-router-ssid
wpa-psk my-router-password

(substitute my-router-ssid and my-router-password for your own router’s ssid and password)

save and close

check it with

sudo ifup wlan0

reboot and check if it auto connects.

sudo reboot



Do you want this to work with the piaware or noobs image?
If noobs then the setup commands(after WIFI is working) are at

For piaware you may need to provide the WIFI dongle details.
piaware doesn’t seem to use the same repositories as noobs or raspbian.
You may need to add the repositories that support your dongle.


I tried that but it says no such directory or file when I tried to save it

When I try to write to a file in the terminal window.
It tell my access denied.
How do I get admin authority to write to files?

using sudo nano /etc/network/interfaces should give you write access.

@ kh8qho

When you open the interfaces file, is there anything in there or is it blank (empty) ?

It should have some text already in there, if not, you probably aren’t opening the right file (typo).

sudo should give you admin rights (as in SU or root user or in Windows speak ‘Administrator’).


No it is not blank and I don’t know why I can’t write to it has me beat. But still hacking away at it

Were you able to get Raspbian to recognize your WiFi device? If so this page has all the information you need to setup your device once it is seen by Raspbian. There is also instructions on making a script which will automatically reconnect your device if for some reason it losses it’s WiFi connection. Following these instructions will make the setup much more easier than trying to manually do it yourself editing interface configuration files.

Thank you I’ll give that a try tomorrow I’ll keep you up to date it looks pretty good

Also I never did get it to recognize my dual band Wi-Fi adapter, from the forums I don’t think it’s possible yet anyways I put the old one back in and now I’m just trying to work on the auto reconnect if the Wi-Fi goes down

I just went through a particularly tricky wifi dongle.

what does



It should show something like this

Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 0bda:2838 Realtek Semiconductor Corp. RTL2838 DVB-T
Bus 001 Device 005: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter

If the adapter shows, what are the results from


It should have something like this in it (note: this is for my wifi dongle, yours may be different)

rt2800usb              17716  0
rt2800lib              71860  1 rt2800usb
rt2x00usb               8545  1 rt2800usb
rt2x00lib              36833  3 rt2x00usb,rt2800lib,rt2800usb

More than likely, the correct driver isn’t on your system from the image. If a kernel update is available, it may fix the issue as well.

Can save files now was messing up with the sudo command

I have the drivers that came with it its in a tar file but I cannot figure out how to install them

1susb says command not found.
I am running this in the terminal window

I’m sure the command is lsusb and not 1susb. (letter ‘l’ instead of number ‘1’)

Ok thank you, but it still says command not found I am running this from the terminal window is that correct

Hmm… not sure then. The lsusb command should be available but maybe in your case it is not installed? Try to install usbutils:

sudo apt-get install usbutils

Terminal window should be fine.

The command is LSUSB (in lowercase, not a number 1 at the beginning).

To install a tar file, its along the lines of

tar -xzf file-name.tar.gz
cd file-name
sudo make install

Use the tar’d file name in place of file-name in the example above


Thank you the L is the wild letter I messed up on