Script error? getting stuck

I’m trying to install the piaware 8.2 using this script:

sudo bash -c "$(wget -O - https://raw.githubusercontent.com/abcd567a/piaware-ubuntu-debian-amd64/master/install-piaware.sh)
EDIT: the link to the script was the wrong one, now is the correct

I’m using:

root@orangepizero:~# uname -a
Linux orangepizero 5.15.80-sunxi #22.11.1 SMP Wed Nov 30 11:13:48 UTC 2022 armv7l armv7l armv7l GNU/Linux
root@orangepizero:~# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 22.04.2 LTS
Release: 22.04
Codename: jammy
root@orangepizero:~# dpkg --print-architecture
armhf
root@orangepizero:~# dpkg --print-foreign-architectures
root@orangepizero:~# cat /etc/os-release
PRETTY_NAME=“Armbian 22.11.4 Jammy”
NAME=“Ubuntu”
VERSION_ID=“22.04”
VERSION=“22.04.2 LTS (Jammy Jellyfish)”
VERSION_CODENAME=jammy
ID=ubuntu
ID_LIKE=debian
HOME_URL=“https://www.ubuntu.com/
SUPPORT_URL=“https://help.ubuntu.com/
BUG_REPORT_URL=“Bugs : Ubuntu
PRIVACY_POLICY_URL=“https://www.ubuntu.com/legal/terms-and-policies/privacy-policy
UBUNTU_CODENAME=jammy
root@orangepizero:~# apt-cache policy dump1090-fa
dump1090-fa:
Installed: 8.2
Candidate: 8.2
Version table:
*** 8.2 100
100 /var/lib/dpkg/status

I am getting a lot of errors while running the script but it still running until I get stuck on this:

make -C dump978 faup978 VERSION=8.2
make[2]: Entering directory ‘/root/piaware_builder/package-bullseye/dump978’
g++ -g -O2 -ffile-prefix-map=/root/piaware_builder/package-bullseye=. -fstack-protector-strong -Wformat -Werror=format-security -std=c++11 -Wall -Wno-psabi -Werror -O2 -g -Ilibs -Wdate-time -D_FORTIFY_SOURCE=2 -DVERSION="8.2" -c -o faup978_main.o faup978_main.cc

Can somebody help me here?
Running fr24 and planefinder with no errors

@Timex

Want minimum problems in installation? Use Bullseye instead of Jammy.

I tried, but my orange pi don’t show up in my network, looks like it didn’t boot with bullseye. It only connects to my lan with the jammy running on it

I don’t know why I need to make dump978 if I will just use the 1090 :face_with_monocle:

It is not buildidng dump978, it s building faup978

As piaware is used to feed both 1090 and 978 data to Flightaware, two uploders (faup1090 ad faup978) are it’s inegral part. The build process builds both uploaders

faup = flightaware uploader

1 Like

Oh, okay, didn’t notice that, I’m trying to install the bullseye version. Without success until now, will keep trying the older versions

1 Like

Well, it didn’t work, installed the Armbian 21 Bullseye, than updated to 22 and, still stuck on:

make[2]: Entering directory ‘/root/piaware_builder/package-buster/dump978’
g++ -g -O2 -fdebug-prefix-map=/root/piaware_builder/package-buster=. -fstack-protector-strong -Wformat -Werror=format-security -std=c++11 -Wall -Wno-psabi -Werror -O2 -g -Ilibs -Wdate-time -D_FORTIFY_SOURCE=2 -DVERSION="8.2~bpo10+1" -c -o faup978_main.o faup978_main.cc

Compiling faup978 is memory hungry, how much RAM does your hardware have?

Why not try to install from Flightaware repository if you now have changed from Jammy to Bullseye, and have architecture armhf?

wget https://flightaware.com/adsb/piaware/files/packages/pool/piaware/f/flightaware-apt-repository/flightaware-apt-repository_1.1_all.deb
sudo dpkg -i flightaware-apt-repository_1.1_all.deb
sudo apt-get update
sudo apt-get install piaware
1 Like

Okay, that really worked.
I was able to reactivate my feeders, everything works fine and great now, but I really don’t know what I did different from the other time that I’ve tried.

I wasn’t able to compile the program tho…

After search a lot I found the repository link to the armh version, it wasn’t easy to find.

Where can I find those links more accessibly, it would help me and saved a lot of time.

Go to following web page
https://flightaware.com/adsb/piaware/install

Scroll down till you see the links shown in screenshot below:

 

CLICK ON SCRENSHOT TO SEE LARGER SIZE

1 Like

Oops, I just mess up things here,

when I said that I wasn’t able to find the repository link to install the armh version, I was refering myself to the FR24 armh version (which is super unfriendly to any kind of support, and I still don’t know how to find the repository links).

I tried to follow these suggested path (PiAware - dump1090 ADS-B integration with FlightAware - FlightAware). Well, at the first time I manage to install the software with no errors, but, I couldn’t make the software link to my user. The status on pi showed that the connection was stablished but I had “offline” status in the service. I formatted the SD and tried to install everything again, without success one more time, It couldn’t connect to my previously created feed. Then I started chatting with the support team, which instructed me to do the same thing that I have done one more time (re-flash the SD card). When I was about to do it, I saw that the Unique Identifier wasn’t the same as my feeder, so, I just changed the code to the one that was on my feeder and it started to work again.

Just n00b things all around.

 

https://www.flightradar24.com/share-your-data

 

OR

 

https://www.flightradar24.com → Add covrage → Share your data

 

image

OMG, I feel more and more stupid on every reply LOL.

Just needed to click on LINUX TAB on the link that you mentioned hahahaha

Too easy, damn.
Thank you sir