FlightAware Discussions

Readsb

Not sure if any support is available for readsb. would like to uninstall it. Tried installing readsb on UAT-only piaware to make easier gain adjustments. After installing readsb the UAT only receiver became a 1090 receiver. There was no uninstall script listed. tried to configure readsb for uat, but ended up disabling it so it turned back toi a uat receiver
sudo nano /etc/default/readsb

Blockquote

readsb configuration

This is sourced by /etc/systemd/system/default.target.wants/readsb.service as

daemon startup configuration.

RECEIVER_OPTIONS="–device 0 --device-type none --uat-receiver-type sdr --gain 20.7 --ppm 0"
DECODER_OPTIONS="–max-range 360"
NET_OPTIONS="–net --net-heartbeat 60 --net-ro-size 1200 --net-ro-interval 0.1 --net-ri-port 0 --net-ro-port 30002 --net-sbs-port 30003 --net-bi-port 30004,30104 --net-bo-port 30005"
JSON_OPTIONS="–json-location-accuracy 2"

Blockquote
logfile for readsb uat receiver converted 10 1090 by readsb config errors disable readsb - Pastebin.com

Where?

Looks like the complete debian package.

sudo apt remove readsb

Thanks, did not know about sudo apt remove readsb

better use purge, as it will remove all configuration files as well.
For clean up, purge is better than remove.

sudo apt purge readsb  
2 Likes

Optionally use this for also removing the dependencies if not used any longer for other things

sudo apt autoremove readsb

Applying command line options from other programs is usually not the way to go.
readsb doesn’t do 978, it’s pretty similar to dump1090-fa in regards to basic functionality and depending on the fork also has some extra functions.

That config file just has command line options which often can be checked with --help:

readsb --help

Just for the future, it’s important to let people know how you installed something.
I just took a wild guess that you used my script or my how-to.
If you would let me know i could maybe even add a note how to remove it.

I followed Automatic installation for readsb · wiedehopf/adsb-scripts Wiki · GitHub to try readsb on a UAT only pi. It started receiving 1090 instead of 978. Trying to change config options to UAT seemed to disable it. A note about uninstalling it would be helpful, also if it works with only 1090. Thank you.