Quick Gain Settings help

I’ve searched to no avail, Just added the ADS-b filter made by flightaware. I have the Pro Stick as well. Once added I went from 35 current planes being to tracked to just 1. Still using a tuned stock mini antenna. Worked fine for me so far. I was getting 50-100 ish miles

So Details

Pi 2
ADSB Filter
Stock Antenna placed outside cut to tune as told on here
Lost my planes

I tried looking for info on how to set the gain and tried several ones but ended up now with no planes being tracked. SOOOOooo.


Update**Took Filter out and started tracking more planes…

Look at the script in this thread

I did it today to confirm my setting.

What setting are you using?
Lots of people seem to work with Max (with the filter).
I had to dial it back to 40, however, I have a 9db gain antenna feeding LMR400 and the FA Pro stick with FA Filter.

Well, gain setting will vary with each individual system. Depends on antenna location, antenna gain, and loss in coax cable.

My system:
Antenna: Cantenna, gain 2 dBi
Location: indoors, but at 60 ft above ground near large glass window.
Coax cable: 12 ft / 4 m RG6 coax.
Amplifier: No amplifier.

My gain settings found by trial & error:

Pro Stick, No Filter, best settig 30 to 35 dB.

Pro Stick + Fliter, best setting “max”.

What is Max? On the code line what Number should I put. I tried several so no major differences.

Also, I found out why I only was picking up one plane before. Some DA didn’t screw the line into the filter all the way. Go Figure. Plane count is back to normal. I guess I should see more msg.s now vs plane count up correct?

max is max, just type that word instead of the number

Regards, Andrew

:smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley:
“max” is abbreviation for “maximum”.
The RTL tuner chip gain can be set in steps.
It’s maximum gain step is 49.6 dB, so theoretically “max” = 49.6
However, RTL somewhat overshoots this value when “max” is used instead of it’s numeric value 49.6

“max” is identical to “use the highest reported manual gain setting”; there’s no overshoot.

So this would look like this then?

PROG_ARGS="--quiet --net --gain max --net-fatsv-port 0"

Thanks Oliver for clearing my misunderstanding about “max”.

I think I mixed up “max” with “agc” and “-10”.
Now I recall that the problem is with “agc” (digital agc of RTL2832U) and “-10” (analog agc of tuner chip R820T). The problem originates with librtlsdr which controls the tuner & mixer gains with one setting, not independently.

Is it “agc” which overshoots, or do I still remember wrongly?

I avoid using both “agc” and “-10”, and only use “max” or a numeric value like 49.

Just to confuse things further, dump1090 doesn’t understand either “max” or “agc” on the command line. Those gain settings are interpreted by dump1090-mutability’s init script and turned into either no gain argument (the default if you don’t specify --gain is maximum gain) and “–gain -10” respectively.

“agc” has an effective gain that’s slightly higher than “max” when using the standard librtlsdr code.

Guy have told em everything except what I need to know. Int eh code line, what Exactly do I put? Is it a number? A word?

Give me an example not more confusing information that does not answer my question.

I hate to be a butt about it but kinda frustrating when you can’t find a simple answer.

You need to see what works. Run the test scripts or just use trial and error.

Start with the max
PROG_ARGS=“–quiet --net --gain max --net-fatsv-port 0”
PROG_ARGS=“–quiet --net --gain 49 --net-fatsv-port 0”

change the number, restart dump1090 and see how it goes.

Thank you Sir! :smiley:

I was doing that and seeing no major effect. So maybe it’s time to get a new antenna as well.

Which dongle you have tried with the filter, generic dvb-t or pro stick?

If you added filter with generic dvb-t stick + stock antenna, dropping of plane count from 35 to 1 is an expected result, as fliter has an attenuation of 6 dB and stock tuned antenna has a gain around 1.5 to 2 dB.

The pro stick has a built in rf amplifier, and covers 6 dB loss due to insertion of filter.

Antenna height is the key. Your stats look a little like my unit with an antenna 3 ft off the ground (sitting on the basement window bars). My 2nd floor bedroom unit gets more as does the big antenna in the attic(soon to be moved to the chimney). If your location is hilly or you are in a valley then there isn’t much you can do.

His setup is in the first post.

It is on top of my Homes Roof on a rear Peak. The north area is blocked by the taller main roof line. I was hoping to see my Msg count go up as there is a cell phone tower less than 1/2 mile away.