FlightAware Discussions

Problems with the dongle?

hi, lately it has happened to me several times that the dongle stops working correctly and goes from 40 planes to 5 instantly, without anything happening. I tried to change the gain, but to no avail, as well as restarting dump190-ago several times

That could also be a broken connection from your antenna. Check cables and that everything is connected properly. Also reboot the whole device.

finally print the output of the command sudo systemctl status dump1090-fa here. Maybe the gain is set incorrect.

I also had a similar issue with my previous Raspberry 4 and i fixed it by changing the USB slot

I don’t remember how the code is formatted.
● dump1090-fa.service - dump1090 ADS-B receiver (FlightAware customization)
Loaded: loaded (/lib/systemd/system/dump1090-fa.service; enabled; vendor preset: enabled)
Active: active (running) since Tue 2020-12-01 07:42:17 GMT; 1h 10min ago
Docs: https://flightaware.com/adsb/piaware/
Main PID: 22909 (dump1090-fa)
Tasks: 3 (limit: 4915)
CGroup: /system.slice/dump1090-fa.service
└─22909 /usr/bin/dump1090-fa --device-index 0 --gain -10 --ppm 0 --max-range 4000 --fix --net --net-heartbeat 60 --net-ro-size 1300 --net-ro-interval 0.2 --ne

Dec 01 07:42:17 raspberrypi systemd[1]: Started dump1090 ADS-B receiver (FlightAware customization).
Dec 01 07:42:17 raspberrypi dump1090-fa[22909]: Tue Dec 1 07:42:17 2020 GMT dump1090-fa 3.8.1 starting up.
Dec 01 07:42:18 raspberrypi dump1090-fa[22909]: rtlsdr: using device #0: Generic RTL2832U OEM (Realtek, RTL2838UHIDIR, SN 00000001)
Dec 01 07:42:18 raspberrypi dump1090-fa[22909]: Found Rafael Micro R820T tuner
Dec 01 07:42:18 raspberrypi dump1090-fa[22909]: rtlsdr: enabling tuner AGC
Dec 01 07:42:18 raspberrypi dump1090-fa[22909]: Allocating 4 zero-copy buffers

I tried to increase the maximum range, I went from 360 to 4000, but apparently it was not that, the gain is usually set to -10 as I have the maximum percentage of messages> 3dBFS (or so it seems on graphs1090 )

ssrdc, I’d be inclined with what Foxhunter said about a bad antenna connection.
I modded my homemade antenna and went from a PL-259 connector into a SO-239 female with a thin lead for a SMA connector on it, and as soon as I added the 9 inch or so adapter coax, my sigs went through the floor. Make sure there’s no stress on your dongle into the pi nor from antenna wire into dongle.
Heat, cold, and wind could all play a factor if you have corroded contacts anywhere or if the antenna wire is moving in the wind.

You say it’ll drop planes seen, but does it ever INCREASE again?

Perhaps try a diff USB port?

I’ll be curious as to the cause should you ever get it figured out…

Gary
K4GHL

Side note:

For the blue FA stick the gain is normally to high set to -10, especially if antenna is outdoor.

I would try a lower value (e.g. 48.0)

From this morning everything seems to have returned ok without having done anything …
As soon as I go where I have the antenna I try to change the usb slot.

I did not know where to ask so I ask you. I ordered 2 rtl-sdr v3 dongles in late August and they never arrived … what should I do?

Please contact adsbsupport@flightaware.com and we’ll get you sorted out.