Feeder Suddenly Stopped Working

Hello all,

I recently put together a feeder using the 1090MHz PiAware ADS-B Kit from FlightAware. Today, out of nowhere, I ran into an issue where no data was being exchanged and I kept getting this error in the log:

“No ADS-B data program seen listening on port 30005 for 3 seconds, next check in 60s”

I’ve physically restarted a few times, ran the “sudo apt purge dump1090-fa” and “sudo apt install dump1090-fa” commands via SSH and even tried the “upgrade and restart PiAware” and "upgrade and restart dump1090 via the control panel but nothing seems to work.

Any ideas?

Please post output of following command:

sudo systemctl status dump1090-fa   

dump1090-fa.service - dump1090 ADS-B receiver (FlightAware customization)
Loaded: loaded (/lib/systemd/system/dump1090-fa.service; enabled; vendor preset: en>
Active: activating (auto-restart) (Result: exit-code) since Tue 2023-04-04 21:08:40>
Docs: PiAware - ADS-B and MLAT Receiver - FlightAware
Process: 2289 ExecStart=/usr/share/dump1090-fa/start-dump1090-fa --write-json /run/d>
Main PID: 2289 (code=exited, status=1/FAILURE)
CPU: 108ms

May be dongle issue. To check your dongle, run following commands, and post output of last command only.

sudo apt install rtlsdr 

sudo systemctl stop piaware dump1090-fa dump978-fa readsb 

rtl_test -t   

All it’s giving me is:

No supported devices found

Unplug dongle, then replug into another USB port
If you are using a USB cable to connect dongle to Pi, remove cable and plug the dongle directly into Pi OR use another cable.

After doing above reboot the Pi, and check status of piaware and dump1090-fa.

Looks like it was a bad USB dongle. I replaced it with a newer one, rebooted, and now I am back in business. Thanks!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.