Dongle not 100%


#1

Hello. I am having an issue with a pro plus dongle where I am getting good results

but then randomly the aircraft count will go down to about 1 aircraft and all I will see is the aircraft on approach to BHD which I have a good view and aircraft fly past at 2000ft. It’s as if the dongle sensitivity is going down even though I’ve got a set gain. Usually restarting dump1090 will resolve this (until it happens again after about 45 minutes) but I bought the RPi and dongle to upgrade my setup so that I could just configure it then leave it or else I would just keep feeding from my PC when I use it. Does anyone know why? Not sure if it could be a Pi or dongle issue. I did think the dongle was overheating before but I’m not sure that’s the case since the dongle is still very hot while it works and a restart of dump1090 will fix it. Thanks.


#2

Morning,

I have noticed a similar effect when light aircraft and helicopters fly within about 1km and under 1500’.

The close aircraft stops reporting for 5 or 6 seconds and has a signal strength of about -1 to -1.4 and the Age list on Skyview suddenly shows greater than zero for 2/3 to 3/4 of the aircraft in the list. (usually only about 10%)

I think the local aircraft is overloading the front end of the amplifier or receiver and it is blocking most signals until it turns or flies further away.

In my case it can be fixed by reducing the Gain of the Pro Stick Plus from the default -10 to 45 (or less) and restarting Piaware

SSH to the Pi and log in.

type piaware-config rtlsdr-gain 48
press Enter

type sudo systemctl restart dump1090-fa
press Enter

Changing the gain will affect your maximum range and for me it changes the point where I lose signal for planes landing at the airport about 20km away.

S.
.


#3

What pi and dongle are you using? I had a lot of trouble getting my zero W to work properly and found the answer was to use a USB extension cable to get the pi and dongle 50-80cm apart. It wasn’t behaving like yours though.

In addition to SweetPea11’s suggestion, I have found the gain optimisation script useful. I did change the time period between gain settings to 5 sec though as I found 62 secs was too long. The planes in my range moved too much in 17 mins (which is how long it takes each cycle) for me to get any really useful data. The script will leave the gain set at whatever the last test setting was (i.e. if it runs through 5 times, it’ll be set on 20.7)