FlightAware Discussions

SOLVED/SOLUTION Added 978 antenna/receiver, but can't get it working

So I’m having some problems getting my setup to work properly after making an addition to my setup. Here’s what I started with:

Raspberry Pi 3B+ running Rasbian with FA package installed using blue FA dongle, installed directly in USB (using no USB hub or power source other than official RPi power adapter).

System has been operational for about a year with no issues.

Here’s what I did:

Added a second ADSB dongle - Orange FA with a tune 978mhz antenna. Followed notes from a few tutorials and successfully added the dump978 package and serialized the dongles. Ran into problems, and saw that power issues were often to blame, so I tried two different powered USB hubs to take load off the RPi, to no noticeable affect.

The situation:

Dump1090 continues to operate properly, but I cannot get dump978 to function. I’m not good enough with Linux to fully understand/troubleshoot this problem.

Here’s some diagnostic information:
pi@raspberrypi:~ $ sudo systemctl status dump978-fa
● dump978-fa.service - dump978 ADS-B UAT receiver
Loaded: loaded (/lib/systemd/system/dump978-fa.service; enabled; vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Thu 2021-10-07 12:51:51 PDT; 8s ago
Docs: PiAware - ADS-B and MLAT Receiver - FlightAware
Process: 6539 ExecStart=/usr/share/dump978-fa/start-dump978-fa (code=exited, status=1/FAILURE)
Main PID: 6539 (code=exited, status=1/FAILURE)

Oct 07 12:51:51 raspberrypi systemd[1]: dump978-fa.service: Failed with result ‘exit-code’.

rtl_test -t
Found 2 device(s):
0: Realtek, RTL2838UHIDIR, SN: 00001090
1: Realtek, RTL2832U, SN: 00000978

Using device 0: Generic RTL2832U OEM
usb_claim_interface error -6
Failed to open rtlsdr device #0.

sudo systemctl status piaware
● piaware.service - FlightAware ADS-B uploader
Loaded: loaded (/lib/systemd/system/piaware.service; enabled; vendor preset: enabled)
Active: active (running) since Thu 2021-10-07 12:19:59 PDT; 34min ago
Docs: PiAware - ADS-B and MLAT Receiver - FlightAware
Main PID: 624 (piaware)
Tasks: 6 (limit: 4915)
CGroup: /system.slice/piaware.service
├─ 624 /usr/bin/piaware -p /run/piaware/piaware.pid -plainlog -statusfile /run/piaware/status.json
├─ 773 /usr/lib/piaware/helpers/faup1090 --net-bo-ipaddr localhost --net-bo-port 30005 --stdout --lat 36.031 --lon -115.150
├─1092 /usr/lib/piaware/helpers/fa-mlat-client --input-connect localhost:30005 --input-type dump1090 --results beast,connect,localhost:30104 --results beast,listen,30105 --results ext
└─7020 /usr/lib/piaware/helpers/faup978 --connect localhost:30978

Oct 07 12:54:14 raspberrypi piaware[624]: faup978 exited normally
Oct 07 12:54:14 raspberrypi piaware[624]: will reconnect to dump978-fa in 30 seconds
Oct 07 12:54:44 raspberrypi sudo[7011]: piaware : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/bin/netstat --program --tcp --wide --all --numeric
Oct 07 12:54:44 raspberrypi sudo[7011]: pam_unix(sudo:session): session opened for user root by (uid=0)
Oct 07 12:54:44 raspberrypi sudo[7011]: pam_unix(sudo:session): session closed for user root
Oct 07 12:54:44 raspberrypi piaware[624]: ADS-B data program ‘dump978-fa’ is listening on port 30978, so far so good
Oct 07 12:54:44 raspberrypi piaware[624]: Starting faup978: /usr/lib/piaware/helpers/faup978 --connect localhost:30978
Oct 07 12:54:44 raspberrypi piaware[624]: Started faup978 (pid 7020) to connect to dump978-fa
Oct 07 12:54:44 raspberrypi piaware[624]: faup978(7020): Connecting to localhost:30978
Oct 07 12:54:44 raspberrypi piaware[624]: faup978(7020): Connected to [::1]:30978

sudo piaware-config
allow-auto-updates yes # value set at /etc/piaware.conf:7
allow-manual-updates yes # value set at /etc/piaware.conf:8
uat-receiver-type sdr # value set at /etc/piaware.conf:9

sudo journalctl --no-pager -u dump978-fa is giving the following repeating log about every 30 seconds:
Oct 07 12:58:19 raspberrypi systemd[1]: dump978-fa.service: Service hold-off time over, scheduling restart.
Oct 07 12:58:19 raspberrypi systemd[1]: Stopped dump978 ADS-B UAT receiver.
Oct 07 12:58:19 raspberrypi systemd[1]: Started dump978 ADS-B UAT receiver.
Oct 07 12:58:19 raspberrypi dump978-fa[7592]: raw-port: listening for connections on 0.0.0.0:30978
Oct 07 12:58:19 raspberrypi dump978-fa[7592]: raw-port: listening for connections on [::]:30978
Oct 07 12:58:19 raspberrypi dump978-fa[7592]: json-port: listening for connections on 0.0.0.0:30979
Oct 07 12:58:19 raspberrypi dump978-fa[7592]: json-port: listening for connections on [::]:30979
Oct 07 12:58:19 raspberrypi dump978-fa[7592]: linux; GNU C++ version 6.2.0 20161010; Boost_106100; UHD_003.009.005-0-unknown
Oct 07 12:58:19 raspberrypi dump978-fa[7592]: usb_claim_interface error -6
Oct 07 12:58:20 raspberrypi dump978-fa[7592]: Found Rafael Micro R820T tuner
Oct 07 12:58:20 raspberrypi dump978-fa[7592]: usb_claim_interface error -6
Oct 07 12:58:20 raspberrypi dump978-fa[7592]: SoapySDR: using maximum manual gain 49.6 dB
Oct 07 12:58:20 raspberrypi dump978-fa[7592]: SoapySDR: using stream setting buffsize=262144
Oct 07 12:58:25 raspberrypi dump978-fa[7592]: Message source reports error: TIMEOUT
Oct 07 12:58:25 raspberrypi dump978-fa[7592]: Abnormal exit
Oct 07 12:58:25 raspberrypi systemd[1]: dump978-fa.service: Main process exited, code=exited, status=1/FAILURE
Oct 07 12:58:25 raspberrypi systemd[1]: dump978-fa.service: Unit entered failed state.
Oct 07 12:58:25 raspberrypi systemd[1]: dump978-fa.service: Failed with result ‘exit-code’.

Sooo, any ideas where I went wrong, what to do about it, or additional info you might need?

are you sure that you trying to connect the correct dongle? Since you serialized them, you would need to be sure that the config file is pointing at the right one. For me, when I look at the config file using
cat /etc/default/dump978-fa
it includes the following line:
RECEIVER_OPTIONS="--sdr driver=rtlsdr,serial=00000978 --format CS8 --sdr-gain 19.7"
Note the added serial number that has to include an exact number of zeroes.

Thanks, this is definitely something that I missed.

I corrected this using the command:

sudo nano /etc/default/dump978-fa

Wrote out the changes successfully (verifying the number of 0’s), rebooted, and ensured that the changes were not overwritten. Unfortunately dump978 still is not working. Here’s a current log:

sudo journalctl --no-pager -u dump978-fa
– Logs begin at Thu 2016-11-03 10:16:42 PDT, end at Thu 2021-10-07 13:48:59 PDT. –
Oct 07 13:37:16 raspberrypi systemd[1]: Started dump978 ADS-B UAT receiver.
Oct 07 13:37:17 raspberrypi dump978-fa[502]: raw-port: listening for connections on 0.0.0.0:30978
Oct 07 13:37:17 raspberrypi dump978-fa[502]: raw-port: listening for connections on [::]:30978
Oct 07 13:37:17 raspberrypi dump978-fa[502]: json-port: listening for connections on 0.0.0.0:30979
Oct 07 13:37:17 raspberrypi dump978-fa[502]: json-port: listening for connections on [::]:30979
Oct 07 13:37:19 raspberrypi dump978-fa[502]: linux; GNU C++ version 6.2.0 20161010; Boost_106100; UHD_003.009.005-0-unknown
Oct 07 13:37:19 raspberrypi dump978-fa[502]: usb_claim_interface error -6
Oct 07 13:37:20 raspberrypi dump978-fa[502]: Found Rafael Micro R820T tuner
Oct 07 13:37:20 raspberrypi dump978-fa[502]: Found Rafael Micro R820T tuner
Oct 07 13:37:20 raspberrypi dump978-fa[502]: Exact sample rate is: 2083333.135571 Hz
Oct 07 13:37:20 raspberrypi dump978-fa[502]: [R82XX] PLL not locked!
Oct 07 13:37:21 raspberrypi dump978-fa[502]: SoapySDR: using maximum manual gain 49.6 dB
Oct 07 13:37:21 raspberrypi dump978-fa[502]: SoapySDR: using stream setting buffsize=262144
Oct 07 13:37:21 raspberrypi dump978-fa[502]: [::]:30978: accepted a connection from [::1]:42410
Oct 07 13:37:21 raspberrypi dump978-fa[502]: [::]:30978: accepted a connection from [::1]:42424
Oct 07 13:38:41 raspberrypi dump978-fa[502]: Message source reports error: TIMEOUT
Oct 07 13:38:41 raspberrypi dump978-fa[502]: Abnormal exit
Oct 07 13:38:41 raspberrypi systemd[1]: dump978-fa.service: Main process exited, code=exited, status=1/FAILURE
Oct 07 13:38:41 raspberrypi systemd[1]: dump978-fa.service: Unit entered failed state.
Oct 07 13:38:41 raspberrypi systemd[1]: dump978-fa.service: Failed with result ‘exit-code’.
Oct 07 13:39:11 raspberrypi systemd[1]: dump978-fa.service: Service hold-off time over, scheduling restart.
Oct 07 13:39:11 raspberrypi systemd[1]: Stopped dump978 ADS-B UAT receiver.
Oct 07 13:39:11 raspberrypi systemd[1]: Started dump978 ADS-B UAT receiver.
Oct 07 13:39:11 raspberrypi dump978-fa[1574]: raw-port: listening for connections on 0.0.0.0:30978
Oct 07 13:39:11 raspberrypi dump978-fa[1574]: raw-port: listening for connections on [::]:30978
Oct 07 13:39:11 raspberrypi dump978-fa[1574]: json-port: listening for connections on 0.0.0.0:30979
Oct 07 13:39:11 raspberrypi dump978-fa[1574]: json-port: listening for connections on [::]:30979
Oct 07 13:39:11 raspberrypi dump978-fa[1574]: linux; GNU C++ version 6.2.0 20161010; Boost_106100; UHD_003.009.005-0-unknown
Oct 07 13:39:11 raspberrypi dump978-fa[1574]: usb_claim_interface error -6
Oct 07 13:39:11 raspberrypi dump978-fa[1574]: Found Rafael Micro R820T tuner
Oct 07 13:39:12 raspberrypi dump978-fa[1574]: Found Rafael Micro R820T tuner
Oct 07 13:39:12 raspberrypi dump978-fa[1574]: Exact sample rate is: 2083333.135571 Hz
Oct 07 13:39:12 raspberrypi dump978-fa[1574]: [R82XX] PLL not locked!
Oct 07 13:39:12 raspberrypi dump978-fa[1574]: SoapySDR: using maximum manual gain 49.6 dB
Oct 07 13:39:12 raspberrypi dump978-fa[1574]: SoapySDR: using stream setting buffsize=262144
Oct 07 13:39:41 raspberrypi dump978-fa[1574]: [::]:30978: accepted a connection from [::1]:42470
Oct 07 13:39:42 raspberrypi dump978-fa[1574]: [::]:30978: accepted a connection from [::1]:42472

Woohoo, I just got it:

I found looking through other threads the following command:

sudo piaware-status

Which said that faup978 wasn’t running “due to configuration settings”

This led me to search what the heck faup978 was, and apparently it is part of the skyview978 package. I ran the command

apt-cache policy skyview978

and found that skyview 978 was not installed

so I ran the commands:

sudo apt update
sudo apt upgrade
sudo apt install dump978-fa skyview978
sudo reboot

And now it appears that everything is running properly. I’m going to flag this solved, and tried to leave some breadcrumbs of my problems and solution here in case somebody has the same issue. I had to tear through like 30 different threads to find all the answers to this (before and after posting here), so hopefully this helps make it a touch easier for someone else.

2 Likes

Are you sure faup978 is part of skyview978 package?

I am not sure which packsge installs faup978, but feel that:

  • the most probable and logical package to install faup978 is piaware package
  • the next probable package to install faup978 is dump978-fa package
  • the skyview978 package seems to be least probable package to install faup978

@obj can guide us.

 

It is not, it is included as part of the piaware package.

That means that you haven’t told piaware that there is a 978 receiver present via the uat-receiver-type config setting.

1 Like