Problem with reinstalling Piaware on raspberry pi3 (tcl-tls is unmet dependency)


#1

My Piaware system keeps crashing after a power cut, so reinstall time is here again, but the same installation commands I used last time do not now work.


pi@raspberrypi:~ $ sudo apt-get install piaware
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
piaware : Depends: tcl-tls but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

pi@raspberrypi:~ $ sudo apt-get install tcl-tls
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
tcl-tls : Depends: libssl1.0.0 (>= 1.0.1) but it is not installable
E: Unable to correct problems, you have held broken packages.

pi@raspberrypi:~ $ sudo apt-get install libssl1
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package libssl1

Any ideas where to go next?


#2

If this is an piaware image just re-image it to the newest image.
(Step 2 here: https://flightaware.com/adsb/piaware/build)

Like the first time you made the sd-card.
After that you can use
sudo piaware-config feeder-id 12321-34234-23423
to input your sites unique ID which can be found on your flightaware stats page.
It can also be put into the config file as described in the instructions.

Then you should be all set to go.
It seems like you are trying to install the “normal” install onto a piaware image. But that “normal” install is meant for raspbian images.


#3

Sorry it is a Raspbian image that I wish to add Pi aware to.


#4

You may need a more recent image of raspbian.

Either you could reimage the sd-card or you could update it to something more current?

Post the output of
apt-cache policy
please.
So i know which version of raspbian it is.


#5

I just tried
pi@raspberrypi:~ $ sudo apt-get install libssl1.0.2
Reading package lists… Done
Building dependency tree
Reading state information… Done
libssl1.0.2 is already the newest version (1.0.2l-2+deb9u3).
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

It is a freash download of Raspbial lite today and has been updated.

pi@raspberrypi:~ $ apt-cache policy
Package files:
100 /var/lib/dpkg/status
release a=now
500 http://archive.raspberrypi.org/debian stretch/ui armhf Packages
release o=Raspberry Pi Foundation,a=stable,n=stretch,l=Raspberry Pi Foundat ion,c=ui,b=armhf
origin archive.raspberrypi.org
500 http://archive.raspberrypi.org/debian stretch/main armhf Packages
release o=Raspberry Pi Foundation,a=stable,n=stretch,l=Raspberry Pi Foundat ion,c=main,b=armhf
origin archive.raspberrypi.org
500 http://flightaware.com/adsb/piaware/files/packages jessie/piaware armhf Pac kages
release o=FlightAware Developers adsb-devs@flightaware.com,n=jessie,c=pia ware,b=armhf
origin flightaware.com
500 http://raspbian.raspberrypi.org/raspbian stretch/rpi armhf Packages
release o=Raspbian,a=stable,n=stretch,l=Raspbian,c=rpi,b=armhf
origin raspbian.raspberrypi.org
500 http://raspbian.raspberrypi.org/raspbian stretch/non-free armhf Packages
release o=Raspbian,a=stable,n=stretch,l=Raspbian,c=non-free,b=armhf
origin raspbian.raspberrypi.org
500 http://raspbian.raspberrypi.org/raspbian stretch/contrib armhf Packages
release o=Raspbian,a=stable,n=stretch,l=Raspbian,c=contrib,b=armhf
origin raspbian.raspberrypi.org
500 http://raspbian.raspberrypi.org/raspbian stretch/main armhf Packages
release o=Raspbian,a=stable,n=stretch,l=Raspbian,c=main,b=armhf
origin raspbian.raspberrypi.org
Pinned packages:


#6

I believe you have the jessie sources (old) for flightaware in use, try the stretch sources:

wget http://flightaware.com/adsb/piaware/files/packages/pool/piaware/p/piaware-support/piaware-repository_3.6.3_all.deb
sudo dpkg -i piaware-repository_3.6.3_all.deb
sudo apt-get update

then try again. (basically what is outlined on https://flightaware.com/adsb/piaware/install)


#7

Yes, this is the problem.


#8

Thank you chaps.
Now working fine.