Update piaware failed


#1

I am trying to update my installation per this: https://flightaware.com/adsb/piaware/install
Well, at the step quoted below, I get an error. Any ideeas?

pi@raspberrypi:~/adsb-receiver $ sudo apt-get install piaware
Reading package lists… Done
Building dependency tree
Reading state information… Done
piaware is already the newest version (3.6.2).
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
libbladerf-dev : Depends: libbladerf2 (= 2018.08-rc2) but it is not installable
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).

Running “sudo apt --fix-broken install” removes the package:

pi@raspberrypi:~/adsb-receiver $ sudo apt --fix-broken install
Reading package lists… Done
Building dependency tree
Reading state information… Done
Correcting dependencies… Done
The following packages will be REMOVED:
libbladerf-dev
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 242 kB disk space will be freed.
Do you want to continue? [Y/n] Y
(Reading database … 131635 files and directories currently installed.)
Removing libbladerf-dev:armhf (2018.08-rc2) …


#2

What image did you start from?

FWIW libbladerf-dev is not a dependency of piaware, and we don’t distribute a package with a version of 2018.08-rc2, so this is something external that’s been installed and is conflicting with the version provided by piaware.


#3

Image is Jessie, freshly updated
I had Pi-hole installed also and it’s web interface was using lighttpd and was interfering with the piaware one…
So I have uninstalled it.
I have tried to update my system using Joe’s script. That failed in that point “The package “tcl8.6-dev” could not be installed in 5 attempts”.
OK…
Now I tried to follow the instructions posted on the link above.
At the step “sudo apt-get install piaware” it fails again with the message quoted above.
“apt --fix-broken install” removes that package.
After that, running the “sudo apt-get install piaware” says that piaware is already at the newest version (3.6.2).
But trying to access the web page (directly or at port 8080) yields the “404-page not found” error now.


#4

The web page is part of the dump1090 package, not the piaware package. What dump1090 are you running?

I don’t really know what state your system is in here - I suggest you ask for help from Joe.

(Oh - you’re on Jessie? The instructions at …/install are for Stretch, they won’t work correctly on Jessie. You should update to Stretch, ideally)


#5

Sorry, I was on Stretch, I was confused.
Yeah, I’ll wipe a now SD card and start fresh. Thanks!