FlightAware Discussions

Problem with new install of my old site

Hi

I did a new install to a new sd card of piaware, copying over my old id number.

SkyView worked perfectly showing my site and distance to each plane tracked, but I was only able to see my site working once when I logged into FlightAware.

I removed my id from the new install hoping to have it detected as a new site, but it still shows up as the old one but not working still in flightAware!

What am I doing wrong?
Thanks
Gerry

Can you elaborate what the problem was before you removed the id?

What do you meant working once, does that mean for an hour or what does it mean?
Were you still using the old feeder-id?

You shouldn’t need a new id but if you want to remove the feeder id do the following:

sudo systemctl stop piaware
sudo piaware-config feeder-id ""
sudo rm /var/cache/piaware/feeder_id
sudo systemctl start piaware

You should now be able to claim the feeder again.
As i said this is only a solution if you are currently having the problem that 2 receivers have the same feeder-id. Won’t solve other problems.

Hi wiedehopf

Thanks for the reply.

I have found what the problem is but so far have been unable to fix it, when I did the reinstall to my Pi3 I changed over to wifi and Skyview worked perfectly, even showing my site, but still not showing in flightaware.com/adsb/stats page.

If I plug the cable back in all is well, so it’s my config file or a FlightAware problem?

This is my config

This file configures the Piaware sdcard image

configuration. Whenever the system boots, this

file is read and its contents are used to

configure the system.

Lines beginning with a ‘#’ are comment lines

and are ignored. Blank lines are also ignored.

All other lines specify configuration settings.

For simplicity, this file only shows the most common options.

For a complete list of options, see

https://flightaware.com/adsb/piaware/advanced_configuration

NETWORK CONFIGURATION

By default, PiAware will use DHCP when connecting to your network.

For other configurations, see the Advanced Configuration page

linked at the top of this file.

Should piaware use a wifi adaptor

for network access?

wireless-network yes

wireless-type static

static-network yes

Alternatively, a static address configuration

can be provided; set "wired-type" to static to use this.

wireless-address 192.168.0.28

wireless-netmask 255.255.255.0

wireless-broadcast 192.168.1.255

wireless-gateway 192.168.1.254

wireless-nameservers 8.8.8.8 8.8.4.4

Should piaware use a wifi adaptor for network access?

If you are using a Pi 3, this will use the built-in wifi.

Otherwise, you will need to attach a supported USB wifi adaptor.

Wifi SSID and password.

This should be changed to match your wireless

network SSID and, for networks that require

a passphrase, the passphrase.

If your SSID or password contains characters other than

numbers and letters, such as the # character or whitespace,

you should enclose the value in quotation marks. For example,

"pass word" or "pass#word".

To include quotation marks (") in a quoted value, use "

To include a backslash () in a quoted value, use \

wireless-ssid XXXX

wireless-password XXXX

RECEIVER CONFIGURATION

For a complete list of receiver types and their associated settings,

see the Advanced Configuration page linked at the top of this file.

For a receiver type of ‘rtlsdr’, this setting controls the dongle gain.

-10 means AGC / maximum gain; other values mean a gain value in dB.

rtlsdr-gain-10#49.6 #42.1

OTHER CONFIGURATION

Should automatic system updates (initiated by FlightAware) be allowed?

allow-auto-updates yes

Should manual system updates (initiated by you from the website control

panel) be allowed?

allow-manual-updates yes

Should PiAware enable multilateration where possible?

You may need to disable this if multilateration overloads your receiver.

allow-mlat yes

Should PiAware enable reception of Mode A/C messages when requested?

You may need to disable this if processing Mode A/C overloads your receiver.

allow-modeac yes

Additional settings can be added below.

feeder-id ec7796ea-06eb-4283-a472-a25099312824 # updated by fa_piaware_config

Remove this. Don’t think it’s an option anymore.

Apart from that i don’t see any problems.
If you connect to this WiFi of yours do you normally need to type in a password on a website or something (captive portal)?

Also with 3 backticks you can inhibit # making things bold

` ` ` (without the spaces)
the config for example
` ` ` (again without spaces to end the "code" block)

Normally all I do is fill my details into this and it works
wireless-ssid
wireless-password

If all else fails I will stick the cable back in!

The 3 backticks was meant for the formatting on the forum.

I’m not sure where

static-network yes

comes from.
But it’s not in the options as far as i see.
It may be a legacy option from previous versions creating problems.
That’s why i asked you to remove that line.

Also did you restart after changing the options? (I don’t know if you remove the sd-card for changing the options)

The strange thing is that Skyview works with the Pi wifi setup but not flightaware.com/adsb/stats.

I removed the SD card to edit the config file

Anyhow how long did you wait before deciding “it’s not working”

Did you already try removing the static-network line?

I used the settings from this
hxxps://uk.flightaware.com/adsb/piaware/build

your config file version might just be outdated.

Could you just do as i ask? No harm in trying right?

But the quotation marks indeed seem unnecessary :slight_smile:
Still the static-network line is not mentioned anywhere on that web page you mentioned.

@Gerry55

How To Format Messagesin This Discussion Forum

The wifi is working because it connects to skyview OK

That indeed is a good point.
Removing the static-network line still seems like a good idea.

You could also just look at the logs, after all you can connect to the pi via ssh/putty right?

sudo journalctl -u piaware -n50 --no-pager

this command should give you the relevant log.

Here is how to connect via ssh/putty: For Beginners - How-to SSH to RPi - Setup Putty in Windows

Oh i see the problem now.

Pretty sure that’s not your routers ip.
Also explains why local network works while piaware has no internet access.

This also makes no sense considering your ip address is 192.168.0.28
so broadcast should end in 0.255 instead of 1.255
(not sure if it matters as the netmask is set, probably doesn’t matter)

If I remove wireless-type static
The wifi stops working.

You could be right about routers ip.
I have changed it, and the wifi is still working, just waiting to see if flightaware.com/adsb/stats Works

Eureka

What a stupid mistake!!!

Thanks for all the help

I didn’t ask you to remove

wireless-type static

I asked you to remove

static-network yes

Just for the record :stuck_out_tongue:

It was the wireless-gateway 192.168.1.254 that was the problem