FlightAware Discussions

Piper tracking not or sporadic

I am near a small airport (E25) and installed PiAware to watch flights. I get quite a bit of traffic and there seem to be enough stations here for MLAT. Our own Piper does not show up at all or only sporadically. Today it tracked right after takeoff for about 3 minutes and then dropped off even though the pilot went above 4000 feet and remained in the area. Some other planes will get tracked (we have several larger airports nearby) but drop off within a 20 mi radius only to pop back up when they head towards the metropolitan. Most small plane traffic tracks just fine. Can I fix this?

Need more details. Are these UAT(978Mhz) or ADS-B(1090Mhz) aircraft?

What is your setup? RPI or other computer specs, Dongle (Airspy, RTL-SDR or FA), Antenna type and height. Coax, filters, gain settings etc.

I don’t see a feeder with your account. carbaer
Look out the coverage map https://flightaware.com/adsb/coverage
There aren’t many receivers in the area.
You could consider adding one.

Sorry, I am not a techie. The feeder is under my husbands name (I set it up). SITE 131909 – KLUF.
Our plane is ADS-B. It tracks just fine from larger airports (like KGEU). The other aircrafts, I don’t know. But they drop off at the same spot if they come from KDVT or KGEU etc.
Setup (we followed the instructions given by flight aware):
Raspberry Pi 3, 32 gig memory card, newest build suggested, pro stick plus, 1090MHz ADS-B Antenna + 25-foot Cable installed on the roof (about 10-foot off the ground at that spot).

The MLAT claims “Supported / Enabled (synchronized with 214 nearby receivers)”

This is what happened this morning:
7-16

The tail number was showing for a while but now it’s not. The aircraft was in the air for an hour. This is just after take off. Elevation at times over 5000 feet. All within range.

Look at the signal levels of the aircraft in question. If they drop off quickly then it could be terrain shielding. It could also be receiver overload.

MLAT doesn’t affect ADS-B or UAT aircraft. It is more for the older Mode-S(without position) transponders.

How do I check the signal levels of the aircraft?
It was definitely not terrain related this morning. It dropped off pretty much directly over the antenna. Nothing in the way. Don’t know about overload. Should it not have picked back up when the aircraft was at 5000 feet and 30 miles away?

Well the plane needs to be received by 4 receivers at the same time for an MLAT position.

Does the airplane have an UAT transponder?
Then doing 978 / UAT reception will be a better way to track it than 1090 MLAT.

Unfortunately it does not have UAT.

Can you SSH to RPi and issue commands? If yes, then please issue following command and post the output:

sudo piaware-config --show rtlsdr-gain

1 Like

This is starting to get a little above my pay grade. I logged into my router to find the IP address for the piaware (it works in the browser) and downloaded PuTTY to SSH into RPI. But it does not accept the IP address. :thinking:

In order to remote into the RPI, you would have to enable SSH in the RPI filesystem. To do that, you would need to remove the SD card from the Pi, plug it into your Windows or Mac computer, and create a text file called ‘ssh’, and then put the card back in the Pi and start it back up.

The file doesn’t need anything inside of it, it just needs to exist.

What is the transponder, specifically? As Jon mentions, if it is properly ADS-B equipped then multilateration doesn’t matter here; it is all about line of sight to the aircraft.

That certainly sounds like a problem with over-amplification (the receiver can become deaf to close signals that are too strong). There is a tradeoff between being able to hear nearby and distant aircraft.

OK, that was super helpful! However, I am assuming that piaware has a different user name and password than Pi and raspberry? I get “access denied”

But it never cam back even though the aircraft flew much further away.

Maybe a transponder fault, then? Whether you can see the plane on Skyaware or not really only depends on whether you’re hearing ADS-B messages or not. If it’s not on Skyaware, then your receiver isn’t hearing position messages for whatever reason.

For piaware sd card image, the default is:

username: pi
password: flightaware

Well, I think I am going to ask the pilot to fly towards the metropolitan next week. If the aircraft pops up at the usual point and stays visible while closer to one of the major airports, maybe that could answer some questions. Otherwise we’ll have to check the transponder. Thanks.

it came back with “max”

perfect! I am in :sweat_smile:

Reduce gain from “max” (which is actually 52~55) to a lower value. You may use 45 as starting value, then later increase or decrease as required (or set it back to max by using -10 instead of 45 in following command).

sudo piaware-config rtlsdr-gain 45
sudo systemctl restart piaware

Now check to confirm gain has changed
sudo piaware-config --show rtlsdr-gain

 

1 Like

"Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6 "

sudo piaware-config rtlsdr-gain (add your desired number here) ENTER
sudo systemctl restart piaware ENTER
sudo systemctl restart dump1090-fa ENTER

No need to reboot, just wait for RP! to update itself. Your Piaware map will update itself in just a few seconds…
KB4ERT