PiAware Raspberry Pi Zero 2

Been running my Piaware on a Pi Zero for ages… no problem. However, with a few other tasks processor use is maxing out. Enter my new quad core Pi Zero 2 (bought specially for the purpose). Now PiAware installation will not boot past the multicolored pi screen with either the original PiAware SD or new PiAware installation on new SD. Will flightaware please release a PiAware installation SD so we can utilise the new PI Zero.

1 Like

Trying putting the card in an older model(anything that will run the piaware image) and do:-
sudo apt update
sudo apt full-upgrade
any yes or y to the update question and wait until it completes. It may take a few minutes. It took a little over 2 minutes on a recently updated (a week or so ago) RPI4 with a good wired Internet connection.
Reboot

Then put the SD card in the new model.

/boot/bcm2708-rpi-zero-w.dtb is probably missing from the current image

There were code updates that came out recently that need to be on the SD for it to boot.

3 Likes

Done all that and still won’t boot. PiAware boots normally on my RPi Zero but not on either one of my new RPi Zero 2s. The RPi Zero 2s are not at fault because will boot fine using vanilla Rasberry Pi OS (standard and lite) without issues.
Also, /boot/bcm2708-rpi-zero-w.dtb is present in the PiAware image so that is probably not the issue either.

1 Like

Quick solution is to use vanilla Rasberry Pi OS image and install dump1090-fa, piaware and dump978-fa (if required) using following guides:

GUIDE-1

https://flightaware.com/adsb/piaware/install

 

GUIDE-2

[Package Install] How to Install and Configure Piaware on Raspberry Pi OS Image / RPi

NOTE (If dump978-fa is installed)
The dump978/dump1090 configuration command in “GUIDE-2” above is pre-ver 6.0.
Use following for ver 6.0 and later.

sudo sed -i 's/^RECEIVER_SERIAL=.*/RECEIVER_SERIAL=00001090/' /etc/default/dump1090-fa  
sudo sed -i 's/driver=rtlsdr[^ ]* /driver=rtlsdr,serial=00000978 /' /etc/default/dump978-fa  

1 Like

The latest FA image, 6.1, was released a couple of months or so ago so of course it’s not going to include support for hardware that hadn’t been released yet. It will take time to produce a newer image that includes support for the Pi Zero 2 yet still works on older Pis as well, plus all the testing that will be needed before the image is released. I wouldn’t expect one until at least 1st quarter 2022, probably later. Meanwhile do as abcd567 suggests and install Raspbian then do a from-packages installation of PiAware.

4 Likes

Pi Zero 2 is an “in place” upgrade, just remove SD card from old and place in new. However, it seems that PiAware 6.1 will not allow this for some reason. I have not yet gone down the install dump 1090 fa and piaware onto the RPi OS root yet but will probably have to if all else fails. Didn’t really want all the faffing about. I was hoping that the Zero 2 was going to just be a 30 second upgrade for adsb but, apparrently, not if one is using a PiAware image.

Are you sure you did the sudo apt update and sudo apt upgrade ?
And it worked properly?

Really if it doesn’t boot then it might just be an issue with your sd-card or something …

Yep. I sat here and supervised the update/upgrade in its entirety.

Not an SD card issue because all is fine and dandy on the my old Pi Zero where it is currently performing as it should. I even tried on a new SD card with a virgin, newly downloaded Piaware image… will not boot on a Pi Zero 2.

That is expected, it misses some files as explained earlier.
You’d have to update it … via the console as described.

Starting with Raspbian Lite isn’t so bad … : https://github.com/wiedehopf/adsb-wiki/wiki/Raspbian-Lite:-ADS-B-receiver

To clarify, I did update/upgrade the “virgin and newly downloaded” image via console. :grinning:

I will get round to install Piaware on a RPi OS lite at some point… when I have a little time should I need to correct any messing up I make :laughing:

Hi all
Sorry for my bad english, i do my best, i am french.
Got the same problem, tried all solutions and with buster aswell…
Nothing working fine.
With bullseye i get some error message when trying install piaware something like failed to install some lib****.
Iam not good enough with linux/raspbian to solve that.
So i will probably wait for a good image from piaware.
If somebody have a better solution, i will be please to try.
Best regards and good day for all of you
Eric

I forgot to say in my Last post:
All was done on a pi zero 2w
For those interested to buy one at a good price in EU , check Reichelt, few are in stock and at a good price. Only one per person… About 18 euros actually. 16 euros Last week. Like all pi, price are growing
I bought alors the hat ethernet and usb on Ali…
Great combo in the same form factor!

16367166776602689438652452912106|666x500

I was going to do the same sort of upgrade (originally I was going to move to a Raspberry Pi 3B+ that I had, as I was thinking that would have more horsepower than the original Zero W).

I’d prefer not to have one of my RPi 4’s outside (I get at least the 4GB versions, so would rather use a cheaper version)

Has anybody from FlightAware commented on what the issue might be?

Yes, in this thread:

Did you try the install under Buster or Bullseye?

Try this:

Package install of piaware 6.1 on Bullseye 32-bit & 64-Bit

 

 

Here is what worked for me to install the latest dev branch of dump1090-fa on a Pi Zero 2 W:

worked for me on RPI 2 Zero upgrading to Bullseye

Zero 2 W: CPU usage : 15%
Zero 1 W: CPU usage : 100%

image

1 Like

Be interesting to know CPU temperature in those scenarios too.

Geoff

Sorry for my bad english, i do my best, i am french

Your English is perfectly acceptable.

Geoff