PiAware 1.20 SD card image works with the new Raspberry Pi 2

Hi Folks…

We’ve confirmed that the latest piaware SD card image as found at raspberrypi.org/products/ras … 2-model-b/).

As you may know the Pi 2 has four ARM7 CPU cores versus one ARM6 core on the Pi 1, also operating at a higher clock rate, and upgrades memory from 512 megabytes to a gigabyte.

To swap out a Pi 1 for a Pi 2, if you’ve updated your SD card (via the FA webpage-based update or by executing ‘sudo apt-get update’ and ‘sudo apt-get upgrade’) you should be able to slide the card into a Pi 2 and it should boot right up. We had speculated that we would have to have two versions of the SD card image. At this point that is not necessary.

Over the next few weeks we intend to leverage more of the capabilities of the Pi 2, all the while continuing to fully support everyone who is running a Pi 1.

Thank you for your participation.



Good news that the initial test works. Next come the nuanced featurettes to bite as more sites come up. Now if my backorded P2 will just arrive… :smiley:

My first Pi 2 arrives tomorrow, but it’s not destined for ADS-B use – my production PiAware system is running on an early (256Mb) Model B, and gets rebooted about once a month for system updates.

bob k6rtm

Updated the software as the first post suggests. Swapped boards, installing my new Raspberry Pi 2. Powered it up and all is working as expected.


Works, tested and confirmed.

Remember the default password is** flightaware** as I made this mistake thinking it was the default PI login, wondering why it didn’t work but resolved now! :slight_smile:

No luck for me. My new Raspberry Pi 2 kept rebooting after showing some lines of the boot sequence. It is a fresh copy of the PiAware 1.20. The RPi2 works fine with Noobs.

Is there anyway to dump the screen / boot log? It booted too quickly to be read. So I cannot tell at which step it rebooted.

flightaware.com/adsb/stats/user/picker is running fine on a Raspberry Pi 2 with PiAware image.

I have a new Pi 2, and I installed Raspbian from the official site, then followed these instructions:


I did encounter one issue: the dump1090 included with piaware didn’t want to start and run. I had to manually run ‘sudo rmmod dvb_usb_rtl28xxu’ and then restart dump1090 with the /etc/init.d/fadump1090.sh script, then restart piaware.

The documentation at the ^ above link may want to include a note about this module issue, as it took me a while to figure out…


I had the same problem with the 1.20 image on my Pi 2. What I found was, unplugging all USB devices caused the Pi to boot successfully. Otherwise I was stuck in endless reboot same as himsing. I’m pretty sure it was rebooting when it tried to start up the USB devices.

So I ended up just going back to plain old Raspbian and installing Piaware on top of that.

Hoping for my Pi 2 to arrive today, so sounds like I should follow the install instructions, rather then copy the image directly?

Well it arrived, eded up installing Raspbian and following the install instructions and not the image.

Sorry Guys, I found the password in Maffewem text…

Hi, I’m new at this site and struggling to get my Rpi B+ to work so I can feed data both to Flight aware and to FR24, I have used PiAware 1.20 to my SD Card but I cant claim my username? so I tried to log in and follow guide where it says connect to HDMI… ect. etc. and log in with ◦Username: pi
◦Password: raspberry BUT it says wrong password?? Does anyone had this issue? and what is correct password?


Morning all,

Is PA 2.0 out yet?

Reason I ask, my FA stats page says that MLAT isn’t available on PA 1.20, but is on v2?

Hadn’t heard about that being released?