Piaware in Car while at Airport?


#1

I’ve tried to read on how to maybe get Pi aware to run as a mobile install,but I’m still confused as to the proper steps needed.Can anybody give me a simple list of what I need to do? Do I need gpsd,a hotspot,etc?

I would like to be able to be at the Airport and see what flights are coming in and leaving while in the car.


#2

There are various ways to do it.

OPTION-1:
DVB-T dongle with it’s whip antenna + RPi + Battery Pack + Screen to display aircraft table & map

OPTION-2:
DVB-T dongle with it’s whip antenna + Android Phone/Tablet.

OPTION-3:
DVB-T dongle with it’s whip antenna + Laptop/Notebook.


#3

Buy an ATT Mobley or T-Mobile SyncUP Drive to give yourself a WiFi Hotspot right in your car.

A Raspberry Pi with an FA dongle and cheap antenna along with a laptop or tablet for viewing air traffic is all you need.

Some newer model vehicles come equipped with WiFi either standard or as an option.

You can also use the Personal Hotspot feature on your smartphone.


#4

@chrisjohnston50
How you propose to power the Raspberry PI?


#5

@abcd567

I use a USB adapter plugged into my car’s cigarette lighter socket.

My car is older and does not come with USB ports, but I assume those would work also.

Output is 5 volts. I don’t know how many amps.


#6

Since the objective is to VIEW the flight details and map, and NOT DATA UPLOAD, a very simple solution is Laptop+DVB-T (or ProStick) Dongle + cheap whip antenna. and that is all.

For Windows Laptop, the Software required is as follows:

ZADIG

Download Zadig 2.3.exe from http://zadig.akeo.ie/.

STEP-1

(a) Plug the DVB-T or ProStick in your Laptop.
(b) Double click Zadig 2.3.exe to run it.

zadig-1

STEP-2

zadig-2

STEP-3

zadig-3

ModeSDeco2

  1. Download modesdeco2_windows_20170127.zip from http://xdeco.org/?page_id=30
  2. Unzip
  3. Open unzipped folder, and take steps as shown in the screenshot below


.

.

  1. Double click the file Run_Decoder.bat. A terminal will open

modesdeco2-console
.
.

  1. Open browser and type localhost:8088 and press Enter key. You can see map and flight table

.

.

.

.

.

.


#7

@abcd567

I assume that MLAT capability does not exist with the above configuration.


#8

Correct.
I just want to see whats coming and going. No need to upload any data.
Thanks for the step by step.


#9

Thank you for this abcd567


#10

For MLAT to work with a mobile PiAware, you will need to connect a GPS receiver to the Pi. PiAware will automatically detect a connected GPS receiver via gpsd and use the position information.


#11

All I did to get MLAT to function was input my current position and altitude via the “My ADS-B” page on FlightAware.


#12

You can manually update the location on the My ADS-B page if you move a site to a new fixed location. In general though, that isn’t very practical for site that you intend to use while mobile.


#13

Agree.

Without GPS, it’s definitely not practical to update while the car is underway. I try to find a place to park where I can get a good visual on the air traffic and then update the PiAware coordinates for that particular observation spot.

What would you recommend for a Raspberry Pi / GPS interface? Preferably a GPS unit which is not a power hog.


#14

@abcd567

I assume that I would need to change my lat/long in the .bat file depending on which airport I’m at?


#15

We don’t officially support the GPS capability so I don’t have any particular recommendations for hardware as most setups don’t need it. I believe there are threads in the forums and some social media posts that describe setups that are configured this way.


#16

As you are NOT feeding data, and are NOT participating in MLAT, it is not necessary, provided you are not far away (>300nm aerial distance) from the entered Latitude:Longitude.

The wrong location entry affects in two ways:
(1) On the map, the receiver location is shown wrong, and range rings are centered on wrong receiver location, but planes are still shoiwn on their correct location.

(2) Planes more than 300nm from receiver location are filtered out and not displayed on map and in flight table. If your actual location is more than 300nm from entered location, you wont see any planes on the map. The flight table will still show some planes, but these are “position-less”, i.e. no latitude and longitude was transmitted by these planes, and modeSDeco2 therefore does not know their location and does not filter these out.

Below are two screen shots which show this behaviour. My actual location is Toronto. I changed my Lat:Lon in .bat file to Lat:Lon of Ottwa, which is at 200nm aerial distance, and plane still showed at correct location, but rings got centered on Ottawa. I next changed Lat:Lon to that of Quebec City, which is at 400nm aerial distance. Rings got centered on Quebec City, and all the planes disappeared from map. The Flight table still showed planes, but only position-less i.e. those which did not transmit their Lat:Lon.

Entered Lat:Lon = 200nm (aerial distance) away from actual Lat:Lon
(Actual location Toronto, Entered location Ottawa)

.

Entered Lat:Lon = 400nm (aerial distance) away from actual Lat:Lon
(Actual location Toronto, Entered location Quebec City)


#17

@abcd567
Excellent.Thanks for the info.
Chrome wasn’t showing the Map,but I could see all the flights. Firefox was displaying the map fine though. After digging around I found out that Chrome has WebGL disabled by default. After I enabled it and restarted Chrome,the Map appeared.:joy:


#18

To feed Flightaware and participate in MLAT from my laptop, I have successfully done following:

(1) On Windows/Mac laptop, downloaded
"2016-12-13-pixel-x86-jessie.iso"
from: https://www.raspberrypi.org/blog/pixel-pc-mac/

(2) Plugged-in a USB flash memory stick (8Gb or more) in laptop and formated it.

(3) Wrote the downloaded .iso image to USB flash memory stick using Win32 disk imager (etcher can also be used).

(4) Shutdown laptop, and powered up again. At start up, entered option to select boot device (F12 one one laptop, Escape then F9 on other laptop, or somethibg similar, depending model of laptop), and selected USB flash memory as the boot device and booted from it into a Raspbian Pixel style desktop.

(5) Wifi was not working / not configurable. Connected a wired Internet. The driver for Wlan card of laptop was not included in .iso image. Gave following commands and the required driver got installed during upgrade:

sudo apt-get update
sudo apt-get upgrade

Later Edit: due to some files getting corrupt, I formatted my USB Flash and wrote the Pixel x86 .iso image again. At first boot, I discovered in previous install, I had not correctly configured WiFi, and thinking that it is Wlan driver problem, did “sudo apt-get upgrade” which was not necessary and took a long time. The driver is available in Pixel x86 for my laptop’s wifi card (broadcom), and in the second fresh install, I could connect to WiFi without doing “sudo apt-get upgrade”.

(6) Installation of Decoder and Data feeders

Tried to install piaware by package install method on this page, it failed.
https://flightaware.com/adsb/piaware/install

The reason is these packages are built for ARM architecture (Raspberry Pi), whereas laptops have i386/amd64 architechture.

To install dump1090-fa (or dump1090-mutability) and Piaware data feeder, I build these from source, using J Prochazka’s scripts. Since these packages were built right on the laptop, these were built for the architecture of the laptop (i386/amd64).

sudo apt-get update
sudo apt-get install git
cd ~/
git clone https://github.com/jprochazka/adsb-receiver.git

The use of Joe Prochazka,s script required two workarounds:

WORKAROUND -1:

Update software versions in file ~/adsb-receiver/bash/variables.sh

#open file variables.sh for editing
sudo nano ~/adsb-receiver/bash/variables.sh

In the file variables.sh, make changes in version numbers as shown below:

WORKAROUND -2

Build and install bladeRF and its dependencies.
Execute this workaround only if you want to install dump1090-fa.
For dump1090-mutability omit this workaround.

INSTALL PACKAGES/TOOLS NEEDED TO BUILD

sudo apt-get update
sudo apt-get -y install git
sudo apt-get -y install debhelper
sudo apt-get -y install cmake
sudo apt-get -y install libusb-1.0-0-dev

INSTALL PACKAGES NEEDED TO FULFILL DEPENDENCIES

sudo apt-get install -y doxygen
sudo apt-get install -y libtecla-dev
sudo apt-get install -y libtecla1-dev
sudo apt-get install -y help2man
sudo apt-get install -y pandoc
sudo apt-get install -y libncurses5-dev

BUILD PACKAGE bladeRF

sudo mkdir ~/build-bladeRF
cd ~/build-bladeRF
sudo git clone https://github.com/Nuand/bladeRF.git
cd bladeRF
sudo dpkg-buildpackage -b

AFTER BUILDPACKAGE IS SUCCESSFULLY COMPLETED

sudo dpkg -i ../libbladerf1_*
sudo dpkg -i ../libbladerf-udev_*
sudo dpkg -i ../libbladerf-dev_*

Final Step After Workarounds:

Run the installation script:

cd ~/adsb-receiver
chmod +x install.sh
./install.sh

#19

Excellent! Will have to give it a try later.
Some of the links aren’t working though.
Do I need to use both workarounds?


#20

Link failure is result of migration of forum from old to new style. Now I have fixed links.

.

1st work around is a must.
2nd workaround ONLY if you want to install dump1090-fa. If you are installing dump1090-mutability, the 2nd workaround is NOT required.