Piaware fails to log in after restore from backup - HELP!


#1

The USB memory stick hostin my piaware installation on a RPi2 was recently corrupted and would not boot.

I restored the installation from a backup I had made with DD in May this year which booted successfully.

However piaware will not send date to my Flightaware account and the following message is recorded.

pi@piaware:~$ cat /tmp/piaware.out
12/21/2017 20:12:33 ****************************************************
12/21/2017 20:12:33 piaware version 2.1-5 is running, process ID 16697
12/21/2017 20:12:33 your system info is: Linux piaware 4.1.19-v7+ #858 SMP Tue Mar 15 15:56:00 GMT 2016 armv7l GNU/Linux
12/21/2017 20:12:33 Connecting to FlightAware adept server at piaware.flightaware.com/1200
12/21/2017 20:12:33 ADS-B data program ‘dump1090-mutab’ is listening on port 30005, so far so good
12/21/2017 20:12:33 Starting faup1090: /usr/lib/piaware/helpers/faup1090 --net-bo-ipaddr localhost --net-bo-port 30005 --stdout --lat -2x.xxx --lon 15x.xxx
12/21/2017 20:12:33 Started faup1090 (pid 16736) to connect to dump1090-mutab
12/21/2017 20:12:33 Connection with adept server at piaware.flightaware.com/1200 established
12/21/2017 20:12:34 FlightAware server SSL certificate validated
12/21/2017 20:12:34 encrypted session established with FlightAware
12/21/2017 20:12:34 autoUpdate is not set in adept config, looking further…
12/21/2017 20:12:34 autoUpdate in /etc/piaware is enabled, allowing update
12/21/2017 20:12:34 manualUpdate is not set in adept config, looking further…
12/21/2017 20:12:34 manualUpdate in /etc/piaware is enabled, allowing update
12/21/2017 20:12:34 multilateration support enabled (use piaware-config to disable)
12/21/2017 20:12:34 piaware received a message from dump1090-mutab!
12/21/2017 20:12:34 *******************************************
12/21/2017 20:12:34 LOGIN FAILED: status ‘error’: reason 'creation of new feeder sites requires a newer PiAware client that supports feeder IDs, please upgrade PiAware and try again’
12/21/2017 20:12:34 please correct this, possibly using piaware-config
12/21/2017 20:12:34 to set valid Flightaware user name and password.
12/21/2017 20:12:34 piaware will now exit.
12/21/2017 20:12:34 You can start it up again using 'sudo /etc/init.d/piaware start’
12/21/2017 20:12:34 TLS alert: close notify

All other applications I have on this rather complicated RPi install work - Flightradar24, Planefinder, several temperature recording and reporting apps - so I am hesitant to take the sensible route and rebuild the installation from scratch.

I understand that the upgrade path from v2.1-5 to v3.x.x was in the past - i.e. 2016 - impossible without upgrade but was wondering if it has been implemented.

I am perplexed as to why the backup will now not run when it was perfectly happy 6 months ago. I have checked that the MAC address is correct as I have MAC spoofed using and entry in the boot config file.

My account is garylovesbeer. MAC address as shown in account is MAC: b8:27:eb:fe:d8:d7.

Any and all help appreciated as I would be vastly disappointed if I could no longer contribute to Flightware.

pi@piaware:~$ ifconfig
eth0 Link encap:Ethernet HWaddr b8:27:eb:fe:d8:d7
inet addr:192.168.0.206 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:512875 errors:0 dropped:3 overruns:0 frame:0
TX packets:377241 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:56233555 (53.6 MiB) TX bytes:201288113 (191.9 MiB)

All and any help with this issue will be appreciated.


#2

@garylovesbeer
First of all glad to see your post after a long period. Last time I remember to see your post was in Planefinder forum.

  1. Go to your stats page
    https://flightaware.com/adsb/stats/user/garylovesbeer

    and copy your Unique Identifier (see screenshot below)

  2. Give command
    sudo piaware-config feeder-id xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

    where xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx is the Unique Identifier you have copied from your Flightaware stats page.

    If the command is executed successfully, it will rerturn following

    Set feeder-id to xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx in /etc/piaware.conf:9
    .

  3. Restart piaware for implementing feeder id
    sudo systemctl restart piaware
    .

  4. Wait 10 minutes, then give following command to check status
    sudo systemctl status piaware -l

    If it is feeding Flightaware, last few lines will be like following:

    9 msgs recv'd from dump1090-fa; 9 msgs sent to FlightAware
    63 msgs recv'd from dump1090-fa (54 in last 5m); 63 msgs sent to FlightAware
    69 msgs recv'd from dump1090-fa (6 in last 5m); 69 msgs sent to FlightAware
    

    .

  5. Check Status on your Flightaware stats page https://flightaware.com/adsb/stats/user/garylovesbeer


#3

Hi abcd567! Thanks for remembering! Life been a little hectic lately - and have had no real issues up until now but have been lurking occasionally on all thee forums.

I had a good look through the forums before I posted so had already tried that command.

Results

pi@piaware:~$ sudo piaware-config feeder-id 3d7f7167-346d-43ec-a805-33dcfdbfca43
piaware-config options:
-user value specify the user name of a valid FlightAware account <>
-password interactively specify the password of the FlightAware account
-autoUpdate value 1 = allow FlightAware to automatically update software on my Pi, 0 = no <>
-manualUpdate value 1 = allow me to trigger manual updates through FlightAware, 0 = no <>
-mlat value 1 = allow multilateration data to be provided, 0 = no <>
-mlatResults value 1 = send multilateration results to localhost:30004, 0 = no <>
-mlatResultsFormat value format(s) to generate mlat results in, ‘default’ to reset to the default format <>
-start attempt to start the ADS-B client
-stop attempt to stop the ADS-B client
-restart attempt to restart the ADS-B client
-status get the status of the ADS-B client
-show show config file
– Forcibly stop option processing
-help Print this message
-? Print this message

I think the problem is the install is a very old version and logs into Flightaware using the MAC address for id. What intrigues me is I have tried 2 different restores from 2 separate dates with the same result.

Might have to reinstall…

BTW hope you and your family have a great Festive season!


#4

BTW /tmp/piaware.out contains this line

12/21/2017 20:12:33 piaware version 2.1-5 is running, process ID 16697

then falls over.


#5

Thanks for greetings. Season’s Greetings to you and family.

Give following command and post output generated:

apt-cache policy piaware

cat /etc/os-release


#6

Hi abcd, thx for the great help!

pi@piaware:~ apt-cache policy piaware piaware: Installed: 2.1-5 Candidate: 3.5.3 Version table: 3.5.3 0 500 http://flightaware.com/adsb/piaware/files/packages/ jessie/piaware armhf Packages *** 2.1-5 0 100 /var/lib/dpkg/status pi@piaware:~

pi@piaware:~$ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 7 (wheezy)"
NAME="Raspbian GNU/Linux"
VERSION_ID="7"
VERSION="7 (wheezy)"
ID=raspbian
ID_LIKE=debian
ANSI_COLOR="1;31"
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL=“http://www.raspbian.org/RaspbianBugs

Hope that helps (both of us).

Cheers


#7

You need to upgrade piaware before it will work. 2.1-5 is no longer supported. That version didn’t even know about feeder-ids.

https://flightaware.com/adsb/piaware/install


#8

Both the OS and piaware are too old.
The clean solution is a fresh install (i.e. format the USB memory stick, and install latest Raspbian and all other software).

You can install dump1090-mutability (or dump1090-fa) + piaware + planefinder data feeder + flightradar24 data feeder + performance graphs using Automated method given here:

ADS-B Receiver Project Setup Scripts

NOTE:
If you choose to install dump1090-mutability on Raspbian Stretch, you will face following bug:

Map does not show planes, and give following warning:

Reason: dump1090-mutability fails to open DVB-T due to missing rtl-sdr.rules.

Workaround (AFTER installation of dump1090-mutability v1.15~dev):

sudo wget -O  /etc/udev/rules.d/rtl-sdr.rules "https://raw.githubusercontent.com/osmocom/rtl-sdr/master/rtl-sdr.rules"

sudo reboot

#9

Bit like me then - too old!!!

I still wonder why it worked fine until the disk corrupted. Very strange.

Anyway, thanks for your help.

See you next year!


#10

@garylovesbeer
Please have a look here:
Raspberry Pi Forums: STICKY: How to upgrade a Wheezy image to Jessie


#11

If it is of any help, long ago I decided to separate the RasPi apps onto their own boxes. So, I have one that runs the ADSB stuff like FlightAware, FR24, adsbexchange etc. Then another Pi for some temperature monitoring, and another for webserving, another for Kodi, and two more for DNS (PiHole) …don’t tell my wife I bought so many! But really, they are so inexpensive it was just easier from a software upgrading standpoint to separate them.


#12

@garylovesbeer

(A) Upgrading from Wheezy to Jessie

To test the method of upgrading from Wheezy to Jessie, I did following:

  1. Downloaded wheezy from:
    http://downloads.raspberrypi.org/raspbian/images/raspbian-2015-05-07/

  2. Wrote wheezy image to microSD card

  3. Successfully upgraded to Jessie using method here:

    Raspberry Pi Forums: STICKY: How to upgrade a Wheezy image to Jessie

.
During this trial upgrade, I noted following two things:

  1. For creating folder autostart the command given in the raspberrypi forum is:
    mkdir /home/pi/.config/autostart

    This command fails as (1) sudo is missing, and (2) folder .config in path to folder autostart does not exist.

    Use following command, in which argument -p creates any folders in path if it does not exist. A better alternative to -p is -pv which announces all the directory created, so that you can see what directories are created.

    sudo mkdir -p /home/pi/.config/autostart

    OR better

    sudo mkdir -pv /home/pi/.config/autostart

  2. Newly created folder .config is not listed when ls or dir command are issued. However command cd /home/pi/.cofig moves prompt to folder .config

(B) Upgrading Piaware from 2.1 to 3.5.3 (After successful upgrade from Wheezy to Jessie)

  1. First purge the existing old version 2.1-5 of Piaware

    sudo dpkg --purge piaware

  2. Once purging is completed, install Piaware 3.5.3 by following commands given on page https://flightaware.com/adsb/piaware/install

    wget http://flightaware.com/adsb/piaware/files/packages/pool/piaware/p/piaware-support/piaware-repository_3.5.3_all.deb
    sudo dpkg -i piaware-repository_3.5.3_all.deb
    

    This will download and install PiAware and required dependencies on your Raspberry Pi.

    sudo apt-get update
    sudo apt-get install piaware
    

    This will enable automatic and manual (web-based, via your request) PiAware software updates. These updates are disabled by default. To leave updates disabled, skip this step.

    sudo piaware-config allow-auto-updates yes
    sudo piaware-config allow-manual-updates yes
    
  3. Now set your feeder id as shown in this post:
    https://discussions.flightaware.com/t/piaware-fails-to-log-in-after-restore-from-backup-help/29355/2


PiAware: Fine for 4+ yrs and now it's not
PiAware: Fine for 4+ yrs and now it's not
#13

Trying it right now.

Cross your fingers abcd!


#14

Success!

Upgrade to Jessie was relatively painless. Had to upgrade sudo apt-get install libtcl8.6 to successfully install piaware 3.5.3.

To get piaware to start I had to edit sudo nano /etc/hosts and comment out
:1 localhost ip6-localhost ip6-loopback

as per another user who had the same error message in /var/log/piaware.log
*** buffer overflow detected ***: /usr/bin/piaware terminated

So thank you for your fantastic help abcd!


#15

Good luck!
When yesterday I upgraded from Wheezy to Jessie, it took more than an hour to complete.

At one point it hanged for very very long time, and I had to reboot Pi and once again issue command sudo apt-get dist-upgrade. I then got responce " the dpkg process was interrupted, please try command sudo dpkg-reconfigure -a. I issued this command and after its completion, again issued command sudo apt-get dist-upgrade.


#16

Glad it went well in the end for you! My upgrade took about 15 minutes on a RPi2.

I am a happy camper!

Now to image the USB stick as a back up.

Hope it goes for another 3 years without any hassles!


#17

.
Actually I do not have any Pi with wheezy. All are either Jessie or Stretch.

The upgrade I did was not meant to fix my problem, but was meant to test the upgrade method, before I recommend it to you and others in this forum.

Only yesterday I downloaded and burned wheezy on a spare blank microSD card, and then upgraded it to Jessie to test the method.

After test, I have formatted the test microSD card, and am keeping it as reserve blank microSD card.

.

I dont know why mine took so long. My microSD card is class 10 with 25 Mb/sec write and 50 Mb/s read speed. Maybe your USB is 3.0 and high speed (50 Mb/sec write and 100 Mb/sec read speed), making upgrade faster.
.

.
Glad to know that you could fix it and your system is up and running again.


#18

That is going above and beyond! Thanks again abcd for all your efforts.


#19

PiAware version 2 systems will not be able to connect to FlightAware soon. I think the count was something around 100 sites still connected to FlightAware with the older software.

If you have any trouble upgrading or flashing a new SD image you can use the discussion boards or email flightaware at adsbsupport@flightaware.com


#20

@david.baker:
You are right David. Re-flashing with latest image is the cleanest, trouble free, and long-lasting solution.

The OP (original poster) had two-fold problem:

  1. Piaware version 2.1-5
  2. Raspbian 7 Wheezy

As you have suggested, I also initially suggested OP to flash latest Raspbian image and install latest Piaware 3.5.3 (package install). The OP did not like this as he had many other software running on Pi and did not want to re-install everything.

In view of reluctance of OP to flash new image, I posted a method which comprised of following 3 steps:

  1. Upgrade existing OS from Wheezy to Jessie WITHOUT re-imaging.
  2. Purge Piaware 2.1-5
  3. Install Piaware 3.5.3 (package install)

Please see this post for details:
https://discussions.flightaware.com/t/piaware-fails-to-log-in-after-restore-from-backup-help/29355/12