FlightAware Discussions

PiAware Debian Dynamic Range

I’m trying to enable dynamic range on my Debian install using these instructions (dump1090/README.adaptive-gain.md at master · flightaware/dump1090 (github.com)).

I’ve already edited the dump1090-fa config file, but what exactly do I enter for this step?

-Pass the --adaptive-range option on the command line.

If you edited the file you only have to restart dump1090.

sudo systemctl restart dump1090-fa

No additonal commands are needed.

That is an “or” not an “and”

  • Set adaptive-dynamic-range yes in piaware-config; or
  • Set ADAPTIVE_DYNAMIC_RANGE=yes in /etc/default/dump1090-fa ; or
  • Pass the --adaptive-range option on the command line.

So simply use any of these. As dump1090-fa runs as a service, i would suggest using the second option by changing it in your config

1 Like