FlightAware Discussions

Piaware v 6.0 24 hrs after installation first results

Last night I updated my 4 flightfeeders to the Piaware v 6.0 and dump1090-fa v 6.0 via manual installation.

Now 24 hrs running it I will call this an improvement to V 5.0 at this point in time
I did enable adaptive gain and it seems to improve my reception of signals.
Previously I had the gain tuned manually and checked once a week or so if it was still at a desired level.

A few figures

Aircraft count up 6,5 % when averaged over the 4 flightfeeders
Postion count up by 12,5% when averaged over the 4 flightfeeders
Range is staying the same or slightly improved, but that’s also dependant on the weather.

All in in all I think this upgrade is really usefull and I’d like to thank all involved in it for their work so we can enjoy a hobby :blush: :+1:

4 Likes

Awesome, glad to hear!

I installed piaware 6 and dump 1090-fa and gain went to maximum. I disabled the gain adjust until I can find some ideas on how to make it work better

pi@c16494:~ $ sudo systemctl status dump1090-fa
● dump1090-fa.service - dump1090 ADS-B receiver (FlightAware customization)
   Loaded: loaded (/lib/systemd/system/dump1090-fa.service; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2021-09-05 07:04:55 EDT; 4h 53min ago
     Docs: https://flightaware.com/adsb/piaware/
 Main PID: 4081 (dump1090-fa)
    Tasks: 3 (limit: 2062)
   CGroup: /system.slice/dump1090-fa.service
           └─4081 /usr/bin/dump1090-fa --quiet --device-type rtlsdr --gain 37 --adaptive-range --fix --lat 26.15410 --lon -80.26576

Sep 05 07:06:06 c16494 dump1090-fa[4081]: adaptive: available dynamic range (43.6dB) >= required dynamic range (30.0dB), continuing
Sep 05 07:06:06 c16494 dump1090-fa[4081]: adaptive: changing gain from 44.5dB (step 26) to 48.0dB (step 27) because: probing dynamic
Sep 05 07:06:06 c16494 dump1090-fa[4081]: rtlsdr: tuner gain set to 48.0 dB (gain step 27)
Sep 05 07:06:16 c16494 dump1090-fa[4081]: adaptive: available dynamic range (43.6dB) >= required dynamic range (30.0dB), continuing
Sep 05 07:06:16 c16494 dump1090-fa[4081]: adaptive: changing gain from 48.0dB (step 27) to 49.6dB (step 28) because: probing dynamic
Sep 05 07:06:16 c16494 dump1090-fa[4081]: rtlsdr: tuner gain set to 49.6 dB (gain step 28)
Sep 05 07:06:26 c16494 dump1090-fa[4081]: adaptive: available dynamic range (39.4dB) >= required dynamic range (30.0dB), continuing
Sep 05 07:06:26 c16494 dump1090-fa[4081]: adaptive: changing gain from 49.6dB (step 28) to 58.6dB (step 29) because: probing dynamic
Sep 05 07:06:26 c16494 dump1090-fa[4081]: rtlsdr: tuner gain set to about 58.6 dB (gain step 29) (tuner AGC enabled)
Sep 05 07:06:36 c16494 dump1090-fa[4081]: adaptive: reached upper gain limit, halting dynamic range scan here
![Screenshot 2021-09-05 204656|613x500](upload://8NilK6XSkB0l36gfhLOwmnWbXQL.jpeg)

You can define an upper and lower limit in the config file :slightly_smiling_face:

this feeder is using the radarbox dongle. How would you determine if a dongle is measuring dynamic range as expected?
also was getting 404 error for (feeder ip)/dump1090-fa/data/stats.json Does this mean it didn’t finish installing?

it will define the type als an rtlsdr device. That’s already in your output so that’s ok.

The adaptation is indeed visible via the json page but I can’t determine why it gives you a 404 error.
look at the installation log for the upgrade to determine if there are issues when installing.

where is the installation log for the upgrade?

It’s located here /var/log/piaware.log

getting messages in /var/log/piaware.log about receiver status

post deleted by the author

If you look inside that directory you will see more log files from Piaware.

Examples are
Piaware.log
Piaware.log.1
Piaware.log.2
Piaware.log.3
Piaware.log 4
Pick the one that includes your installation date (I don’t know how long you are running on v 6.0) and check inside that log the time you have installed v 6.0
Command
sudo nano /var/log/piaware.log.x (replace the x with the correct number). If there was an errror with the installation I would expect to see it there in the log.

Looks like the installation was successful from the messages, in Piaware.log.1


Still have 404 error for (my ip)/dump1090-fa/data/stats.json
Setting dynamic range target to 43 keeps gain between 44.5 and 48

You are not using https instead of http ?

Otherwise you might have an issue with lighttpd
Issue the follwing commands

sudo chown -R www-data:www-data /var/log/lighttpd/
sudo systemctl restart lighttpd

Check if you still get the 404 error

dump1090-localhost-cpu-90d

This is is a 3-month display of CPU usage. Can you tell when I changed from PiAware 5.0 to 6.0? Granted, it isn’t like the software was taxing my Pi but I found it interesting to see a drop in use.

1 Like

Thanks for suggestion still the same, even after version 6.1. Seems to work fine other than 404 error

Then I’m out of options I’m sorry.