Turning off AGC

I just installed a LNA and set the gain to 32 per reading some information about it but it seems like AGC is still messing with the gain. Is there a way to shut it off? Is 32 good for what I am trying to accomplish?

If you are using Piaware SD card image, and ver 6.1 or later, disable "Adaptive Gain Control” then monitor for 24 hrs.

sudo piaware-config adaptive-dynamic-range no  

sudo systemctl restart piaware   

sudo systemctl restart dump1090-fa   

(1) After disabling “adaptive gain control” by 1st command above, you must either reboot Pi or restart both piaware and dump1090-fa for the change to be implemented

(2) If you are NOT using SD card image, but using Raspberry Pi OS with package install of piaware and dump1090-fa, then above command wont disable adaptive gain control. You will have to edit file /etc/default/dump1090-fa and set:


After 10 minutes check logs

sudo journalctl -u dump1090-fa -n 10   


Are you using the piaware image or the package install on top of Raspberry/Debian installation?

You didn’t say what you’re trying to accomplish. Nobody can tell you what gain setting is best for your location, elevation ,antenna, dongle and setup, which you didn’t tell us. You’ll have to figure that out for yourself by monitoring your stats. Graphs1090 is a valuable tool for that. Or we could give you advice if you provide needed information but we can’t read minds or look through the Internet and see your feeder’s setup. :smile:

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.