FlightAware Discussions

Disabling Adaptive Gain?

So I’m about to show my unfamiliarity with coding, Raspberry Pi and navigating around in piaware while I’m SSH logged in with PuTTy, but here we go…

I’m trying to figure out how to turn off the new adaptive gain, I’m wanting to play around with my gain to try and understand it better.
Things I’ve tried to turn it off:
I’ve pulled out my SD card and looked at /boot/piaware-config.txt to change adaptive gain to no, but didn’t see it there.
I entered in the “piaware- config” command and only a few things pop up, but nothing about adaptive gain.
The only place I can find anything about adaptive gain is when I enter “sudo nano /etc/default/dump1090-fa” and I see the following picture:

I go down change the yes to no, then exit after it askes me if I want to save and I say yes. But it doesn’t seem to take the change? I can go back in and the no has changed back to yes. I tried a new SD card with a new install, looked for it in the /boot/piaware-config.txt, played around in PuTTY and still can’t figure out how to turn it off.

So how do I turn this thing off?

piaware-config -showall

Try this to show all the settings.

/etc/default/dump1090-fa is not the right file as it states at the top of the file.
Use piaware-config.

For Piaware SD Card image:

In file /boot/piaware-config.txt, add this line
adaptive-dynamic-range no

OR

In SSH terminal, issue following command:
sudo piaware-config adaptive-dynamic-range no