Piaware crashes/freezes RPi w/high volume of tracks


#1

I have really been enjoying working with the PiAware SD on a Raspberry Pi 2. I live in a condo so I can’t run anything like an ethernet cable from our third floor balcony into the building…so I am using WIFI. For the most part everything has worked out well. I can SSH via PuTTY and piaware connects with flightaware and data results show up on MyADS-B. BUT…typically after a few hours operation either the WIFI connection breaks down or the RPi locks up. First SSH seems to get really slow then stops all together and then I notice that the server is no longer showing moving AC tracks (and then fails to reload from the browser) If I catch it in time while I still have SSH connection I can reboot and things are good…for awhile. If I don’t, I have to go outside to unplug the replug the system; not the recommended method to restart a RPi!

I have made no changes to the SD configuration other than expanding the memory allocation and setting up the WIFI.

I see several other posts that may be the same issue, so as a minimum this post can serve as additional feedback of a possible problem.

I had hoped to leave this system running 24/7 while I’m away for a few weeks but that may not be feasible with this issue. While I will continue to search the other posts for a recommended solution, I sure would appreciate any suggestions.

Thanks,
Dave K4DPF


#2

It is always a good thing to check the logs in /tmp/piaware.out to see if there is a connection problem or a power problem.
If you can ssh into your box just run “cat /tmp/piaware.out”.
We also display these logs on your personal ADSB stats page on FlightAware. Expand the “log” section.

Connection problems will show up as loss connections and retries.
Power problems will NOT show up in the logs but as the system just stopped with no further logs.

Wifi connection problems are mostly caused by the wifi dongle. We recommend the Edimax Wifi dongle (listed on the piaware build page) but you can use one of the recommended Wifi adapters
elinux.org/RPi_USB_Wi-Fi_Adapters

Power problems are tricky to solve. In most cases, the power adapter is not able to supply 5V. Higher quality supplies are able to supply more current and less of a drop in voltage. If you have a digital multimeter this is very easy to test. Also remember that the more current drawn the lower the voltage the power supply can give. It might start around 5V at idle but then drop below 4.8V when running programs.

On the older raspberry pi: Use TP 1 and TP 2 and it should read from 4.8 to 5.2 V.

On the RPi2 : Use PP3 and PP7 . These should read 4.8 to 5.2V.

The power usage:
RPi B – 200 to 400mA
RPi B+/ RPi 2 – 200 to 350mA
keyboards – 100mA to 600mA
Wifi adapters – 200mA to 1A
RTL dongle – 100mA to 300mA

Running an RPi + wifi + RTL dongle can use from 600mA to 1.5mA. Again… just plug everything in and check if you are 4.8V or higher.
If your system is very close to 5V then your system doesn’t have a power problem and probably something else causing the system to hang.
If your system is even close to 4.8V this can cause erratic crashes. You can try plugging in a power hungry keyboard or other device to push voltage down even more. Good way to test how close you are to a crash.


#3

Thanks so much for the reply. I will start working my way through your suggestions.

As for power supplies I have two separate wallwarts in the system. One powers only the RPi and the second powers the SDR and WIFI dongles. Will double check the voltage just in case.

Will post any results…even though it will be a few days before I can get back to it.

Many thanks,
Dave


#4

It’s worth bearing in mind that the quality of the cable from the power adaptor to the pi can have a big effect. A poor quality cable can make an otherwise OK power supply insufficient due to voltage drop over the cable. If it’s a particularly cheap adaptor, they tend to have very thin conductors which has a bigger effect on power loss as current increases. Try changing for a better quality cable, or better still a PSU that puts out slightly higher than 5V to overcome cable losses. I use this one which outputs 5.25V, and it resolved all the crashing problems I was having.


#5

How about measuring the voltage at the pins of the GPIO - see raspberrypi-spy.co.uk/2014/0 … nd-pinout/

Pin 6 to pin 2 or 4 should be 5v (careful don’t short the pins one to another)

(I’ve not tried this!!!)


Note the pin spacing is such that on old computer IDE drive cable fits, as do some other plugs with 0.1" spacing - might make it easier to connect the digital multimeter safely.


#6

Refer to this tweaks and it resolved the PiAware 3.5.3 lighttpd service hanging issue which result in hard reboot!

sudo nano /etc/lighttpd/conf-available/15-fastcgi-php.conf

— BOF15-fastcgi-php.conf —

-- depends: fastcgi --

/usr/share/doc/lighttpd/fastcgi.txt.gz

http://redmine.lighttpd.net/projects/lighttpd/wiki/Docs:ConfigurationOptions#mod_fastcgi-fastcgi

Start an FastCGI server for php (needs the php5-cgi package)

fastcgi.server += ( “.php” =>
((
“bin-path” => “/usr/bin/php-cgi”,
“socket” => “/var/run/lighttpd/php.socket”,
“max-procs” => 3,
“bin-environment” => (
“PHP_FCGI_CHILDREN” => “4”,
“PHP_FCGI_MAX_REQUESTS” => “500”
),
“bin-copy-environment” => (
“PATH”, “SHELL”, “USER”
),
“broken-scriptfilename” => “enable”
))
)
— EOF 15-fastcgi-php.conf —

sudo /etc/init.d/lighttpd restart && sudo /etc/init.d/lighttpd status