FlightAware Discussions

Piaware and pi a+ issue

Just bought a rpi 3a+ which I want run piaware on.
Downloaded the piaware image, moved it to the memory card using etcher as recommended and when I power it on, nothing happens.
It refuses to boot, only the red led light is constantly on and the screen connected to the hdmi only display the rainbow color thing.

Does anyone know how to fix this?

https://elinux.org/R-Pi_Troubleshooting#Coloured_splash_screen

Check this link please. Also are you sure you used Etcher like described in the guide?

Ok so after checking up on this you won’t be able to use the piaware image, it probably is based on a Raspbian version that is too old.
You can use https://www.raspberrypi.org/downloads/raspbian/ (stretch lite is recommended) and install the package version.

Or if you have another RPi handy you can update the piaware image on that with

sudo apt update
sudo apt dist-upgrade

And then use the sd-card in the new Raspberry pi

Rainbow screen hang generally indicates a bootloader problem. AFAIK the bootloader/kernel should be fine on a 3A+, but I don’t actually have one on hand to test with.

Does a standard Raspbian Lite image work?

(edit: Hm, ok, the 3A+ is newer than I thought; you’ll probably need to wait for a new piaware sdcard image or use the standard Raspbian image as suggested by wiedehopf)

Thanks for all of the replies.
As for your questions.

  1. Yes im sure that i used etcher, i even tried rufus but neither worked.
  2. I can use the standard lite image and i have tried to install piware through packages but somehow the website wont work.

As it looks right now, the 3 A+ is to new for the image and their packages, guess i have to wait a little while.

You are connected with ssh or access it locally via keyboard i guess?
Did you install both dump1090-fa and piaware?

I’m sure we will figure out the website, when you open the IP address in your browser does it display anything or what exactly does it say?

I got both ssh and local access with keyboard.
Yes i installed both, i followed the instruction to the letter on flight awares website.

When I enter the IP in the browser i simply get the “this page is reserved” thing for lighthttpd.

Oh i forgot the default page is under
IP/dump1090-fa/

If you want to change that you can take a look at the configuration files in
/etc/lighttpd/conf-enabled

I used an older Pi to upgrade the image install via apt-get, then put the sd card in the a+. Not sure if that only works with a Pi 3 though, or any pi will do.

Did you use a pi 3 or 3+ for the sd install?

Don’t think it really matters. The Raspberry Pi will upgrade to the latest kernel, which should support every model.

A Pi 3. Bit I guess @wiedehopf is right.

Unfortunately the PiAware SDCard image currently will not work on a Pi 3A+. We’re aware of the problem and working on a solution.

Has this been fixed in the 3.7.1 which was just release?

Yes, the 3.7.1 image should boot OK on a 3A+

Thank you, I can confirm that it works.

1 Like