FlightAware Discussions

Can't get image to work on piaware

i am new to this and trying to set up piaware. I used etcher to load my SD card, when I put it in my pi, it doesn’t load. I get this rainbow screen and it just sits there. any help would be greatly appreciated.

Rainbow screen generally means there’s a problem with the sdcard (the Pi is not booting past the very very early first steps). Try rewriting the image; try a different sdcard.

(I assume you’re using the PiAware sdcard image from PiAware - build your own ADS-B ground station for integration with FlightAware - FlightAware ?)

yes. and I have tried 2 different sd cards.

i have another card that is running pihole. is there a way to load piaware onto that sd card so they are running together?

What model pi are you using?

Have you tried downloading the image again? Maybe you have a corrupted download.

You may like to try the Raspberry Pi Imager program by Raspberry
Raspberry Pi Imager

In your case after its installed and running you need to scroll to the bottom use the last option “Use Custom”

image

tried Pi Imager with a fresh download and a different sd card. it is stuck in an endless loop with a QR code at the top of the screen that says no operating system, but no rainbow screen. I am using a raspberry pi 4 with 2 gig.

Try the same card in the other pi you have … to eliminate that as an issue?

Could also be that both sd-cards are counterfeit i suppose …
Or there’s an issue with the sd-card reader you use to write the image.

Or try to write a Raspi OS Lite image with the image … see if you get that running, you can always add on FA stuff.
Raspbian Lite: ADS B receiver · wiedehopf/adsb-wiki Wiki · GitHub

Maybe this boot diagnostic information may help you diagnose the problem:

I am really new with the Pi. is there a way to capture the boot diagnostic?

Other than photographing the screen, I don’t think so.