Piaware 7.1 RadarBox feeder

Hi,
Anyone suceed feeding radarbox within Piaware 7.1 ? Thanks!

 

Yes. Please see following post.
Scroll down to (5) RadarBox24 feeder

BONUS: Install other feeders on Raspi OS Bullseye

 

2 Likes

The install works, but only if you change the version manually in the install script.
abcd567 pointed already to the solution.

btw: This solution also works on other non-Raspbian installations like DietPi or Ubuntu

1 Like

Thanks! Works like a charm!

worked for me, thanks…

Looks like Radarbox changed their install script.

Today i reinstalled one of my devices with Bullseye and the install script ran through without editing it before.

This is a two fold action.
They have not only added Bullseye to their script, but have also added rbfeeder package for Bullseye in their repository.

This is the new code they have added to their script:

     bullseye)
        echo 'deb https://apt.rb24.com/ bullseye main' > /etc/apt/sources.list.d/rb24.list 
     ;;

 

 

Below is the part of their script which detects OS version, saves it into variable VERS, and then according to value stored in VERS, selects the appropriate repository file to be added to RPi’s folder /etc/apt/sources.list.d/

The subsequent command in script (i.e command apt-get install -y rbfeeder) installs rbfeeder from repository in file /etc/apt/sources.list.d/rb24.list

 

VERS=`lsb_release -c | awk -F ':' '{print $2}' | sed -e 's/^[[:space:]]*//' -e 's/[[:space:]]*$//'`


# Create a new debian repository source file
case "$VERS" in
    stretch)
        echo 'deb https://apt.rb24.com/ stretch main' > /etc/apt/sources.list.d/rb24.list
        ;;

     buster)
        echo 'deb https://apt.rb24.com/ buster main' > /etc/apt/sources.list.d/rb24.list
        ;;

     bullseye)
        echo 'deb https://apt.rb24.com/ bullseye main' > /etc/apt/sources.list.d/rb24.list
        ;;

     *)
        echo "Don't know how to install for a distribution named $DIST" >&2
        exit 1
esac

The Radarbox MLAT client doesn’t appear to be fixed yet

sudo apt-get install mlat-client -y returns this

That message shows, that another apt process is running. It can be started only once and has nothing to do with the availability of a package

You either have an automatic update currently running or a process got stuck.

If i am trying to run sudo apt install mlat-client i am only getting a “not found” message

@gavin323
If you get the above message mentioned by @foxhunter, this means their Bullseye repository still does not have mlat-client. In this case install it from my Github page linked below. Use option (1) Package for Raspi OS BULLSEYE (32-bit)

https://github.com/abcd567a/mlat-client-package/blob/master/README.md

 

I have tried that before, it returns an error

Did you read my comment? You do have an installation instance still running on your device.
check with
sudo ps -ef|grep dpkg

In the screen it also shows the pid 17186
You can kill it with
sudo kill -9 17186

But i would rather check why it is hanging and not simply kill a process without knowing the impact.

@gavin323

Reboot Pi to break the process which is keeping apt / dpkg stuck. Then try sudo apt install mlat-client

Also check availability of mlat-clent in RB24’s Bullseye repository by following command, and post output.

apt-cache policy mlat-client

 

If t’s an automatic upgrade/update, it starts over again before he is able to login.
But that would be the hardcore version.

Package mlat-client cannot be found

@gavin323

Then do this:

 

 

I don’t care about Radarbox MLAT :wink:

I was just helping with that thread.

This is OK if you don’t care for RB24 mlat. My post was actually meant for @gavin323 who cares and wants to install RB24 mlat :wink:

2 Likes

I am trying to get the mlat working for RadarBox and get the following data…
`pi@piaware:~ $ apt-cache policy mlat-client
mlat-client:
Installed: 0.2.11
Candidate: 0.2.11
Version table:
0.2.11 500
500 https://apt.rb24.com buster/main armhf Packages
*** 0.2.11 100
100 /var/lib/dpkg/status
pi@piaware:~ $ sudo apt install mlat-client
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
mlat-client : Depends: python3 (< 3.8) but 3.9.2-3 is to be installed
Depends: python3.7:any but it is not installable
E: Unable to correct problems, you have held broken packages.
pi@piaware:~ $
`

 

What is your OS?
Please post output of following commands:

uname -m   

lsb_release -sc  

cat /etc/os-release   

 

pi@piaware : ~ $ uname -m

armv7l

pi@piaware : ~ $ lsb_release -sc

bullseye

pi@piaware : ~ $ cat /etc/os-release

PRETTY_NAME=“Raspbian GNU/Linux 11 (bullseye)”

NAME=“Raspbian GNU/Linux”

VERSION_ID=“11”

VERSION=“11 (bullseye)”

VERSION_CODENAME=bullseye

ID=raspbian

ID_LIKE=debian

HOME_URL=“http://www.raspbian.org/

SUPPORT_URL=“RaspbianForums - Raspbian

BUG_REPORT_URL=“RaspbianBugs - Raspbian

pi@piaware : ~ $