FlightAware Discussions

Help Insstalling Radarbox client!

Hello all,

I know this is Flightaware but the Radarbox forums are lacking and I like it here better anyways!

I have a Pi3 that is currently feeding FA,RB24, and others just fine but I want to switch it to a Pi4 and install everything fresh. Every time I try to install the Radarbox feeder, it goes through some things and eventually says “rbfeeder package cannot be found” I’m not very good with linux/pi commands but I’ve searched and done all that i can think of and am a total loss. Anyone able to help? I’ve attached a screenshot of the terminal and it’s output when I run the install command. Thank you for all your help!

This error i had two days before.
There seem to be an issue with the key servers, that’s the message behind.

I was forcing the installation giving the instructions to ignore unsigned packages.
This needs to be fixed by Radarbox.

Was finally able to get it to install after scouring the net. You are right that its because of it being unsigned and Radarbox definitely needs to fix it. For anyone reading this that is having issues I used the following commands…

sudo apt-get update --allow-unauthenticated
sudo apt-get update --allow-insecure-repositories
sudo apt-get -y --allow-unauthenticated install rbfeeder

Please feel free to close thread!

Now you have it fixed you might want to revert back to only the authenticated and secure repositories. Otherwise you might have some security issues in the future :wink::face_with_monocle:

I would check the Airnav-Forum if somebody else has highlighted it. If not do it by yourself.
Maybe Radarbox isn’t yet aware of it.

Once they fixed it, simply run their installer again.

The Airnav forum was of little use. How do I revert back to only using secure repositories in the future?

The commands above should not change anything in your configuration but install the rbfeeder only.

You might want to clear the apt cache and remove the rbfeeder once they provide a fixed version.

The --allow-unauthenticated is a flag that will allow such packages only one time and it will be your command. It will not affect other future APT commands.

Thanks guys, I really appreciate it. There isn’t much help over at Airnav it seems. I emailed support almost a week ago and never heard anything. They did, however, feature my station on their blog for June so I guess that was nice. You can find it here…

https://www.radarbox.com/blog/airnav-radarbox-featured-ads-b-station-june-2021-matthew-mccutcheon