FlightAware Discussions

PiAware 6 is live

I’ve just upgraded my two worst sites (nothing meaningful there, just the location I’m at).
I didn’t attempt to update the existing, but rather ‘format and burn’ the new image.
Now I’m waiting for the magic to happen!!

Is it possible to permanently remove dump978-fa? given there is no 978 traffic anywhere near my sites

Not easily on a PiAware sdcard image (it would break the upgrade process, among other things). But dump978-fa doesn’t run unless you configure it to.

Ok, understand.
Would it be possible (in future update), for the 978 notification not to be displayed until it is configured?

Can you explain why you’d like that?

If Dump-978 isn’t displayed until it is configured (and a radio is present), it becomes a diagnostic tool in its own right.

Don’t get me wrong, I’m happy the code is there for those that can use it, but for most of the planet, it will never be enabled.

How do I update my RPi from V5.0 to 6.0?

I don’t want it to trash anything, as I’m also feeding FR24, so I guess just an update command?

My preferred method is to recover the config files, format the card (or start with a new card) and install clean.

1 Like

I’d rather not start from scratch, given my miniscule knowledge of RPis :laughing:

Then follow the instructions from abcd in this post ( step 1,2 and 3)

CAUTION: Do NOT use these scripts on Piaware SD Card image. It will break your installation.


HaHa! I understand and that’s one reason I find it easiest to start clean.

1 Like

Thank you Tom - I’ll give it a go :+1:

1 Like

Worked a treat :smiley: :smiley: :smiley:

One note, when doing step 2 allow to adapt the config file for dump1090-fa.
Otherwise you will stay with the v5 config file. The program will ask this, default answer is N(o) you should select (Y)es it will keep your own entries that have been made.
After reboot you can then enable adaptive gain via editing the config file.
Command is sudo nano /etc/default/dump1090-fa
set the option adaptive dynamic range from no to yes

1 Like

I did that :+1: I’ll try the adaptive gain next.

I have noticed that my message rate has halved since the update though!
I’m running a second RPi, still on V5.0 and that’s running fine still.

Give it some time, it will have to settle first. I thought I had a decrease as well but I have it running for 14 hrs now.
I can see some higher position reports and aircraft.

Adaptive gain will look for the best gain for your specific environment. It checks on an hourly basis ( at my systems).

1 Like

Yup, back to normal now and I’ve enabled auto-gain now too. Will compare it my second RPi running in parallel with manual gain.

A few users reported issues with MLAT/UDP Traffic:

I am impacted as well

We are aware of the MLAT UDP issues and are working on a fix.


Hi there

I have successfuly performed the upgrade to version 6.0 for PiAware.

For some reason my Dump 1090-fa version is showing dump1090-fa 5.0 bp09+1

Would someone who know more about these things than I kindly advise how to update dump1090-fa to 6.0 as well?

Many thanks

This is because your OS is Raspbian Stretch
bp09 = back port OS ver 09.

You can confirm Stretch and 09 by following command:

cat /etc/os-release