Piaware 3 NTP Time issues


#1

So I updated to Piaware 3. Fresh image downloaded from an official source on a Pi3. Only thing I adjusted in the configuration file was wifi.

The time will not update. I have to force it to update:

Sudo service ntp stop
Sudo ntpd -gq
#wait about 5 seconds for it to update and display time change
Sudo service ntp start

Then the time is set. Next time I reboot the time is off again. I’ve been thinking about adding a real time clock just so it works. No issues with this on piaware 2. . . I am tempted to use a raspbian image and install piaware 3 on top.

Any ideas? NTP servers are set correctly.

Thanks

Sent from my iPhone using Tapatalk Pro


#2

What does ntpq -p look like before you fix it? My test units work fine:



pi@piaware:~$ ntpq -p
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
+h88-150-253-182 143.210.16.201   3 u 1019  512   12    9.012   -0.684   0.056
 mail1.ugh.no    83.162.149.224   3 u 1434  512   64   11.920    0.762   0.125
*ntp1.warwicknet 195.66.241.10    2 u   86  512  377   10.580    0.825   0.279
+lyla.preshweb.c 130.159.196.117  3 u  409  512   61   10.614   -0.683   0.146


(you will have different servers since they come from a pool)

I would be interested to know if vanilla Raspbian works OK for you, because the PiAware image uses the standard Raspbian ntpd and ntp.conf, so if one works and not the other then it’s obviously not the NTP config itself causing the problem.


#3

ntpq -p output:

remote           refid      st t when poll reach   delay   offset  jitter

==============================================================================
10.0.0.5 .INIT. 16 u - 64 0 0.000 0.000 0.000

THis is weird…


#4

Maybe your DHCP server is handing out a ntp server address (that doesn’t actually work)?


#5

It is possible, but I’ve never had this issue before. Thats why I’m confused now. I have multiple other Pi’s and machines with no NTP issues.


#6

Same issue today with NTP not working. Date displays Aug 19th and unable to reset from GUI or command line.
Having IT check Firewall setting for any problems.


#7

I too am having issues with time setting after installing a Raspberry Pi 3B. This is the message I get;

•Anomaly report for PiAware feeder with a MAC address of b8:27:eb:7b:71:ea:
1.The system clock off by 189 days, 10 hours, 15 minutes. Please set your system clock to the correct time. Maybe try ‘sudo /etc/init.d/ntp restart’ or look into why ntpd has been unable to set the system clock to the correct time.

I have tried applying the command as it says to do but not avail. Time is still off, even when I go in a attempt to manually set the time, upon reboot the time is back to being off by the 189 days above.

I am more of a hardware guy and have no problem on that end, but my computer skills are limited. Any solutions would be greatly appreciated. I have tried most of the solutions on-line that I could understand, but then there are the complex command codes that I cannot make out like how many spaces in the command and what keys to use to get the correct characters. Not too savvy in that department.

I cannot set the date on the RPI3 when I try to set up without anything else connected, except for keyboard monitor and power.


#8

The Pi doesn’t have a RTC so this is fairly normal, you need a mechanism to set the date on reboot.

That said, the PiAware 3 image does include ntpd with the standard Raspbian setup, which uses the NTP pool servers (with the gotcha that if your DHCP server hands out a NTP server, that address replaces the pool config).

FWIW the OP’s problem is, I suspect, a DNS problem as I’ve seen it on FlightFeeders that are explicitly configured to ignore DHCP - something upstream is handing out a RFC1918 address for all DNS queries, perhaps the modem/router if its link is down, this is a terrible thing to do but some systems do it.


#9

I discovered the easy fix is to plug the unit into a LAN. Then set the time and do the command code as suggested. Worked without any problems.