PiAware 2.x software to be discontinued at the end of 2017


#1

If you are still using PiAware 2.x software, support for this version will be discontinued at the end of 2017.

Why is FlightAware doing this?

Currently less than 1.5% of all active PiAware sites are still on version 2.x. The data decoder in the PiAware suite has been greatly improved in PiAware 3, delivering more and better quality data then PiAware 2.x. FlightAware must allocate resources to continue supporting PiAware 2.x and these resources can be better used to develop and maintain PiAware 3.

How do I upgrade?

The easiest option is to re-image the SD card with the latest PiAware 3.x SD card version. Alternatively, you can perform a package upgrade only. For options and details on how to re-image or upgrade, please see the PiAware Upgrade page.

What happens if I don’t upgrade?

Your PiAware site will stop feeding data after the end of the year and you will no longer accumulate statistics data on the My ADS-B or global statistics pages. If you only have one site, then your account will no longer receive a free upgrade to the Enterprise Account level.

Does this mean I need new hardware?

No, absolutely not. You can, for example, continue to use a Raspberry Pi 2 running the latest PiAware 3 software. The versioning of the PiAware software is independent of the Raspberry Pi hardware versions.

What are the benefits of PiAware 3 software?

The PiAware 3 software includes the newer Skyview map user interface which is not available in PiAware 2. Furthermore, the improved data decoder in PiAware 3 software allows you to see more data in Skyview. We encourage you to read the PiAware 3 software announcement thread for complete details.

How do I tell which version of PiAware my site is using?

The easiest way to check is to click “My ADS-B” at the top of any page at flightaware.com. If you have more than one site, select the site that you want to check in the orange drop down list. In the “Site Information” section of the page, look in the right column for “Feeder Type.” The PiAware software version number will be displayed there.

If you need further assistance in upgrading from PiAware 2.x, please contact adsbsupport@flightaware.com.

Thank you for your support of the FlightAware ADS-B network!


#2