FlightAware Discussions

PI multiple locations and modesmixer2

Hello,
I have one FlightAware account and PI multiple locations. At this time I made only tests in very close locations but I’m planning to install a new PI in a location far 200 miles from the “primary” location. I use modesmixer2 to collect datas and is configured with my location (–location ), do you know how to manage 2 far locations inside modesmixer2? if I leave only my “master” location could be a problem?

Use a separate piaware for each location. You can have more than one site associated with your FlightAware account.

Please avoid feeding piaware from a combined feed to a single site - it causes various problems, primarily (1) unpredictable data delays and (2) data being discarded because it is implausibly far from the site location.

1 Like

Sorry, probably i didn’t describe well the situation: i already have different sites inside my flightaware account, so for this side of configuration i think all works and will works good. My question is about modeSmixer2 configuration because it seems to have the possibility to have several ip addresses for all PI you want to merge but only one geo coordinates, so finally my question is: in mm2 how to manage the location of several different PI?

You can scroll the ModeSMixer2 map to the location of other Pi. It will show the planes if you have added correct parameters for other Pi. However it would show coverage curve based on receiver location you have configured.

Alternatively, you can run two instances of mm2, each configured for different pi, with respective locations, and differdnt web ports (eg --web 8787 for feed from one Pi, and --web 8686 for other Pi).

What method you have used to install mm2? Running 2nd instance depends on how you have installed & configured it.

is a good idea to run two instances of mm2. I have installed mm2 in a different folder from the default, and actually the configuration is:

cmd /c modesmixer2.exe --web 8888 --inConnect 192.168.1.142:30005 --inConnect 192.168.1.142:30105 --outServer xxxxx:10001 --outConnect beast:xxxxxxx:41501 --location xx.xxx,yy…yyy --filter-nocountry

So, if i understand well, i can install another mm2 in a different folder and configure in the same way changing the inconnect ip to reach the other PI…and change the coordinates of location…

no need to install anything in another folder.
Just add one more batch file with a different name.

Assuming existing config file name is mm2A.bat
New file in same folder, name mm2B.bat

Contents of Existing file mm2A.bat
cmd /c modesmixer2.exe --web 8888 --inConnect 192.168.1.142:30005 --inConnect 192.168.1.142:30105 --outServer xxxxx:10001 --outConnect beast:xxxxxxx:41501 --location xx.xxx,yy…yyy --filter-nocountry

Contents of New file mm2B.bat
NOTE:
bbb.bbb.bbb.bbb is IP address of 2nd PI
--location bb.bbbb,cc.cccc is location of 2nd Pi
--web 7777 will display 2nd Pi’s map on port 7777

 
cmd /c modesmixer2.exe --web 7777 --inConnect bbb.bbb.bbb.bbb:30005 --inConnect bbb.bbb.bbb.bbb:30105 --outServer xxxxx:10001 --outConnect beast:xxxxxxx:41501 --location bb.bbbb,cc.cccc --filter-nocountry

1 Like

What would a connection look like between modemixer2 and piaware? I’m using modesdeco2 as inputs?
i have the inputs working good, i can see the combined output on mm2 web page. the goal is not having to change any parameters in 1090-fa or pi aware.

@hdphilip

  1. Where have you installed modesMixer2/modesDeco2, on RPi or on Windows?

  2. Irrespective of where you have installed modesMixer2/modesDeco2, you do NOT need to change parameters of dump1090-fa or piaware to feed data to modesMixer2/modesDeco2. All settings are done in config of modesMixer2 / modesDeco2.

it’s install on a raspberry pi, i disabled the “# dump1090-fa won’t automatically start unless ENABLED=no” to turn off the dump 1090-fa from feeding the pi aware.
here’s my conf of mm2

–inConnectId 192.168.1.102:31090:ADSB
–inConnectId 127.0.0.1:30105:MLAT
–inConnectId 127.0.0.1:30205:ADSB
–outServer fatsv:30002
–outServer beast:30104
–outConnect beast:localhost:30004
–location 38.24812:-121.30249
–web 8787
i was trying a few different values

It is confusing. The mm2 is mixer not decoder (mm2=modesMixer2). You have turned off dump1090-fa also. What decoder (or source of ADSB data) you have?

i’m using the modeSdeco2 as decoders, i can see the airplanes combined on the modemixer web server on port 8787
i was thinking i could use piaware as way to serve the service.
The purpose of 2 Rx’s is to have better over head coverage, rx number 2 will have a simple ground plane antenna with reduced gain

1 Like

@hdphilip

Your settings seem OK.
What I make out from your posts is like this:

  1. You have disabled dump1090-fa on both Pi1 & Pi2

  2. You have installed modesDeco2 on both Pi1 & Pi2

  3. On Pi1, modesDeco2 is configured to output raw data on port 30205

  4. On Pi2, modesDeco2 is configured to output raw data on port 31090

  5. You have modesMixer2 on Pi1
    It is configured to receive raw data from ports as follows:
    From Pi1
    –inConnectId 127.0.0.1:30105:MLAT
    –inConnectId 127.0.0.1:30205:ADSB

    From Pi2
    –inConnectId 192.168.1.102:31090:ADSB

Note: You missed the MLAT from Pi2. If you add following in modesMixer2 settings, you will see Pi2 Mlat also
–inConnectId 192.168.1.102:30105:MLAT

That is correct, P1 also has the Piaware installed on it also.

I think both Pi1 & Pi2 have piaware data feeder installed, am I right?

Pi2 does not have piaware installed,
The dongle will be moved to PI1 when the setup goes outside.

i’m thinking the outconnect and outserver on the modemixer are incorrect to feed piaware.

Oh, OK. I have misunderstood.

i just can’t find the port(s) piaware looks at

By default piaware looks for data in Beast binary format on localhost:30005 or 127.0.0.1:30005.

If you have data available at other than above noted location, then you have to change settings of piaware as follows:

oh, i see, the local map gets served from dump1090-fa? sounds like. and i’ve beed using the local map to see my airplanes. while in direct connection mode. I’d need to do the relayed connection sd card image. or install piaware on my other Pi2.

Thanks for your help
Philip

This is better. Avoid feeding one instance of piaware from two 1090 dongles on same Pi or two 1090 dongles on two different Pis. Flightaware discourages this. Am I right @obj?