Oracle VM with Pi aware on Windows


#1

Since we are all into experimenting, has anyone tried to use Pi aware on Oracle’s VM virtual Box?
I thought of trying to experimenting with VM but to use raspberry and applications like dumpvdl2. Of course like I have mentioed before, my Linux knowledge is about nil.


#2

@glennblum
.


#3

abcd567,
I have installed VM Virtual Box a while back and loaded it with raspberry to learn with. I stopped when I ordered my Pi3 piaware.
Please let me know what you come up with. I am downloading the .iso right now. the fastest I get is 11 hours until the download is done


#4

Try download by Torrent:

  1. Jessie:
    http://downloads.raspberrypi.org/rpd_x86/images/rpd_x86-2017-06-23/2017-06-22-rpd-x86-jessie.iso.torrent

  2. Stretch:
    http://downloads.raspberrypi.org/rpd_x86/images/rpd_x86-2017-12-01/2017-11-16-rpd-x86-stretch.iso.torrent

.
After installing Raspbian JESSIE, I installed dump1090-mutability and Piaware and FlightRadar24 feeder and Planefinder feeder.

I used adsb receiver project by J Prochazka to install all above.


#5

Piaware SD Card image is for Raspberry PI (CPU armhf).
It wont install on a computer with Intel x86 or amd x64 CPU.

On my Windows Desktop with Intel CPU, I have Downloaded and installed through VM the x86 version of Raspbian JESSIE, as shown in my FIRST POST above.


#6

working on it right now.


#7

JESSIE x86 or STRETCH x86 ?
I have tested successful installation of dump1090-mutability and Piaware data feeders using J Prochazka script on JESSIE x86. Did not try on STRETCH x86.


#8

Dump1090-mutable or dump1090-fa?


#9

Under the use of VM what ip address is used? I have no clue.


#10

dump1090-mutability.
If I recall correctly, the JProchazka script failed to build dump1090-fa x86 installation package.
May be I remember wrong. You may first try dump1090-fa, and if it fails, can install dump1090-mutability.


#11

Default is something like 10.0.0.1
You can find it by starting Jessie, then open terminal (see screenshot below) and type ifconfig and press Enter key.
In the output check value of inet addr

.
Oracle%20VM_Jessie%20x86%20rpd

.

For a router assigned address (something like 198.168.0.xx), which is accessible from network:
On main window click Settings >> On the pop-up window click Network, and choose “Attached to: Bridged Adapter” >> Press OK.

Changed Network Settings will be implemented only after Jessie is rebooted.

After reboot, open terminal on Jessie, give command ifconfig, and in the output find IP address assigned by router by reading value of inet addr:
.

.
.

Oracle%20VM%20-%20Network%20Settings


#12

The other bad part is I cant get copy and paste to work.


#13

.

Neither could I, even though I tried ALL settings shown in screenshot below.
I now access it by PuTTY installed on my Windows host computer. PuTTY allows me copy-paste.
.

Oracle%20VM%20-%20Clipboard%20Settings


#14

All is installed and all instructions have been followed. I typed in the address and the webpage shows up but no data, I dont think that my dump1090 is not working.


#15

To see dump1090-mutability web page: ip-of-Jessie/dump1090/gmap.html
If it still does not show then

  1. Clear browser cache (Ctrl + Shift + Delete)
  2. Reload Browser (Ctrl + F5)

To check dump1090-mutability
sudo systemctl status dump1090-mutability

Have you plugged-in Pro Stick into your Windows computer? If yes, then enable it as shown below.

SCREENSHOT 1 of 2

.

SCREENSHOT 2 of 2
VM-Raspbian%20x86%20-%2025


#16


#17

I get this, what do you get?
(Use PuTTY to copy-paste commands)

pi@raspberry:~ $ ls adsb-receiver/build/dump1090-mutability
dump1090
dump1090-mutability_1.15~dev_i386.changes
dump1090-mutability_1.15~dev_i386.deb
package-archive

#18

its working now. When addressing the USB input I didnt have it completely set up.


#19

Are you using dump1090-mutability with its default settings (i.e. use Dongle plugged into Windows computer), or configured dump1090-mutability to --net-only and receive input on network?


#20

I have it set for dongle plugged into computer.