No SSH on 8.2?

After upgrading to 8.2 by installing a fresh image, I added the empty SSH file to the /boot directory before replacing the SDcard in the raspberry pi. That has always worked in the past, but I cannot get SSH to work on a fresh 8.2 install. Because of the receiver location, headless operation is a must for me. Any suggestions?

1 Like

SSH into my Pi Zero works fiine with 8.2.

Good luck!

J

The few times I’ve had this problem I was using the wrong password.

I’m not sure if this applies to installing the FA image install, bit if you went installed the os directly using Raspberry Pi Imager and then planned to do a package install, the way that ssh is enabled has changed - it needs to be enabled before you write the os to the SD card:

image

Click the gear wheel
image

Hi,

Did you create a file called “SSH” as you posted, or a file called “ssh” in the /boot directory? Linux is case-sensitive for file names, and that might be the issue.

It looks like one of your systems is using the sd-card install:
Feeder Type: PiAware (SD Card) 7.2

It looks like your new install has switched to the package install method:
Feeder Type: PiAware (Debian Package Add-on) 8.2

That means the user/pass for your new system is not the FA standard user/pass, but whatever you set when installing the OS image, before adding the FA package.

I checked, and the standard Pi OS install still seems to enable ssh as you mentioned, but note the lower-case “ssh” file name.


For headless setup, SSH can be enabled by placing a file named ssh, without any extension, onto the boot partition of the SD Card. When the Raspberry Pi boots, it looks for the ssh file. If it is found, SSH is enabled and the file is deleted. The content of the file does not matter; it could contain text, or nothing at all.

Good luck,
-Dan

Edit: I copied the wrong note above the first time. Corrected.

@MC130E I thought I would check that I hadn’t been following an unnecessary procedure, so I just flashed a SD card using the Raspi Imager to create a 32 bit Bullseye Lite image and did not set up a user/ssh as I suggested above. I then added a file called ssh to the boot partition and used the card to boot a headless raspi 4.

Previously you would then ssh in with username pi and password raspberry. However, thevuser pi and password raspberry combination is no longer created - so this is what you get:

jrg@MBPro2021 ~ % ssh pi@192.168.124.106
Please note that SSH may not work until a valid user has been set up.

See http://rptl.io/newuser for details.
pi@192.168.124.106's password: 
Permission denied, please try again.
pi@192.168.124.106's password: 

If you follow the http://rptl… link you get to:
https://www.raspberrypi.com/news/raspberry-pi-bullseye-update-april-2022/

Scroll down to the Headless setup heading. This covers using the Raspberry Pi Imager and also provides another method which doesn’t involve Imager but looks a lot more complicated - I’ve never tried it.

Thank everyone for the help. Everything is working now. I downloaded a fresh copy of the piaware-sd-card image file and loaded it onto a different sdcard using a different sdcard writer.

My previous Feeder Type: PiAware (SD Card) 7.2 now reads 8.2 and has ssh working.

1 Like

I’ve installed a couple of 8.2 SD card images in the last month. I used the method of adding an empty file called ssh in the boot partition of the SD card after writing the image.

To log in the username is pi and the default password is flightaware. This is detailed in the file PiAwareSetupGuide.pdf which is contained inside the the piaware-sd-card-8.2.img.zip file.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.