FlightAware Discussions

New install

Good evening,

I am trying to install the new Flightaware feeder. After several times I see this after using sudo apt-get install piaware
~To me it looks like the software cannot be installed. I tried to install the 3.8 version.

Any ideas and help is much appreciated. Tried to contact the Flightaware helpdesk, but no succes.

Thanks

pi@raspberrypi:~ $ sudo apt-get install piaware
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
piaware : Depends: libboost-filesystem1.67.0 but it is not installable
Depends: libboost-program-options1.67.0 but it is not installable
Depends: libboost-regex1.67.0 (>= 1.67.0-10) but it is not installable
Depends: libboost-system1.67.0 but it is not installable
Depends: libc6 (>= 2.28) but 2.24-11+deb9u3 is to be installed
Depends: libssl1.1 (>= 1.1.1) but 1.1.0f-3+deb9u2 is to be installed
E: Unable to correct problems, you have held broken packages.

You installed the Buster repository package on Raspbian Stretch.

If you’re using stretch, install the stretch repository package.

Thank you for the reply. did as the website suggests. Please see attachment. Same result

What do these commands show?

$ cat /etc/os-release
$ apt-cache policy piaware-repository
$ apt-cache policy piaware
$ apt-cache policy libboost-filesystem1.67.0

Thanks for the reply.
This it what I see
pi@raspberrypi : **~ ** cat /etc/os-release

-bash: $: command not found

pi@raspberrypi : ~ $ cat /etc/os-release

PRETTY_NAME=“Raspbian GNU/Linux 9 (stretch)”

NAME=“Raspbian GNU/Linux”

VERSION_ID=“9”

VERSION=“9 (stretch)”

ID=pi24-raspbian

ID_LIKE=debian

HOME_URL=“http://www.raspbian.org/

SUPPORT_URL=“http://www.raspbian.org/RaspbianForums

BUG_REPORT_URL=“http://www.raspbian.org/RaspbianBugs

pi@raspberrypi : ~ $ apt-cache policy piaware-repository

piaware-repository:

Installed: 3.8.0~bpo9+1

Candidate: 3.8.0

Version table:

3.8.0 500

500 http://flightaware.com/adsb/piaware/files/packages buster/piaware armhf Packages

*** 3.8.0~bpo9+1 500

500 http://flightaware.com/adsb/piaware/files/packages stretch/piaware armhf Packages

100 /var/lib/dpkg/status

pi@raspberrypi : ~ $ apt-cache policy piaware

piaware:

Installed: (none)

Candidate: 3.8.0

Version table:

3.8.0 500

500 http://flightaware.com/adsb/piaware/files/packages buster/piaware armhf Packages

3.8.0~bpo9+1 500

500 http://flightaware.com/adsb/piaware/files/packages stretch/piaware armhf Packages

pi@raspberrypi : ~ $ apt-cache policy libboost-filesystem1.67.0

libboost-filesystem1.67.0:

Installed: (none)

Candidate: (none)

Version table:

pi@raspberrypi : ~ $

Somehow you have both the stretch and buster repositories configured, probably as a result of using the buster install steps in the past.

please try:

sudo apt-get remove --purge piaware-repository piaware
sudo rm /etc/apt/source.list.d/piaware*.list

then repeat the stretch install steps. Be sure you do the “update” step.

Alternatively, start afresh with a Raspbian Buster image if you don’t have anything else on the Pi that you need to preserve. Stretch is out of date now.

Hello Obj,

I started all over. Formatted my sd card on my Mac and formatted it into MS-Dos.
Reinstalled as described.
Now I want to access my Pi, I know I had to created a file ssh as I did in the tgterminal window.
I tried to log in with ssh pi@192.168.xxx.xx used the password as described here"
Enable SSH access

For security reasons, SSH access is disabled by default on new PiAware SD card

installs, starting with version 3.3. To enable SSH, create an empty file on the /boot

partition of the SD card with the filename of “ssh” only (no file extension). When

this file is present, SSH will be automatically enabled. The default login is “pi” and

password “flightaware” to connect via SSH.

But for some reason I see this when I try to use the password:

Permission denied, please try again.

ssh pi@192.168.xxx.xx’s password:

after retrying it says something about public key

Any ideas?

Thanks

Well which image did you use?

Did you put the file named ssh on the boot partition?

Copy pasting a guide isn’t useful.
You need to describe what you actually did …

Because if you followed the guide correctly, it would be working.
Well at least i’m not aware of any issues with the functionality.

I formatted my. sd card. into Ms Dos format
Downloaded the piaware-sd-card 3.8.0.img
Flashed it with Balenaetcher
Add a ssh file to the boot on the sd card in the Terminal window on my Mac.
Inserted the sd card into my Pi, could see it was claimed as new feeder ( new sharing key)
I am able to access 192.168.xxx.xx/dump1090
So it feeder is running.
Now I want to access the pi to install the other feeders, used ssh pi@192.168.xxx.xx
After asking for the password I gave flightaware, withe the result access denied
Hope this helps

Could you show the exact command you used?

You can always remove power and put the sd-card into the Mac again.
Then check in the file explorer if the ssh file is present.

Edit:
On second thought:
If it says access denied, ssh is already enabled, so disregard all the above.
The issue is the credentials you give.

Do you know why it needs the colon?
That’s kinda strange.

This is normal when connecting to a new ssh server. It alerts you that it’s a system that’s not recognised yet - in an environment where this is important you would double check the key is correct to make sure you aren’t connecting to the wrong system, so if you get this prompt unexpectedly later you check to see that there hasn’t been some kind of security breach.

Are you using Mac terminal to ssh from? If so, try this:

ssh pi:@192.168.x.x

Note the colon before the @ sign.

Thank you for the reply. Yes I try to connect with ssh on my Mac. Go-> connect to server

this is the result
There was a problem connecting to the server 192.168.xxx.xx The server may not exist or it in unavailable at this time

It’s basically a blank password and should force it to use password authentication, eg

ssh pi:raspberry@192.168.x.x

Alternatively you can do:

ssh -o PreferredAuthentications=password pi@192.168.0.x.x

If that doesn’t work and the password is being entered accurately, then the output of ssh -vvv would be useful

You need to use the correct IP address for your pi. It might help to allocate a fixed one in your router settings if it’s changing when you power off and on.

Are you sure that’s ssh?
Which application are you using?

I did that a long Tim e ago.:slight_smile:

I go to finder-> go-> connect to server and that is the same way I always did and The newer OS for Mac do offer the ssh service

Try opening terminal and typing the ssh command as I put above instead of using Connect to server.

Also you don’t need to blank out 192.168.x.x addresses as they aren’t routable outside your own network so no one can connect to them externally.

Thank you very much for the reply.

I did as you said. ssh pi:raspberry@192.168.178.30 . This is the outcome

marjaenbert@MBPvanMjaenBert ~ % ssh pi:raspberry@192.168.178.30

pi:raspberry@192.168.178.30’s password:

Linux piaware 4.19.75-v7+ #1270 SMP Tue Sep 24 18:45:11 BST 2019 armv7l

The programs included with the Debian GNU/Linux system are free software;

the exact distribution terms for each program are described in the

individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent

permitted by applicable law.

SSH is enabled and the default password for the ‘pi’ user has not been changed.

This is a security risk - please type ‘passwd’ to set a new password.

pi@piaware : ~ $

Is it possible to add the other feeders form here?

Thanks
Bert

Oh you logged in using raspberry as the password? I wasn’t expecting that to work since you said you are using the piaware image - it was just an example in my reply to wiedehopf.

In that case then yes you add other feeders from the command prompt.