New install Piaware 7.1

I have installed and been able to track traffic, very simple setup. I have NOT been successful at connecting to the flightaware server.

I have tried port forwarding 30005, however I can’t find any troubleshooting tips OR better yet a simple walkthrough of connecting. I can see the site picks up my public IP, so that is working. I am not sure why i am not able to connect.

ANY help appreciated.

Port 30005 is local to the piaware. Flight aware uses TCP 1200 and I think some UDP ports

netstat -a | grep ESTAB
Will show you the established TCP connections.

Have you claimed your receiver? PiAware - Claim and Link a Brand New PiAware Ground Station - FlightAware

What does
piaware-status and sudo systemctl status piaware.service
show? Remove your unique feeder ID from the output.

Ok… that is helpful. I’ll look at the netstat outputs, have not got that far into it yet. At the moment, yes I am collecting flight data,

and I have already made sure the services were up, but I’ll check again. Never know :wink: THAN YOU for the help and time. Q: is there a resource for the ports / protocol? that need to be opened on the firewall?

Check out

For some of the details.

Also there are the github pages

1 Like

Ya… still opened 1200 and just looking at netstat, but still not finding flightaware? weird

Netstat will only show you a connection if there is a connection, and I think we already established that there is no connection.

What does /var/log/piaware.log say? That is the first place to look if there are connection problems.

So… the piaware log shows:

and netstat -a | grep ESTAB


Ended up finally getting it. I was trying to use both interfaces (is what I think happened) but to be honest not sure.

So… worked for a bit. Now back down, had a power bump :frowning: well maybe someone unplugged the RPi :open_mouth: NOW can’t connect again? Do I need to reclaim the connection?

Once it’s claimed you don’t need to reclaim it.

Just check the log again.
I’d guess you have set up your networking wrong … maybe describe if you set up a static IP or something else than the default DHCP?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.