FlightAware Discussions

New Flightaware Prostick Plus - now no signals


#1

I just got my new Flighware Prostick Plus and hooked it all up to my Pi3. Lots of signals for about an hour, but then suddenly nothing. It was working fine with my old standard dongle, and for about an hour after I installed the Prostick.

When I look at “My ADSB” the PiAware and FlightAware are both green - MLAT is red.

Here is the message in Log:

[2018-11-05 10:30 CST] no ADS-B data program seen listening on port 30005 for 10 seconds, next check in 60s
[2018-11-05 10:30 CST] no ADS-B data program is serving on port 30005, not starting multilateration client yet
[2018-11-05 10:31 CST] 0 msgs recv’d from dump1090 (0 in last 5m); 0 msgs sent to FlightAware

I have rebooted and restarted everything, but nothing. I have also verified I have the right type of SMA connector.

Its just really weird because it worked really well for about an hour, then just stopped.

Any ideas?


#2
journalctl -u dump1090-fa -e

Please show the output of this command.

It looks like dump1090-fa is just not running.

Could also be the prostick needs more power and your power supply is insufficient.
Also try a different usb port that sometimes helps with the connection.


#3

Good ideas - I did start feeding with POE, that should feed 2.4 amps to the pi. I will try just plugging it in directly and see if that works. Still doesn’t really explain why it would work for a while and then just quit.

I’m not at home right now, but sent a restart from Flightaware of the dump1090 and here is what I got in the log:

[2018-11-05 10:36 CST] manual update (user-initiated via their flightaware control page) requested by adept server
[2018-11-05 10:36 CST] performing manual update, action: restart_dump1090
[2018-11-05 10:36 CST] attempting to restart dump1090…
[2018-11-05 10:36 CST] attempting to restart dump1090-fa using ‘systemctl --no-block try-restart dump1090-fa.service < /dev/null’…
[2018-11-05 10:36 CST] dump1090 restart appears to have been successful
[2018-11-05 10:36 CST] update request complete
[2018-11-05 10:36 CST] no ADS-B data program is serving on port 30005, not starting multilateration client yet

I will try your command tonight when I am at home and see what I get and report back.

Thanks!


#4

That’s the thing with power issues … it can depend on temperature and where the wind is blowing from outside :stuck_out_tongue_winking_eye:


#5

I would check also the ID number associated with that dongle.
It happened to me too when I was changing dongles to have one switch from ID 0 to 1 and back to 0 at reboot. This was with the Piaware add on and ADS-B project script.
I edited the dump1090-fa config file to match.
Sudo nano /etc/default/dump1090-fa


#6

But if you reboot and only have one dongle in there it will be at index 0 and just work.


#7

Yes. That was when I was swapping the dongle for UAT.
BTW, the default power supply that came with the Pi was sufficient when it was 32C in the garage, feeding the Pi and two FA dongles.


#8

Good thoughts - I will look at that. It was working great, I don’t think it rebooted. Would it switch without a reboot?


#9

Then reboot it.
Easiest way to exclude such problems.

When messing with the USB dongle it’s always a good idea to reboot.